Bug 261251 - terminating application causes crash
Summary: terminating application causes crash
Status: RESOLVED FIXED
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-25 21:40 UTC by Francesco
Modified: 2011-03-24 01:19 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francesco 2010-12-25 21:40:26 UTC
Application: ksysguard (4.4.2 (KDE 4.4.2))
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
Firefox was in loop with javascript, so I killed it from System Monitor, but this killed System monitor too.

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7761710 (LWP 7887))]

Thread 2 (Thread 0xb74e6b70 (LWP 7888)):
#0  0x003327d4 in __pthread_mutex_unlock_usercnt () from /lib/libpthread.so.0
#1  0x009c1fa6 in pthread_mutex_unlock () from /lib/libc.so.6
#2  0x033dcfee in g_main_context_prepare () from /lib/libglib-2.0.so.0
#3  0x033dd279 in ?? () from /lib/libglib-2.0.so.0
#4  0x033ddba7 in g_main_loop_run () from /lib/libglib-2.0.so.0
#5  0x02b9b6b4 in ?? () from /usr/lib/libgio-2.0.so.0
#6  0x0340448f in ?? () from /lib/libglib-2.0.so.0
#7  0x0032ecc9 in start_thread () from /lib/libpthread.so.0
#8  0x009b469e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7761710 (LWP 7887)):
[KCrash Handler]
#7  QModelIndex (this=0x9294fe4, child=...) at ../../include/QtCore/../../src/corelib/kernel/qabstractitemmodel.h:65
#8  QSortFilterProxyModel::parent (this=0x9294fe4, child=...) at itemviews/qsortfilterproxymodel.cpp:1656
#9  0x036e803d in parent (this=0x93623bc) at kernel/qabstractitemmodel.h:389
#10 QPersistentModelIndex::parent (this=0x93623bc) at kernel/qabstractitemmodel.cpp:347
#11 0x05c023a0 in isValid (this=0x9270b08, parent=..., start=210, end=210) at itemviews/qitemselectionmodel.h:108
#12 QItemSelectionModelPrivate::_q_rowsAboutToBeInserted (this=0x9270b08, parent=..., start=210, end=210) at itemviews/qitemselectionmodel.cpp:747
#13 0x05c0540a in QItemSelectionModel::qt_metacall (this=0x9264000, _c=QMetaObject::InvokeMetaMethod, _id=17, _a=0xbfb5b5d0) at .moc/release-shared/moc_qitemselectionmodel.cpp:138
#14 0x036fb8ca in QMetaObject::metacall (object=0x9264000, cl=153399200, idx=17, argv=0xbfb5b5d0) at kernel/qmetaobject.cpp:237
#15 0x0370e6ad in QMetaObject::activate (sender=0x9294fe4, m=0x3828198, local_signal_index=4, argv=0x74) at kernel/qobject.cpp:3280
#16 0x0375f41f in QAbstractItemModel::rowsAboutToBeInserted (this=0x9294fe4, _t1=..., _t2=210, _t3=210) at .moc/release-shared/moc_qabstractitemmodel.cpp:174
#17 0x036edc95 in QAbstractItemModel::beginInsertRows (this=0x9294fe4, parent=..., first=210, last=210) at kernel/qabstractitemmodel.cpp:2396
#18 0x05c3a92c in QSortFilterProxyModelPrivate::insert_source_items (this=0x924afa0, source_to_proxy=..., proxy_to_source=..., source_items=..., source_parent=..., orient=Qt::Vertical, emit_signal=true) at itemviews/qsortfilterproxymodel.cpp:681
#19 0x05c3ac8f in QSortFilterProxyModelPrivate::source_items_inserted (this=0x924afa0, source_parent=..., start=210, end=210, orient=Qt::Vertical) at itemviews/qsortfilterproxymodel.cpp:804
#20 0x05c3b09f in QSortFilterProxyModelPrivate::_q_sourceRowsInserted (this=0x924afa0, source_parent=..., start=210, end=210) at itemviews/qsortfilterproxymodel.cpp:1278
#21 0x05c3d4af in QSortFilterProxyModel::qt_metacall (this=0x9294fe4, _c=QMetaObject::InvokeMetaMethod, _id=12, _a=0xbfb5b8f0) at .moc/release-shared/moc_qsortfilterproxymodel.cpp:135
#22 0x003de11a in ProcessFilter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libprocessui.so.4
#23 0x036fb8ca in QMetaObject::metacall (object=0x9294fe4, cl=153399200, idx=0, argv=0x9294fe4) at kernel/qmetaobject.cpp:237
#24 0x0370e6ad in QMetaObject::activate (sender=0x9294fd8, m=0x3828198, local_signal_index=5, argv=0x74) at kernel/qobject.cpp:3280
#25 0x0375f3bf in QAbstractItemModel::rowsInserted (this=0x9294fd8, _t1=..., _t2=210, _t3=210) at .moc/release-shared/moc_qabstractitemmodel.cpp:181
#26 0x036eebf3 in QAbstractItemModel::endInsertRows (this=0x9294fd8) at kernel/qabstractitemmodel.cpp:2413
#27 0x003e43fe in ?? () from /usr/lib/libprocessui.so.4
#28 0x036fb8ca in QMetaObject::metacall (object=0x925ad78, cl=153399200, idx=0, argv=0x925ad78) at kernel/qmetaobject.cpp:237
#29 0x0370e6ad in QMetaObject::activate (sender=0x9271538, m=0x1c7cc0, local_signal_index=2, argv=0x74) at kernel/qobject.cpp:3280
#30 0x001bcac7 in KSysGuard::Processes::endAddProcess() () from /usr/lib/libprocesscore.so.4
#31 0x001bdc47 in KSysGuard::Processes::addProcess(long, long) () from /usr/lib/libprocesscore.so.4
#32 0x001bead9 in KSysGuard::Processes::updateOrAddProcess(long) () from /usr/lib/libprocesscore.so.4
#33 0x001befe2 in KSysGuard::Processes::processesUpdated() () from /usr/lib/libprocesscore.so.4
#34 0x001bf2c3 in KSysGuard::Processes::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libprocesscore.so.4
#35 0x036fb8ca in QMetaObject::metacall (object=0x9271538, cl=153399200, idx=0, argv=0x9271538) at kernel/qmetaobject.cpp:237
#36 0x0370e6ad in QMetaObject::activate (sender=0x925bfd8, m=0x1c7e30, local_signal_index=0, argv=0x74) at kernel/qobject.cpp:3280
#37 0x001c5957 in ?? () from /usr/lib/libprocesscore.so.4
#38 0x001c2b15 in ?? () from /usr/lib/libprocesscore.so.4
#39 0x001bccb0 in KSysGuard::Processes::updateAllProcesses(long, QFlags<KSysGuard::Processes::UpdateFlag>) () from /usr/lib/libprocesscore.so.4
#40 0x003df21e in ProcessModel::update(long, QFlags<KSysGuard::Processes::UpdateFlag>) () from /usr/lib/libprocessui.so.4
#41 0x003d317a in KSysGuardProcessList::updateList() () from /usr/lib/libprocessui.so.4
#42 0x003d94f3 in KSysGuardProcessList::killSelectedProcesses() () from /usr/lib/libprocessui.so.4
#43 0x003db360 in KSysGuardProcessList::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libprocessui.so.4
#44 0x036fb8ca in QMetaObject::metacall (object=0x92512f0, cl=153399200, idx=3, argv=0x0) at kernel/qmetaobject.cpp:237
#45 0x0370e6ad in QMetaObject::activate (sender=0x9261b98, m=0x5f62704, local_signal_index=2, argv=0x74) at kernel/qobject.cpp:3280
#46 0x05d3f019 in QAbstractButton::clicked (this=0x9261b98, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:206
#47 0x059feff9 in QAbstractButtonPrivate::emitClicked (this=0x9296f00) at widgets/qabstractbutton.cpp:546
#48 0x05a006f4 in QAbstractButtonPrivate::click (this=0x9296f00) at widgets/qabstractbutton.cpp:539
#49 0x05a009ae in QAbstractButton::mouseReleaseEvent (this=0x9261b98, e=0xbfb5c780) at widgets/qabstractbutton.cpp:1121
#50 0x0562ee08 in QWidget::event (this=0x9261b98, event=0xbfb5c780) at kernel/qwidget.cpp:8187
#51 0x059fee9e in QAbstractButton::event (this=0x9261b98, e=0x9294fe4) at widgets/qabstractbutton.cpp:1080
#52 0x05aacc22 in QPushButton::event (this=0x9261b98, e=0xbfb5c780) at widgets/qpushbutton.cpp:683
#53 0x055d0fdc in QApplicationPrivate::notify_helper (this=0x906ff28, receiver=0x9261b98, e=0xbfb5c780) at kernel/qapplication.cpp:4396
#54 0x055d7c2e in QApplication::notify (this=0x906fe98, receiver=0x9261b98, e=0xbfb5c780) at kernel/qapplication.cpp:3959
#55 0x0102868a in KApplication::notify (this=0x906fe98, receiver=0x9261b98, event=0xbfb5c780) at ../../kdeui/kernel/kapplication.cpp:310
#56 0x036f5b3b in QCoreApplication::notifyInternal (this=0x906fe98, receiver=0x9261b98, event=0xbfb5c780) at kernel/qcoreapplication.cpp:732
#57 0x055d6094 in sendEvent (receiver=0x9261b98, event=0xbfb5c780, alienWidget=0x9261b98, nativeWidget=0x9242390, buttonDown=0x5f6b3c0, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#58 QApplicationPrivate::sendMouseEvent (receiver=0x9261b98, event=0xbfb5c780, alienWidget=0x9261b98, nativeWidget=0x9242390, buttonDown=0x5f6b3c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3058
#59 0x05664d10 in QETWidget::translateMouseEvent (this=0x9242390, event=0xbfb5cc9c) at kernel/qapplication_x11.cpp:4403
#60 0x05664151 in QApplication::x11ProcessEvent (this=0x906fe98, event=0xbfb5cc9c) at kernel/qapplication_x11.cpp:3414
#61 0x0569336a in x11EventSourceDispatch (s=0x9073168, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#62 0x033d9855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#63 0x033dd668 in ?? () from /lib/libglib-2.0.so.0
#64 0x033dd848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#65 0x03724565 in QEventDispatcherGlib::processEvents (this=0x905b6c8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#66 0x05692be5 in QGuiEventDispatcherGlib::processEvents (this=0x905b6c8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#67 0x036f4609 in QEventLoop::processEvents (this=0xbfb5cf94, flags=) at kernel/qeventloop.cpp:149
#68 0x036f4a8a in QEventLoop::exec (this=0xbfb5cf94, flags=...) at kernel/qeventloop.cpp:201
#69 0x036f900f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#70 0x055cfe07 in QApplication::exec () at kernel/qapplication.cpp:3672
#71 0x002ee6c7 in kdemain () from /usr/lib/libkdeinit4_ksysguard.so
#72 0x0804860b in _start ()

This bug may be a duplicate of or related to bug 236382.

Possible duplicates by query: bug 238819, bug 236382, bug 227475, bug 221078.

Reported using DrKonqi
Comment 1 John Tapsell 2011-03-24 01:10:14 UTC
Git commit 846700f962b803b5efc75d520265fc6408b699c1 by John Tapsell.
Committed on 24/03/2011 at 00:30.
Pushed by johnflux into branch 'master'.

Fix crash when killing a process

BUG:269094
BUG:261251

M  +7    -3    libs/ksysguard/processui/ksysguardprocesslist.cpp     

http://commits.kde.org/kde-workspace/846700f962b803b5efc75d520265fc6408b699c1
Comment 2 John Tapsell 2011-03-24 01:19:22 UTC
Git commit fc5993dde16f7403f10e171d13193a0db9473aaf by John Tapsell.
Committed on 24/03/2011 at 00:30.
Pushed by johnflux into branch 'KDE/4.6'.

Fix crash when killing a process

BUG:269094
BUG:261251

M  +7    -3    libs/ksysguard/processui/ksysguardprocesslist.cpp     

http://commits.kde.org/kde-workspace/fc5993dde16f7403f10e171d13193a0db9473aaf