Bug 261211 - Corrupted Akregator archive causes Kontact to crash
Summary: Corrupted Akregator archive causes Kontact to crash
Status: RESOLVED DUPLICATE of bug 116482
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-25 09:45 UTC by Thomas Tanghus
Modified: 2010-12-25 11:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (8.45 KB, text/plain)
2010-12-25 09:59 UTC, Thomas Tanghus
Details
Excerpt from ~/.xsession-errors (67.46 KB, text/plain)
2010-12-25 10:01 UTC, Thomas Tanghus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Tanghus 2010-12-25 09:45:42 UTC
Application: kontact (4.4.9)
KDE Platform Version: 4.5.90 (4.6 RC1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

I had just started Kontact (which started with showing the Contacts even though they were not the last part I used and they are non-functional because akonadiserver reports protocol 27 but 28 is expected but that's another bugreport to come ;)
I switched to Mail, then to Akregator to get it to load the feeds, then back to Mail, and Crash...

15 minutes earlier I had to do a hard reboot because after upgrading to 4.6 RC1 the system suddenly think it should suspend/sleep but couldn't wake up the monitor again. This could have resulted in file corruption in Akregators metakit(?) backend? I've yet to test that.

-- Backtrace:
Application: Kontact (kontact), signal: Aborted
[Current thread is 1 (Thread 0xb77e6730 (LWP 4336))]

Thread 2 (Thread 0xb0863b70 (LWP 4405)):
#0  0x007a1f76 in pthread_mutex_unlock (mutex=0xab51fdc) at forward.c:184
#1  0x043e809c in g_main_context_query () from /lib/libglib-2.0.so.0
#2  0x043ed2c4 in ?? () from /lib/libglib-2.0.so.0
#3  0x043ed848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x0264b59f in QEventDispatcherGlib::processEvents (this=0xab1e948, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#5  0x0261b609 in QEventLoop::processEvents (this=0xb0863270, flags=) at kernel/qeventloop.cpp:149
#6  0x0261ba8a in QEventLoop::exec (this=0xb0863270, flags=...) at kernel/qeventloop.cpp:201
#7  0x02517b7e in QThread::exec (this=0xaac2128) at thread/qthread.cpp:490
#8  0x025fa35b in QInotifyFileSystemWatcherEngine::run (this=0xaac2128) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x0251adf9 in QThreadPrivate::start (arg=0xaac2128) at thread/qthread_unix.cpp:266
#10 0x0249dcc9 in start_thread (arg=0xb0863b70) at pthread_create.c:304
#11 0x0079469e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb77e6730 (LWP 4336)):
[KCrash Handler]
#7  0x00ae3416 in __kernel_vsyscall ()
#8  0x006ee941 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#9  0x006f1e42 in abort () at abort.c:92
#10 0x00726305 in __libc_message (do_abort=2, fmt=0x7fe280 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
#11 0x00730501 in malloc_printerr (action=<value optimized out>, str=0x6 <Address 0x6 out of bounds>, ptr=0xb86af48) at malloc.c:6283
#12 0x007363cf in realloc_check (oldmem=0xb86af48, bytes=192, caller=0x48633ac) at hooks.c:330
#13 0x00736153 in __libc_realloc (oldmem=0xb86af48, bytes=192) at malloc.c:3757
#14 0x048633ac in c4_BaseArray::SetLength (this=0xb711238, nNewSize=136) at ../../../../akregator/plugins/mk4storage/metakit/src/univ.cpp:79
#15 0x048635a1 in c4_BaseArray::InsertAt (this=0xb711238, nIndex=116, nCount=8) at ../../../../akregator/plugins/mk4storage/metakit/src/univ.cpp:97
#16 0x048636d1 in c4_DWordArray::InsertAt (this=0xb711238, nIndex=29, newElement=5210916, nCount=2) at ../../../../akregator/plugins/mk4storage/metakit/src/univ.cpp:123
#17 0x0485afab in c4_Allocator::InsertPair (this=0xb711238, i_=29, from_=4336, to_=5216848) at ../../../../akregator/plugins/mk4storage/metakit/src/persist.cpp:268
#18 0x0485b126 in c4_Allocator::Occupy (this=0xb711238, pos_=5210916, len_=5932) at ../../../../akregator/plugins/mk4storage/metakit/src/persist.cpp:192
#19 0x0484aa95 in c4_Column::PullLocation (this=0xb8707d0, ptr_=@0x10f0) at ../../../../akregator/plugins/mk4storage/metakit/src/column.cpp:165
#20 0x04856c9f in c4_FormatB::Define (this=0xb865558, ptr_=0xbfcf89bc) at ../../../../akregator/plugins/mk4storage/metakit/src/format.cpp:412
#21 0x04858d4a in c4_HandlerSeq::Prepare (this=0xb857f20, ptr_=0xbfcf89bc, selfDesc_=false) at ../../../../akregator/plugins/mk4storage/metakit/src/handler.cpp:321
#22 0x04856676 in c4_FormatV::SetupAllSubviews (this=0xb8652c8) at ../../../../akregator/plugins/mk4storage/metakit/src/format.cpp:963
#23 0x04856aa0 in c4_FormatV::Get (this=0xb8652c8, index_=0, length_=@0xbfcf8a3c) at ../../../../akregator/plugins/mk4storage/metakit/src/format.cpp:1027
#24 0x04858756 in c4_Handler::GetBytes (this=0xb8652c8, index_=0, buf_=..., copySmall_=false) at ../../../../akregator/plugins/mk4storage/metakit/src/handler.cpp:53
#25 0x04866a9b in c4_Sequence::Get (this=0xb8634a0, index_=0, propId_=37, buf_=...) at ../../../../akregator/plugins/mk4storage/metakit/src/viewx.cpp:319
#26 0x048676b0 in GetData (this=0xbfcf8b10) at ../../../../akregator/plugins/mk4storage/metakit/include/mk4.inl:421
#27 c4_ViewRef::operator c4_View (this=0xbfcf8b10) at ../../../../akregator/plugins/mk4storage/metakit/src/viewx.cpp:587
#28 0x04861245 in c4_Storage::Description (this=0xb6440d0, name_=0xb721d12 "articles") at ../../../../akregator/plugins/mk4storage/metakit/src/store.cpp:342
#29 0x04861e31 in c4_Storage::GetAs (this=0xb6440d0, description_=0x48721d4 "articles[guid:S,title:S,hash:I,guidIsHash:I,guidIsPermaLink:I,description:S,link:S,comments:I,commentsLink:S,status:I,pubDate:I,tags[tag:S],hasEnclosure:I,enclosureUrl:S,enclosureType:S,enclosureLengt"...) at ../../../../akregator/plugins/mk4storage/metakit/src/store.cpp:261
#30 0x0486d5da in Akregator::Backend::FeedStorageMK4Impl::FeedStorageMK4Impl (this=0xb857be0, url=..., main=0xa3dd2e8) at ../../../../akregator/plugins/mk4storage/feedstoragemk4impl.cpp:154
#31 0x0487037c in Akregator::Backend::StorageMK4Impl::StorageMK4ImplPrivate::createFeedStorage (this=0xabb1130, url=...) at ../../../../akregator/plugins/mk4storage/storagemk4impl.cpp:77
#32 0x04bcabc8 in Akregator::Feed::loadArticles (this=0xb619300) at ../../../akregator/src/feed.cpp:234
#33 0x04bce8e3 in Akregator::Feed::fromOPML (e=..., storage=0xa3dd2e8) at ../../../akregator/src/feed.cpp:174
#34 0x04bdb41d in Akregator::FeedList::parseChildNodes (this=0xac97d08, node=..., parent=0xb73d498) at ../../../akregator/src/feedlist.cpp:237
#35 0x04bdb646 in Akregator::FeedList::parseChildNodes (this=0xac97d08, node=..., parent=0xad30c78) at ../../../akregator/src/feedlist.cpp:255
#36 0x04bdbeb4 in Akregator::FeedList::readFromOpml (this=0xac97d08, doc=...) at ../../../akregator/src/feedlist.cpp:295
#37 0x04c1f298 in Akregator::LoadFeedListCommand::Private::handleDocument (this=0xac5da08, doc=...) at ../../../akregator/src/loadfeedlistcommand.cpp:68
#38 0x04c1fdda in Akregator::LoadFeedListCommand::Private::doLoad (this=0xac5da08) at ../../../akregator/src/loadfeedlistcommand.cpp:173
#39 0x04c20213 in Akregator::LoadFeedListCommand::qt_metacall (this=0xac5d950, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0xbfcf94dc) at ./loadfeedlistcommand.moc:78
#40 0x026228ca in QMetaObject::metacall (object=0xac5d950, cl=4336, idx=8, argv=0xbfcf94dc) at kernel/qmetaobject.cpp:237
#41 0x026356ad in QMetaObject::activate (sender=0xac60988, m=0x274e188, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#42 0x0263aa47 in QSingleShotTimer::timeout (this=0xac60988) at .moc/release-shared/qtimer.moc:82
#43 0x0263ab5c in QSingleShotTimer::timerEvent (this=0xac60988) at kernel/qtimer.cpp:308
#44 0x0262f504 in QObject::event (this=0xac60988, e=0x6) at kernel/qobject.cpp:1183
#45 0x01004fdc in QApplicationPrivate::notify_helper (this=0x9658b20, receiver=0xac60988, e=0xbfcf9a10) at kernel/qapplication.cpp:4396
#46 0x0100b04e in QApplication::notify (this=0xbfcf9d74, receiver=0xac60988, e=0xbfcf9a10) at kernel/qapplication.cpp:3798
#47 0x00ceb2ca in KApplication::notify (this=0xbfcf9d74, receiver=0xac60988, event=0xbfcf9a10) at ../../kdeui/kernel/kapplication.cpp:311
#48 0x0261cb3b in QCoreApplication::notifyInternal (this=0xbfcf9d74, receiver=0xac60988, event=0xbfcf9a10) at kernel/qcoreapplication.cpp:732
#49 0x0264ead6 in sendEvent (this=0x9653374) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#50 QTimerInfoList::activateTimers (this=0x9653374) at kernel/qeventdispatcher_unix.cpp:602
#51 0x0264b874 in timerSourceDispatch (source=0x9653340) at kernel/qeventdispatcher_glib.cpp:184
#52 0x043e9855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#53 0x043ed668 in ?? () from /lib/libglib-2.0.so.0
#54 0x043ed848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#55 0x0264b565 in QEventDispatcherGlib::processEvents (this=0x964e790, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#56 0x010c6be5 in QGuiEventDispatcherGlib::processEvents (this=0x964e790, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#57 0x0261b609 in QEventLoop::processEvents (this=0xbfcf9cd4, flags=) at kernel/qeventloop.cpp:149
#58 0x0261ba8a in QEventLoop::exec (this=0xbfcf9cd4, flags=...) at kernel/qeventloop.cpp:201
#59 0x0262000f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#60 0x01003e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#61 0x0804b132 in main (argc=1, argv=0xbfcf9f94) at ../../../kontact/src/main.cpp:224

Reported using DrKonqi
Comment 1 Thomas Tanghus 2010-12-25 09:59:02 UTC
Created attachment 55221 [details]
New crash information added by DrKonqi

kontact (4.4.9) on KDE Platform 4.5.90 (4.6 RC1) using Qt 4.7.0

- What I was doing when the application crashed:

Almost the same as before. Started Kontact (it started at Contacts again), switched to Akregator: Crash

I'll attach some output from ~/.xsession-errors which looks useful.

-- Backtrace (Reduced):
#10 0x08587305 in __libc_message (do_abort=2, fmt=0x865f280 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
#11 0x08591501 in malloc_printerr (action=<value optimized out>, str=0x6 <Address 0x6 out of bounds>, ptr=0xaf36c88) at malloc.c:6283
#12 0x085973cf in realloc_check (oldmem=0xaf36c88, bytes=192, caller=0x4b633ac) at hooks.c:330
#13 0x08597153 in __libc_realloc (oldmem=0xaf36c88, bytes=192) at malloc.c:3757
#14 0x04b633ac in c4_BaseArray::SetLength (this=0xadb8980, nNewSize=136) at ../../../../akregator/plugins/mk4storage/metakit/src/univ.cpp:79
Comment 2 Thomas Tanghus 2010-12-25 10:01:17 UTC
Created attachment 55222 [details]
Excerpt from ~/.xsession-errors
Comment 3 Thomas Tanghus 2010-12-25 10:07:56 UTC
I have renamed ~/.kde/share/apps/akregator/Archive and now it starts up fine. I still have the original - corrupted - files, if they could be useful for debugging?
Comment 4 Christophe Marin 2010-12-25 11:52:55 UTC

*** This bug has been marked as a duplicate of bug 116482 ***