Bug 261006 - R: Impossible to copy or move emails
Summary: R: Impossible to copy or move emails
Status: CLOSED FIXED
Alias: None
Product: KMail Mobile
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-22 22:14 UTC by Sabine Faure
Modified: 2011-01-08 02:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Pop up dialogue to select a folder for emails to be copied to or moved to (56.75 KB, image/png)
2010-12-22 22:19 UTC, Sabine Faure
Details
Ok and Cancel buttons partially cut in selection dialogue to copy or move emails (43.46 KB, image/png)
2010-12-23 23:05 UTC, Sabine Faure
Details
Both buttons are fully displayed within the N900 screen. (45.75 KB, image/png)
2011-01-08 02:38 UTC, Sabine Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sabine Faure 2010-12-22 22:14:22 UTC
Version:           unspecified (using Devel) 
OS:                Linux

There is no way to confirm the folder selected when copying or moving emails from one folder to another.

This is a regression since it worked fine 3 days ago when I last tested this.

Reproducible: Always

Steps to Reproduce:
- Launch Kmail-mobile
- Click on your Imap inbox
- Open the 'Actions' tab
- Click on 'Edit'
- Click on 'New Subfolder'
- Enter a name for the new subfolder (ex: Folder 1) and click on 'Ok'
- Click on your Imap inbox twice
- Select two emails from the list and click on 'Copy Email To'
- Select Imap account/inbox/Folder 1 from the pop up dialogue
- The selected folder is highlighted in grey

Actual Results:  
Nothing more happens. 

There is no way to confirm the selection: no 'Ok' button, pressing 'Enter' does not work, double clicking on the folder does not work either

Expected Results:  
It should be possible to confirm the selected folder and to close the pop up dialogue.

The emails should be properly copied to the selected folder.

Note: the same pb happens with the 'Move Email To' functionality.

N900, 4:4.6~20101222.1208531-1maemo1.1208558
Comment 1 Sabine Faure 2010-12-22 22:19:12 UTC
Created attachment 55171 [details]
Pop up dialogue to select a folder for emails to be copied to or moved to

There is no 'Ok' button if you scroll down or other way to confirm the folder selected so it is now impossible to copy or move emails because of this regression.

N900, 4:4.6~20101222.1208531-1maemo1.1208558
Comment 2 Tobias Koenig 2010-12-23 09:41:02 UTC
SVN commit 1208776 by tokoe:

Make the dialog fullscreen on mobile devices

CCBUG: 261006


 M  +7 -0      collectiondialog_mobile.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1208776
Comment 3 Tobias Koenig 2010-12-23 10:26:58 UTC
Hej Sabine,

can you retest this bug, please?

Ciao,
Tobias
Comment 4 Sabine Faure 2010-12-23 23:02:33 UTC
Hi Tobias!

It is mostly corrected now.

There are two buttons ('ok' and 'cancel') to confirm the selected folder now.

There is a display issue remaining since the buttons are cut at the bottom (see screenshot enclosed) but they are fully usable and work so let me know when I can close this bug.

N900, 4:4.6~.20101223.2034.git9cc0c3e-1maemo1.120883
Comment 5 Sabine Faure 2010-12-23 23:05:03 UTC
Created attachment 55198 [details]
Ok and Cancel buttons partially cut in selection dialogue to copy or move emails

N900, 4:4.6~.20101223.2034.git9cc0c3e-1maemo1.120883
Comment 6 Tobias Koenig 2010-12-28 10:02:22 UTC
SVN commit 1209843 by tokoe:

Decrease the size of the QML area to make it fit on the
display of mobile devices.

CCBUG: 261006


 M  +2 -2      CollectionDialogMobile.qml  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1209843
Comment 7 Tobias Koenig 2010-12-28 10:03:30 UTC
Hej Sabine,

can you retest if the layout works on the device now, please?

Ciao,
Tobias
Comment 8 Sabine Faure 2011-01-08 02:36:59 UTC
Hi Tobias!

It is corrected now.

Both 'ok' and 'cancel' buttons fit perfectly in the N900 screen (see snapshot enclosed) and work fine so I am closing this bug.

N900, 4:4.6~.20110106.1209.gitfde48d5-1maemo1.121147
Comment 9 Sabine Faure 2011-01-08 02:38:29 UTC
Created attachment 55720 [details]
Both buttons are fully displayed within the N900 screen.

N900, 4:4.6~.20110106.1209.gitfde48d5-1maemo1.121147