Bug 260989 - Kontact crash
Summary: Kontact crash
Status: RESOLVED DUPLICATE of bug 185544
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-22 18:54 UTC by Thomas Williams
Modified: 2010-12-26 23:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Williams 2010-12-22 18:54:25 UTC
Application: kontact (4.4.6)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed: I was playing LinCity NG and it crashed and then I rebooted because screen resolution was fouled. When I rebooted Kontact tried to restart and said another instance was running and then the crash report screen started.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76d9730 (LWP 2500))]

Thread 2 (Thread 0xaec11b70 (LWP 2621)):
#0  0x05619b2c in g_ptr_array_set_size () from /lib/libglib-2.0.so.0
#1  0x05647da5 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#2  0x05648279 in ?? () from /lib/libglib-2.0.so.0
#3  0x05648848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x0765959f in QEventDispatcherGlib::processEvents (this=0x9af8380, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#5  0x07629609 in QEventLoop::processEvents (this=0xaec11270, flags=) at kernel/qeventloop.cpp:149
#6  0x07629a8a in QEventLoop::exec (this=0xaec11270, flags=...) at kernel/qeventloop.cpp:201
#7  0x07525b7e in QThread::exec (this=0x8f56240) at thread/qthread.cpp:490
#8  0x0760835b in QInotifyFileSystemWatcherEngine::run (this=0x8f56240) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x07528df9 in QThreadPrivate::start (arg=0x8f56240) at thread/qthread_unix.cpp:266
#10 0x00b6ecc9 in start_thread (arg=0xaec11b70) at pthread_create.c:304
#11 0x0050c69e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb76d9730 (LWP 2500)):
[KCrash Handler]
#7  0x07643473 in isSignalConnected (sender=0x9795e50, m=0xfe5948, local_signal_index=1, argv=0xbfc59a94) at kernel/qobject_p.h:223
#8  QMetaObject::activate (sender=0x9795e50, m=0xfe5948, local_signal_index=1, argv=0xbfc59a94) at kernel/qobject.cpp:3203
#9  0x00f27e59 in KPIM::ProgressItem::progressItemProgress (this=0x9795e50, _t1=0x9795e50, _t2=100) at ./progressmanager.moc:114
#10 0x00f27e8b in KPIM::ProgressItem::setProgress (this=0x9795e50, v=100) at ../../libkdepim/progressmanager.cpp:107
#11 0xb31818c6 in KMail::PopAccount::slotJobFinished (this=0x98da6c0) at ../../kmail/popaccount.cpp:677
#12 0xb31843a0 in KMail::PopAccount::slotResult (this=0x98da6c0) at ../../kmail/popaccount.cpp:1105
#13 0xb3186787 in KMail::PopAccount::qt_metacall (this=0x98da6c0, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xbfc59f38) at ./popaccount.moc:92
#14 0x076308ca in QMetaObject::metacall (object=0x98da6c0, cl=QMetaObject::ResetProperty, idx=14, argv=0xbfc59f38) at kernel/qmetaobject.cpp:237
#15 0x076436ad in QMetaObject::activate (sender=0xa29f8c0, m=0x8d7b48, local_signal_index=3, argv=0x4) at kernel/qobject.cpp:3280
#16 0x007648a3 in KJob::result (this=0xa29f8c0, _t1=0xa29f8c0) at ./kjob.moc:194
#17 0x00764c08 in KJob::emitResult (this=0xa29f8c0) at ../../kdecore/jobs/kjob.cpp:312
#18 0x00caa480 in KIO::SimpleJob::slotFinished (this=0xa29f8c0) at ../../kio/kio/job.cpp:522
#19 0x00caa960 in KIO::TransferJob::slotFinished (this=0xa29f8c0) at ../../kio/kio/job.cpp:1111
#20 0x00ca8453 in KIO::TransferJob::qt_metacall (this=0xa29f8c0, _c=QMetaObject::InvokeMetaMethod, _id=47, _a=0xbfc5a1dc) at ./jobclasses.moc:367
#21 0x076308ca in QMetaObject::metacall (object=0xa29f8c0, cl=QMetaObject::ResetProperty, idx=47, argv=0xbfc5a1dc) at kernel/qmetaobject.cpp:237
#22 0x076436ad in QMetaObject::activate (sender=0x9a7b938, m=0xe59944, local_signal_index=4, argv=0x4) at kernel/qobject.cpp:3280
#23 0x00d62fc7 in KIO::SlaveInterface::finished (this=0x9a7b938) at ./slaveinterface.moc:171
#24 0x00d66768 in KIO::SlaveInterface::dispatch (this=0x9a7b938, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:175
#25 0x00d63483 in KIO::SlaveInterface::dispatch (this=0x9a7b938) at ../../kio/kio/slaveinterface.cpp:91
#26 0x00d55fe8 in KIO::Slave::gotInput (this=0x9a7b938) at ../../kio/kio/slave.cpp:344
#27 0x00d561f3 in KIO::Slave::qt_metacall (this=0x9a7b938, _c=QMetaObject::InvokeMetaMethod, _id=30, _a=0xbfc5a4fc) at ./slave.moc:82
#28 0x076308ca in QMetaObject::metacall (object=0x9a7b938, cl=QMetaObject::ResetProperty, idx=30, argv=0xbfc5a4fc) at kernel/qmetaobject.cpp:237
#29 0x076436ad in QMetaObject::activate (sender=0x99c4ad8, m=0xe56500, local_signal_index=0, argv=0x4) at kernel/qobject.cpp:3280
#30 0x00c6fe17 in KIO::Connection::readyRead (this=0x99c4ad8) at ./connection.moc:92
#31 0x00c7217e in KIO::ConnectionPrivate::dequeue (this=0x9a7cb60) at ../../kio/kio/connection.cpp:82
#32 0x00c722ae in KIO::Connection::qt_metacall (this=0x99c4ad8, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xa339628) at ./connection.moc:79
#33 0x076308ca in QMetaObject::metacall (object=0x99c4ad8, cl=QMetaObject::ResetProperty, idx=5, argv=0xa339628) at kernel/qmetaobject.cpp:237
#34 0x0763bdf6 in QMetaCallEvent::placeMetaCall (this=0xa3e2f68, object=0x99c4ad8) at kernel/qobject.cpp:534
#35 0x0763d6a2 in QObject::event (this=0x99c4ad8, e=0x0) at kernel/qobject.cpp:1219
#36 0x04671fdc in QApplicationPrivate::notify_helper (this=0x8e9e100, receiver=0x99c4ad8, e=0xa3e2f68) at kernel/qapplication.cpp:4396
#37 0x0467804e in QApplication::notify (this=0xbfc5ae54, receiver=0x99c4ad8, e=0xa3e2f68) at kernel/qapplication.cpp:3798
#38 0x011c468a in KApplication::notify (this=0xbfc5ae54, receiver=0x99c4ad8, event=0xa3e2f68) at ../../kdeui/kernel/kapplication.cpp:310
#39 0x0762ab3b in QCoreApplication::notifyInternal (this=0xbfc5ae54, receiver=0x99c4ad8, event=0xa3e2f68) at kernel/qcoreapplication.cpp:732
#40 0x0762dd8b in sendEvent (receiver=0x0, event_type=0, data=0x8e78eb8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#41 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8e78eb8) at kernel/qcoreapplication.cpp:1373
#42 0x0762df4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#43 0x07659a74 in sendPostedEvents (s=0x8ea1510) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#44 postEventSourceDispatch (s=0x8ea1510) at kernel/qeventdispatcher_glib.cpp:277
#45 0x05644855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#46 0x05648668 in ?? () from /lib/libglib-2.0.so.0
#47 0x05648848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#48 0x07659565 in QEventDispatcherGlib::processEvents (this=0x8e78b78, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#49 0x04733be5 in QGuiEventDispatcherGlib::processEvents (this=0x8e78b78, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#50 0x07629609 in QEventLoop::processEvents (this=0xbfc5adb4, flags=) at kernel/qeventloop.cpp:149
#51 0x07629a8a in QEventLoop::exec (this=0xbfc5adb4, flags=...) at kernel/qeventloop.cpp:201
#52 0x0762e00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#53 0x04670e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#54 0x0804b132 in main (argc=3, argv=0xbfc5b074) at ../../../kontact/src/main.cpp:224

Reported using DrKonqi
Comment 1 Christophe Marin 2010-12-26 23:29:37 UTC

*** This bug has been marked as a duplicate of bug 185544 ***