Bug 260931 - Akonadi imap resource crashed
Summary: Akonadi imap resource crashed
Status: RESOLVED DUPLICATE of bug 260009
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-22 01:14 UTC by Alex Merry
Modified: 2010-12-30 14:06 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Merry 2010-12-22 01:14:20 UTC
Application: akonadi_imap_resource (0.1)
KDE Platform Version: 4.5.86 (4.6 >= 20101210) (Compiled from sources)
Qt Version: 4.7.1
Operating System: Linux 2.6.36-ARCH x86_64
Distribution (Platform): Archlinux Packages

-- Information about the crash:
- What I was doing when the application crashed:

I opened a folder, selected an unread message, and it didn't seem to be loading the body.  I deleted the message (it was spam) while it was still attempting to load.  At this point, I noticed by internet had stopped working.  KMail came up with a "conflict resolution" dialog, I chose "Take right one".  I went back to trying to sort my internet connection, and the akonadi imap crash dialog came up.

-- Backtrace:
Application: Akonadi Resource (akonadi_imap_resource), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f36bbfb4760 (LWP 11290))]

Thread 4 (Thread 0x7f36a90f7710 (LWP 19893)):
#0  0x00007f36b6edd173 in poll () from /lib/libc.so.6
#1  0x00007f36b5ee1134 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f36b5ee166d in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007f36bb3cdf66 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007f36bb3a2232 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f36bb3a247c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f36bb2b7d54 in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007f36b9e45c2a in KIMAP::SessionThread::run (this=0x18268c0) at /home/kde-devel/src/KDE/kdepimlibs/kimap/sessionthread.cpp:166
#8  0x00007f36bb2ba52e in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f36bb031cb0 in start_thread () from /lib/libpthread.so.0
#10 0x00007f36b6ee59dd in clone () from /lib/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f36a88f6710 (LWP 20085)):
#0  0x00007f36b5ee0535 in g_main_context_query () from /usr/lib/libglib-2.0.so.0
#1  0x00007f36b5ee103b in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f36b5ee166d in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007f36bb3cdf66 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007f36bb3a2232 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f36bb3a247c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f36bb2b7d54 in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007f36b9e45c2a in KIMAP::SessionThread::run (this=0x170adb0) at /home/kde-devel/src/KDE/kdepimlibs/kimap/sessionthread.cpp:166
#8  0x00007f36bb2ba52e in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f36bb031cb0 in start_thread () from /lib/libpthread.so.0
#10 0x00007f36b6ee59dd in clone () from /lib/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f36a4422710 (LWP 20086)):
#0  0x00007f36bb036779 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f36bb2bab82 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f36bb2b0c18 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007f36bb2ba52e in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f36bb031cb0 in start_thread () from /lib/libpthread.so.0
#5  0x00007f36b6ee59dd in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f36bbfb4760 (LWP 11290)):
[KCrash Handler]
#6  0x000000000041da3c in QString::QString (this=0x7fff2b517660, other=...) at /usr/include/QtCore/qstring.h:728
#7  0x000000000044daea in ImapAccount::server (this=0x0) at /home/kde-devel/src/KDE/kdepim/runtime/resources/imap/imapaccount.cpp:48
#8  0x000000000046119a in SessionPool::cancelSessionCreation (this=0x15d0940, session=0x17013b0, errorCode=4, errorMessage=...) at /home/kde-devel/src/KDE/kdepim/runtime/resources/imap/sessionpool.cpp:222
#9  0x0000000000461deb in SessionPool::onEarlyConnectionLost (this=0x15d0940) at /home/kde-devel/src/KDE/kdepim/runtime/resources/imap/sessionpool.cpp:339
#10 0x0000000000462c4b in SessionPool::qt_metacall (this=0x15d0940, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x7fff2b517810) at /home/kde-devel/build/KDE/kdepim/runtime/resources/imap/sessionpool.moc:122
#11 0x00007f36bb3b831f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#12 0x00007f36b9e43265 in KIMAP::Session::connectionLost (this=0x17013b0) at /home/kde-devel/build/KDE/kdepimlibs/kimap/session.moc:128
#13 0x00007f36b9e42a40 in KIMAP::SessionPrivate::socketError (this=0x166a7b0) at /home/kde-devel/src/KDE/kdepimlibs/kimap/session.cpp:354
#14 0x00007f36b9e431b3 in KIMAP::Session::qt_metacall (this=0x17013b0, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0x1775d20) at /home/kde-devel/build/KDE/kdepimlibs/kimap/session.moc:109
#15 0x00007f36bb3b717a in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#16 0x00007f36ba5502b4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#17 0x00007f36ba554dca in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#18 0x00007f36b8576645 in KApplication::notify (this=0x7fff2b518330, receiver=0x17013b0, event=0x16fbfe0) at /home/kde-devel/src/KDE/kdelibs/kdeui/kernel/kapplication.cpp:311
#19 0x00007f36bb3a2e9c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#20 0x00007f36bb3a66c5 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#21 0x00007f36bb3cdd73 in ?? () from /usr/lib/libQtCore.so.4
#22 0x00007f36b5ee0bf3 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0x00007f36b5ee13d0 in ?? () from /usr/lib/libglib-2.0.so.0
#24 0x00007f36b5ee166d in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0x00007f36bb3cdf0f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#26 0x00007f36ba5f51ae in ?? () from /usr/lib/libQtGui.so.4
#27 0x00007f36bb3a2232 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0x00007f36bb3a247c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#29 0x00007f36bb3a697b in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#30 0x00007f36bbac9f9c in Akonadi::ResourceBase::init (r=0x15b95a0) at /home/kde-devel/src/KDE/kdepimlibs/akonadi/resourcebase.cpp:302
#31 0x000000000042831e in Akonadi::ResourceBase::init<ImapResource> (argc=3, argv=0x7fff2b518488) at /home/kde-devel/kde/include/akonadi/resourcebase.h:188
#32 0x0000000000426e67 in main (argc=3, argv=0x7fff2b518488) at /home/kde-devel/src/KDE/kdepim/runtime/resources/imap/imapresource.cpp:580

Reported using DrKonqi
Comment 1 Alex Merry 2010-12-22 01:15:22 UTC
On second thoughts, maybe the crash happened before the conflict resolution dialog.  Sorry, I was a little distracted at the time.
Comment 2 Dario Andres 2010-12-25 15:45:39 UTC
[Comment from a bug triager]
This looks mostly the same as bug 260009; but I will let developers confirm.
Regards
Comment 3 Volker Krause 2010-12-30 14:06:43 UTC

*** This bug has been marked as a duplicate of bug 260009 ***