Bug 260927 - Klondike-3: Solver reports game as lost, in next move it is solvable
Summary: Klondike-3: Solver reports game as lost, in next move it is solvable
Status: RESOLVED FIXED
Alias: None
Product: kpat
Classification: Applications
Component: solver (show other bugs)
Version: 3.0
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-22 00:06 UTC by heisewurgl
Modified: 2011-01-26 13:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
saved game to reproduce (2.90 KB, text/plain)
2010-12-22 00:09 UTC, heisewurgl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description heisewurgl 2010-12-22 00:06:33 UTC
Version:           3.0 (using KDE 1.2) 
OS:                Linux

The attached game is actually solvable, but up to the saved state the program says unsolvable.

Reproducible: Always

Steps to Reproduce:
When you load the attached saved game, then one move is done automagicaly (the 2 of spaced is moved), revert that move. Look at the bottom line, it says "unsolvable" ... sorry I just have the german translation here, but thats what it means). Then take the next cards from the stack and the game can be solved! And yes, it really can be solved.

Actual Results:  
It says unsolvable

Expected Results:  
Should say solvable
Comment 1 heisewurgl 2010-12-22 00:09:27 UTC
Created attachment 55147 [details]
saved game to reproduce
Comment 2 Stephan Kulow 2011-01-10 15:55:52 UTC
very bad story. The end of the pile is about the only situation where it matters not to automove ;(
Comment 3 Stephan Kulow 2011-01-26 13:45:46 UTC
SVN commit 1217243 by coolo:

klondike 3 is not as easy with automoves as klondike 1
BUG: 260927


 M  +4 -3      klondikesolver.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1217243