Bug 260703 - favorite folders: please option to show as list as it is in Kmail1
Summary: favorite folders: please option to show as list as it is in Kmail1
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Unclassified
Component: folders (show other bugs)
Version: 2.0.89
Platform: Ubuntu Packages Linux
: NOR wishlist with 56 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-19 14:37 UTC by Janet
Modified: 2016-09-10 19:26 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janet 2010-12-19 14:37:05 UTC
Version:           2.0.89 (using KDE 4.5.85) 
OS:                Linux

In Kmail2 the favorite folders are shown as icons instead of a list. This has some disadvantages:

- The most important and annoying is they don't have any informatinal value: you cannot see how much mails are in the folder and you cannot see if the folder contains new messages. But that's a very important part of those favorites IMHO, to see at one glance that in those important folders something new happend. Especially when you have a very long list of mail folders which are out of sight you - I - depend on that information for the favorite folders.

- They are not configurable in size: some people need or prefer small icons, others need big icons

- IMHO the icon view mode wastes too much space compared to a list and at least to me it looks more cluttered. 

- IMHO a list is easier to "grab" because you don't have to orientate in two directions. With icon view above and folder list below you have to orientate from left to right above and top to bottom below. One direction, only top to bottom, is faster to overlook and at least for me more pleasant.


Reproducible: Always



Expected Results:  
The favorite folder icons should 
1. be configurable in size
2. optionally show information like number of new/unread mails + an indicator that there are new unread mails in that folder
3. offer the option to show as list like it was in kmail1


OS: Linux (i686) release 2.6.35-24-generic
Compiler: cc
Comment 1 m.wege 2011-01-03 10:08:29 UTC
I agree that the favourite folders appear really cluttered and are not much usable in this state. I would prefer how they were in Kmail1. Alternatively the best thing I would like to see is the Kmail1 view with 2 collumns to use the space better. If this can not be done for release of 4.6 I would at least like to see the icon size adapt to the one I use on my system and have the icons be ordered in a grid.
Comment 2 m.wege 2011-01-03 10:10:57 UTC
addition: The font size should also be the same as in the other folder list.
Comment 3 _ 2011-02-09 05:45:10 UTC
(In reply to comment #0)
> The favorite folder icons should 
> 1. be configurable in size
> 2. optionally show information like number of new/unread mails + an indicator
> that there are new unread mails in that folder
> 3. offer the option to show as list like it was in kmail1

agreed.  icons only, e.g. when having 5+ favorite folders, as I've had in KMail for ages, is effectively unmanageable.
Comment 4 Ivan D Vasin 2011-06-18 21:30:22 UTC
on the other hand, with some layouts and folder counts, icons might work well if they could be resized, as in Dolphin via an icon zoom slider, perhaps accessible via a small toolbar button if it would take up too much space otherwise.

at best, i would also like to see a way to change the favorites view to use icons, list, or details mode.  i think it makes sense to put those in the favorites panel's context menu or in a menu accessible via a small toolbar button or both.
Comment 5 Philipp Woelfel 2011-06-23 04:09:50 UTC
This is a show-stopper. I have 100+ folders total and the 18 most frequently used ones in my favourite list (KMail1). A "Favourite Folders" view with icons is useless to me and forces me to stick with the old KMail. I think the typical user who has a need of the "Favourite Folders" view has lots of folders and therefore also many favourite ones.
Comment 6 Tanja Schulte 2011-06-26 13:49:45 UTC
*** This bug has been confirmed by popular vote. ***
Comment 7 Tanja Schulte 2011-06-26 13:52:25 UTC
It just should be configurable. Show it or not, icons view or list, size of icons, and very important: the option to show how many new mails are in those folders and an indicator like bold font that there are new mails! Useless for me without.
Comment 8 Hamlet 2011-07-06 21:03:09 UTC
Should I mention that (at least in my box, KMail 2.1.0, KDE 4.6.4, Gentoo) those folders don't accept drag&drop, nor their icon settings are saved? And that their order is as wild as the one in the folders view?
Comment 9 Peter Paulsen 2011-07-12 12:56:41 UTC
Same problems here (Kubuntu, KDE 4.6.4 and Kmail 2.1.0): The folders in the favorite folders' field don't accept drag'n'drop and they don't show the number of unread mails in them. The latter could be achieved for the icon view with an overlay that shows the number of new/unread messages. Another problem is that the order of the favorite folders cannot be manipulated by the user! All issues do work with Kmail 1!

I also agree that the appearance should be configurable (icon size, layout, order).
Comment 10 Christophe Giboudeaux 2011-09-16 13:42:17 UTC
Fixed in kmail 4.8.0 (commits gc47e350 & g345fc22 in kdepim)
Comment 11 Tanja Schulte 2012-04-01 17:03:47 UTC
Only partly solved I'd say... It is now possible to show the favorite folders as list - thanks a lot! Though I had not realized it before I was just reading this, because I had expected it to be like in KMail 1, configurable directly via the favorite folder box and not hidden in the settings. After reading here I went on searching. 

Partly solved because in KMail 1 there was the option to configure the icon size and to sort the favorite folders. Both is still not possible in KMail 2.
Comment 12 Bernd Oliver Sünderhauf 2012-12-02 13:36:37 UTC
Only partly solved per comment #11 and per my quick check, so please reopen.
Comment 13 Allen Winter 2012-12-03 13:09:40 UTC
reopening, per Bernd.

Bernd: I gave you permission to modify bugs yourself now.
Comment 14 Laurent Montel 2013-08-12 21:18:04 UTC
Git commit b5b543d236580895c02fd5836450cbcb50426f08 by Montel Laurent.
Committed on 12/08/2013 at 21:14.
Pushed by mlaurent into branch 'master'.

Allow to change icon size in favorite folder

M  +3    -1    kmail/kmail_part.rc
M  +3    -1    kmail/kmmainwin.rc
M  +64   -0    mailcommon/widgets/favoritecollectionwidget.cpp
M  +4    -1    mailcommon/widgets/favoritecollectionwidget.h

http://commits.kde.org/kdepim/b5b543d236580895c02fd5836450cbcb50426f08
Comment 15 Laurent Montel 2013-08-14 07:18:43 UTC
Git commit 63dc38ad33804faf8a26eb83ff6e33ff0a789328 by Montel Laurent.
Committed on 14/08/2013 at 07:18.
Pushed by mlaurent into branch 'master'.

Allow to change type of favorite

M  +3    -1    kmail/kmail_part.rc
M  +3    -1    kmail/kmmainwin.rc
M  +52   -4    mailcommon/widgets/favoritecollectionwidget.cpp
M  +1    -1    mailcommon/widgets/favoritecollectionwidget.h

http://commits.kde.org/kdepim/63dc38ad33804faf8a26eb83ff6e33ff0a789328
Comment 16 Denis Kurz 2016-09-10 19:26:28 UTC
Fixed by commits in comment 14 and comment 15. Noone complained after these changes were applied, and I just checked that they work as proposed in 16.08.1.