Bug 260669 - Images on camera always marked as new
Summary: Images on camera always marked as new
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Import-History (show other bugs)
Version: 2.0.0
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
: 274531 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-12-18 23:26 UTC by JD Rogers
Modified: 2017-08-16 09:31 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.1.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description JD Rogers 2010-12-18 23:26:58 UTC
Version:           1.6.0 (using KDE 4.5.1) 
OS:                Linux

Since upgrade from 1.4 to 1.6, images are marked as downloaded (checkmark) after I download from the camera, but are marked as new (star) the next time I access the camera.


Reproducible: Always

Steps to Reproduce:
1. Import some photos from the camera. 
2. Close camera GUI, disconnect or turn off the camera
3. Reconnect the camera and open the import GUI


Actual Results:  
All images including those previously downloaded will be marked as new

Expected Results:  
Images that were previously downloaded would not be marked as new.

Digikam 1.6 from ubuntu pilip5 PPA
Camera: canon 400d

This worked properly on version 1.4 with my camera and configuration.
Comment 1 mikewidner 2011-06-30 19:05:52 UTC
I'm seeing the same behavior with both of my Canon cameras. One is an old Powershot A75, the other a new(ish) Powershot A3000.
Comment 2 caulier.gilles 2011-08-03 14:55:43 UTC
I confirm this problem with UMS camera too, using 2.0.0...

Marcel, there is a problem with DB camera interface to store download status ?

Gilles Caulier
Comment 3 caulier.gilles 2011-08-03 14:58:59 UTC
Git commit 437cd2b58c69ec4ad788b0e3e32c5ac0da4530e8 by Gilles Caulier.
Committed on 03/08/2011 at 16:58.
Pushed by cgilles into branch 'master'.

add camera type mime to handle digiKAm as camera interface unde Gnome
BUGS: 260669

M  +1    -0    digikam/main/digikam.desktop

http://commits.kde.org/digikam/437cd2b58c69ec4ad788b0e3e32c5ac0da4530e8
Comment 4 caulier.gilles 2011-08-03 15:02:54 UTC
*** Bug 274531 has been marked as a duplicate of this bug. ***
Comment 5 caulier.gilles 2011-08-04 13:15:00 UTC
Git commit db28ce80274cf9dc8c4eeb6bcb93354aeae93f3b by Gilles Caulier.
Committed on 04/08/2011 at 15:09.
Pushed by cgilles into branch 'master'.

Do not overwrite download status from DB when thumb/info are get on the fly. This fix download indicators over icon view items.
Do not overwrite file mtime get at camera connection when metadata are updated with thumbnails. This fix Ordering of icon view items.
Fix loop to get download status. No need to copy map.
Improve and simplify icon-view loop to refresh items depending of sort order.
Less CameraIconItem dependency to preprare camera Icon View Qt4 model/view port.
BUGS: 260669
BUGS: 246336

M  +1    -0    utilities/cameragui/items/cameraiconitem.cpp
M  +2    -4    utilities/cameragui/controller/camerahistoryupdater.cpp
M  +1    -1    utilities/cameragui/controller/camerathumbsctrl.cpp
M  +24   -33   utilities/cameragui/main/cameraui.cpp

http://commits.kde.org/digikam/db28ce80274cf9dc8c4eeb6bcb93354aeae93f3b