Bug 260613 - "save changes" should ask for file-format if the edited picture does not exist yet (imported from RAW)
Summary: "save changes" should ask for file-format if the edited picture does not exis...
Status: REPORTED
Alias: None
Product: digikam
Classification: Unclassified
Component: ImageEditor-Versioning (show other bugs)
Version: 2.0.0
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-18 09:40 UTC by S. Burmeister
Modified: 2022-02-02 05:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S. Burmeister 2010-12-18 09:40:48 UTC
Version:           2.0.0 (using KDE 4.5.4) 
OS:                Linux

If one imports a picture from a RAW picture it does not yet exist on the harddisk. Thus clicking on "save changes" should ask which file-format the user would like to use for the picture instead of just applying jpg.

This is only an issue for RAW pictures, since for other pictures the format of the original file can be taken.

Reproducible: Always
Comment 1 Marcel Wiesweg 2010-12-18 15:37:47 UTC
There is a default workspace format defined for versioned files in the settings.
It's currently JPEG per default. We can also have more configurable automatic naming schemes in the future.
Nonetheless, I agree there is need for an action which allows to sets filename, format, and album manually for the current case. Last time I started to implement that, the plan ran in a circle and ended with reusing the export/save as dialog, but that solution was not convincing so I postponed.
Comment 2 caulier.gilles 2011-12-13 14:04:41 UTC
Sven,

Do you see comment #1 from Marcel ?

Gilles Caulier
Comment 3 caulier.gilles 2014-08-30 22:27:31 UTC
Sven,

Second call about comment #1 from Marcel to read and respond, please...

Gilles Caulier
Comment 4 Andrew Crouthamel 2018-11-12 02:51:25 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Andrew Crouthamel 2018-11-21 04:47:14 UTC
Dear Bug Submitter,

This is a reminder that this bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? This bug will be moved back to REPORTED Status for manual review later, which may take a while. If you are able to, please lend us a hand.

Thank you for helping us make KDE software even better for everyone!