Bug 260425 - SVM: Embedded odf files not shown in Calligra
Summary: SVM: Embedded odf files not shown in Calligra
Status: VERIFIED FIXED
Alias: None
Product: calligracommon
Classification: Unclassified
Component: flake-plugins (show other bugs)
Version: 2.0
Platform: Unlisted Binaries All
: NOR normal (vote)
Target Milestone: ---
Assignee: Calligra Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-10 16:52 UTC by Lassi Nieminen
Modified: 2011-06-16 11:02 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Test document to be tested in Openoffice and Kpresenter. (38.00 KB, application/x-zip-compressed)
2009-12-10 16:52 UTC, David Faure
Details
Screenshot when viewed in kpresenter. (175.03 KB, image/pjpeg)
2009-12-10 16:53 UTC, David Faure
Details
Screenshot when viewed in Openoffice. (188.07 KB, image/pjpeg)
2009-12-10 16:53 UTC, David Faure
Details
Test data in .odt format (43.10 KB, application/octet-stream)
2011-05-11 16:45 UTC, swathi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Faure 2010-12-17 19:41:15 UTC


---- Reported by faure@kde.org 2010-03-22 12:44:57 ----




---- Reported by lassi.ta.nieminen@nokia.com 2009-12-10 17:52:56 +0200 ----

Created an attachment
Test document to be tested in Openoffice and Kpresenter.

SOFTWARE VERSION:
Kubuntu version 9.04
KOffice Version 1056420
Test Document(Openoffice):oop_content_title_4object.odp

STEPS LEADING TO PROBLEM: 

1.Open the ODP file in OpenOffice.
2.Open the same document in KPresenter.
3.Observe the first slide.


EXPECTED OUTCOME:
The slide with title and 4 slide should be displayed.See
attachment(oop_title_4object.jpeg).

ACTUAL OUTCOME:
The slide with title and 4 objects is not displayed completely.See
attachment(oo_title_4object.jpeg)

FREQUENCY OF OCCURRENCE: 
Always



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-12-10 17:53:34 +0200 ----

Created an attachment
Screenshot when viewed in kpresenter.



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-12-10 17:53:50 +0200 ----

Created an attachment
Screenshot when viewed in Openoffice.



--- Bug imported by faure@kde.org 2010-03-22 12:44  ---

This bug was previously known as _bug_ 150312.

Imported an attachment (id=42059)
Imported an attachment (id=42060)
Imported an attachment (id=42061)




---- Additional Comments From boud@valdyas.org 2010-03-23 10:46:21 ----

Not filter but core bugs.



---- Additional Comments From t.zachmann@zagge.de 2010-03-28 07:44:48 ----

This file embeds an ods and an odg file. Currently that is not supported by koffice. There are replacement graphics written by OO but these are in an OO format and therefore not much of a help.



---- Additional Comments From boud@valdyas.org 2010-04-21 19:30:48 ----

*** http://bugs.kde.org/show_bug.cgi?id=231682 has been marked as a duplicate of this bug. ***



---- Additional Comments From boud@valdyas.org 2010-04-21 19:45:45 ----

*** http://bugs.kde.org/show_bug.cgi?id=231719 has been marked as a duplicate of this bug. ***



---- Additional Comments From zander@kde.org 2010-07-15 13:00:34 ----

Is this fixed in r1148808 ?



--- Bug imported by faure@kde.org 2010-12-17 19:42  ---

This bug was previously known as bug 231715.

Imported an attachment (id=54885)
Imported an attachment (id=54886)
Imported an attachment (id=54887)

The original submitter of attachment 54885 [details] is unknown.
   Reassigning to the person who moved it here: faure@kde.org.
The original submitter of attachment 54886 [details] is unknown.
   Reassigning to the person who moved it here: faure@kde.org.
The original submitter of attachment 54887 [details] is unknown.
   Reassigning to the person who moved it here: faure@kde.org.

Comment 1 swathi 2011-05-11 16:45:47 UTC
Created attachment 59906 [details]
Test data in .odt format

Even .odt format also,embedded odp,odt,ods files are not displaying properly.
Attaching the test data in .odt format.
Comment 2 Inge Wallin 2011-05-11 20:58:09 UTC
Edited the title.  We're not Koffice any more :)
Comment 3 Inge Wallin 2011-05-11 22:41:03 UTC
Git commit 32d4bcec89c73bf19241326d669bf32c2f110571 by Inge Wallin.
Committed on 11/05/2011 at 22:39.
Pushed by ingwa into branch 'master'.

SVM: Make the origin part of MapMode work.

There is still scaling to do.  Need a testfile for that.

This makes the testfile in bug 260425 look ok even if there are still
a couple of issues with the text alignment and placement.

CCBUG: 260425

M  +4    -1    plugins/vectorshape/libsvm/SvmPainterBackend.cpp     

http://commits.kde.org/calligra/32d4bcec89c73bf19241326d669bf32c2f110571
Comment 4 Inge Wallin 2011-05-11 22:45:06 UTC
Moved to flake-plugins component.  

After the rendering of the backup pictures (SVM) is nice enough, this bug should perhaps be moved to the embedding component to address the real bug: that we don't handle embedded documents except for charts and formulas.
Comment 5 Inge Wallin 2011-05-12 14:41:00 UTC
This bug is fixed now.  Swathi will raise individual bugs for outstanding minor formatting issues.
Comment 6 swathi 2011-06-16 11:02:49 UTC
Verified in  418b733f49c666c5204b0576f1c33c5587496a7e.