Bug 260354 - trust flag per address to allow displaying of HTML emails
Summary: trust flag per address to allow displaying of HTML emails
Status: RESOLVED FIXED
Alias: None
Product: kaddressbook
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-17 10:23 UTC by Martin Koller
Modified: 2013-01-29 12:25 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.9.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Koller 2010-12-17 10:23:54 UTC
Version:           unspecified (using KDE 4.5.4) 
OS:                Linux

Allow to define a trust flag per address so that all emails from this contact will be immediately displayed correctly when received as HTML.

Currently an HTML-only email is only displayed correctly when I explicitely "trust" this user inside kmail by clicking on a special link displayed in the mail viewer, or when I set the complete folder to prefer HTML mails.

In fact, I trust a specific user, and this should be possible to define globally in the addressbook, because when I rearrange my mails (e.g. I move the mail from one folder to a different one), then I again have the display problem and only the option to allow HTML for the complete folder or the cumbersome way to always click on the link inside the mail viewer.

Reproducible: Didn't try
Comment 1 Laurent Montel 2012-11-16 09:34:11 UTC
Fixed in 4.9.3
Comment 2 Martin Koller 2013-01-24 09:34:42 UTC
Can you tell me HOW I can enable this trust flag per address, please ?
I'm using KDE 4.10 RC3 and can not see it in kaddressbook.
Comment 3 Laurent Montel 2013-01-25 08:40:30 UTC
edit contact -> contact -> prefer to receive messages formatted as "..." => select html or plain text.
Comment 4 Martin Koller 2013-01-25 10:07:58 UTC
This flag is named "prefers to RECEIVE messages..." - I'm talking about SEEING these messages as HTML. Maybe the flag is used for both directions ? If so, one should change the text to "prefers to USE messages formatted as.." or something similar.

BUT: The main problem is: that flag does not do anything.
I changed it for one of my addressbook entries from which I have an HTML mail in my inbox. The inbox does not have the "prefer HTML" flag set, so when I select the message from this contact, I still see the html source with the red warning rectangle.
Also sending to this contact does not create an HTML mail.
What am I missing ?
Comment 5 Laurent Montel 2013-01-25 10:27:12 UTC
yes perhaps text is not ok
""The main problem is: that flag does not do anything." because it needs to be indexed in nepomuk
for me your contact is not indexed so it can't find this settings.
Comment 6 Martin Koller 2013-01-25 11:07:46 UTC
How can I check if this contact is indexed ? (Nepomuk is enabled, mail indexing is enabled)
And how can I force it to be indexed if it is not ?
Comment 7 Martin Koller 2013-01-26 11:06:38 UTC
I have now removed all 2 addressbooks, re-added them again.
With akonadiconsole I saw that akonadi_nepomuk_feeder was "not running", which I then restarted from here and waited until it says "Indexing completed."
After the reindexing was done, I again started kmail, checked that on a new mail the addressee completion works for this contact, then clicked on the mail from this contact in my inbox and I STILL see the HTML source.
This simply does not work.

The addressbook I'm using here is a vcard dir. What I feel strange is that when I change the HTML flag for a contact, a NEW vcard file is created in the same directory. So in fact this vcard dir now has this contact twice (although kaddressbook only lists the one I changed)
Comment 8 Laurent Montel 2013-01-29 12:25:32 UTC
"This simply does not work." works fine here.
I define "HTML" and I saw html format.
if I define "Plain text" I have just plain text.

So for me it works fine.