Bug 260350 - plasma-desktop crashes intermittently at startup
Summary: plasma-desktop crashes intermittently at startup
Status: RESOLVED DUPLICATE of bug 257741
Alias: None
Product: plasma4
Classification: Unclassified
Component: desktop (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-17 09:56 UTC by Michael J Gruber
Modified: 2011-01-01 16:56 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Kcrash report (8.26 KB, application/octet-stream)
2010-12-17 09:56 UTC, Michael J Gruber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael J Gruber 2010-12-17 09:56:02 UTC
Created attachment 54854 [details]
Kcrash report

Version:           unspecified (using KDE 4.5.4) 
OS:                Linux

Boot system and login via KDM. plasma-desktop crashes but kwin works.

The crash can be reproduced some of the time.

Sometimes, plasma-desktop is restarted automatically; sometimes I have to do that manually.

Reproducible: Sometimes

Steps to Reproduce:
Boot system and login via KDM. plasma-desktop crashes but kwin works.

The crash can be reproduced some of the time.

Actual Results:  
plasma-desktop crashes.
Sometimes, plasma-desktop is restarted automatically; sometimes I have to do that manually.

Expected Results:  
plasma-desktop starts without crash.
If it does crash, it should be always restarted.

This is on an system x86_64 which is booted (from an external drive) on different hardware interchangeably. One has Intel onboard graphics, the other Nvidia Quadro (laptop).

I do not use proprietary drivers.
I do use gallium (mesa-dri-drivers-experimental) but the crash happens on both systems. It does not happen only when switching between both systems.

Desktop effects with openGL are enabled and working.
Comment 1 Dario Andres 2010-12-17 17:00:51 UTC
[Comment from a bug triager]
The crash is related to a library which reads the EXIF (meta)information of some picture files, which are loaded by the Frame plugin.
Just to be sure of that you can try removing the Frame images from your desktop.
You can also try to update your system.
If you re-add the Frame plasmoid and Plasma crash again, then we can track down the bug and report it to the EXIF/libkexiv developers
Regards
Comment 2 Michael J Gruber 2010-12-17 17:06:20 UTC
(In reply to comment #1)
> [Comment from a bug triager]
> The crash is related to a library which reads the EXIF (meta)information of
> some picture files, which are loaded by the Frame plugin.
> Just to be sure of that you can try removing the Frame images from your
> desktop.

Thanks for the hint! I'll try that but have to wait for at least a week to see whether it helps reproducibly.

> You can also try to update your system.

Well, Fedora 14 with current updates... I've had this problem with several KDE 4.5.x but we may have 4.6 soon in kde-redhat.

> If you re-add the Frame plasmoid and Plasma crash again, then we can track down
> the bug and report it to the EXIF/libkexiv developers
> Regards

Thanks!
Comment 3 Dario Andres 2010-12-17 17:07:09 UTC
[Comment from a bug triager]
This could be related to bug 257741.
Comment 4 Marco Martin 2010-12-18 19:40:23 UTC
backtraces go in comments

Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.4 (KDE 4.5.4)
Qt Version: 4.7.1
Operating System: Linux 2.6.35.9-64.fc14.x86_64 x86_64

-- Information about the crash:
Boot system and login via KDM. plasma-desktop crashes but kwin works.

The crash can be reproduced some of the time.

Sometimes, plasma-desktop is restarted automatically; sometimes I have to do that manually.

-- Backtrace:
Application: Plasma-Arbeitsfläche (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f73ad48e840 (LWP 2345))]

Thread 2 (Thread 0x7f738f9d6700 (LWP 2364)):
[KCrash Handler]
#6  0x00000039c866c734 in ?? () from /usr/lib64/libstdc++.so.6
#7  0x00000039c866c9c8 in std::_Rb_tree_insert_and_rebalance(bool, std::_Rb_tree_node_base*, std::_Rb_tree_node_base*, std::_Rb_tree_node_base&) () from /usr/lib64/libstdc++.so.6
#8  0x00000039d670c558 in std::_Rb_tree<std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::pair<std::basic_string<char, std::char_traits<char>, std::allocator<char> > const, std::basic_string<char, std::char_traits<char>, std::allocator<char> > >, std::_Select1st<std::pair<std::basic_string<char, std::char_traits<char>, std::allocator<char> > const, std::basic_string<char, std::char_traits<char>, std::allocator<char> > > >, std::less<std::basic_string<char, std::char_traits<char>, std::allocator<char> > >, std::allocator<std::pair<std::basic_string<char, std::char_traits<char>, std::allocator<char> > const, std::basic_string<char, std::char_traits<char>, std::allocator<char> > > > >::_M_insert_(std::_Rb_tree_node_base const*, std::_Rb_tree_node_base const*, std::pair<std::basic_string<char, std::char_traits<char>, std::allocator<char> > const, std::basic_string<char, std::char_traits<char>, std::allocator<char> > > const&) () from /usr/lib64/libexiv2.so.9
#9  0x00000039d670c750 in std::_Rb_tree<std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::pair<std::basic_string<char, std::char_traits<char>, std::allocator<char> > const, std::basic_string<char, std::char_traits<char>, std::allocator<char> > >, std::_Select1st<std::pair<std::basic_string<char, std::char_traits<char>, std::allocator<char> > const, std::basic_string<char, std::char_traits<char>, std::allocator<char> > > >, std::less<std::basic_string<char, std::char_traits<char>, std::allocator<char> > >, std::allocator<std::pair<std::basic_string<char, std::char_traits<char>, std::allocator<char> > const, std::basic_string<char, std::char_traits<char>, std::allocator<char> > > > >::_M_insert_unique(std::pair<std::basic_string<char, std::char_traits<char>, std::allocator<char> > const, std::basic_string<char, std::char_traits<char>, std::allocator<char> > > const&) () from /usr/lib64/libexiv2.so.9
#10 0x00000039d670c8da in std::_Rb_tree<std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::pair<std::basic_string<char, std::char_traits<char>, std::allocator<char> > const, std::basic_string<char, std::char_traits<char>, std::allocator<char> > >, std::_Select1st<std::pair<std::basic_string<char, std::char_traits<char>, std::allocator<char> > const, std::basic_string<char, std::char_traits<char>, std::allocator<char> > > >, std::less<std::basic_string<char, std::char_traits<char>, std::allocator<char> > >, std::allocator<std::pair<std::basic_string<char, std::char_traits<char>, std::allocator<char> > const, std::basic_string<char, std::char_traits<char>, std::allocator<char> > > > >::_M_insert_unique_(std::_Rb_tree_const_iterator<std::pair<std::basic_string<char, std::char_traits<char>, std::allocator<char> > const, std::basic_string<char, std::char_traits<char>, std::allocator<char> > > >, std::pair<std::basic_string<char, std::char_traits<char>, std::allocator<char> > const, std::basic_string<char, std::char_traits<char>, std::allocator<char> > > const&) () from /usr/lib64/libexiv2.so.9
#11 0x00000039d671e788 in ?? () from /usr/lib64/libexiv2.so.9
#12 0x00000039d671ee91 in ?? () from /usr/lib64/libexiv2.so.9
#13 0x00000039d6742104 in ?? () from /usr/lib64/libexiv2.so.9
#14 0x00000039d6714fe4 in ?? () from /usr/lib64/libexiv2.so.9
#15 0x00000039d670d35d in Exiv2::XmpParser::initialize() () from /usr/lib64/libexiv2.so.9
#16 0x00000039d6710b05 in Exiv2::XmpParser::decode(Exiv2::XmpData&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&) () from /usr/lib64/libexiv2.so.9
#17 0x00000039d6699c96 in Exiv2::JpegBase::readMetadata() () from /usr/lib64/libexiv2.so.9
#18 0x00007f73999a5868 in KExiv2Iface::KExiv2::load(QString const&) const () from /usr/lib64/libkexiv2.so.8
#19 0x00007f7399c2a073 in ?? () from /usr/lib64/kde4/plasma_applet_frame.so
#20 0x00007f7399c2a2e7 in ?? () from /usr/lib64/kde4/plasma_applet_frame.so
#21 0x0000003289c68cc8 in ?? () from /usr/lib64/libQtCore.so.4
#22 0x0000003289c726ee in ?? () from /usr/lib64/libQtCore.so.4
#23 0x00000039c3206d5b in start_thread () from /lib64/libpthread.so.0
#24 0x00000039c26e4aad in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f73ad48e840 (LWP 2345)):
#0  0x00000039c26db0b3 in poll () from /lib64/libc.so.6
#1  0x00000039c5208b6a in ?? () from /usr/lib64/libxcb.so.1
#2  0x00000039c52090b3 in ?? () from /usr/lib64/libxcb.so.1
#3  0x00000039c5209144 in xcb_writev () from /usr/lib64/libxcb.so.1
#4  0x00000039c4e4d546 in _XSend () from /usr/lib64/libX11.so.6
#5  0x00000039c4e4da87 in _XReply () from /usr/lib64/libX11.so.6
#6  0x00000039c4e2a577 in XGetWindowProperty () from /usr/lib64/libX11.so.6
#7  0x00000039c4e2b333 in XGetWMColormapWindows () from /usr/lib64/libX11.so.6
#8  0x000000328b651676 in QWidgetPrivate::setParent_sys(QWidget*, QFlags<Qt::WindowType>) () from /usr/lib64/libQtGui.so.4
#9  0x000000328b60bc98 in QWidget::setParent(QWidget*, QFlags<Qt::WindowType>) () from /usr/lib64/libQtGui.so.4
#10 0x000000328b60c4c5 in QWidget::setWindowFlags(QFlags<Qt::WindowType>) () from /usr/lib64/libQtGui.so.4
#11 0x0000003236f6311a in ?? () from /usr/lib64/libplasma.so.3
#12 0x0000003236f0e4f9 in Plasma::Applet::flushPendingConstraintsEvents() () from /usr/lib64/libplasma.so.3
#13 0x0000003236f21197 in ?? () from /usr/lib64/libplasma.so.3
#14 0x0000003236f32f34 in ?? () from /usr/lib64/libplasma.so.3
#15 0x0000003236f34003 in Plasma::Corona::loadLayout(QString const&) () from /usr/lib64/libplasma.so.3
#16 0x0000003236f340d2 in Plasma::Corona::initializeLayout(QString const&) () from /usr/lib64/libplasma.so.3
#17 0x000000323564f412 in ?? () from /usr/lib64/libkdeinit4_plasma-desktop.so
#18 0x000000323564f723 in ?? () from /usr/lib64/libkdeinit4_plasma-desktop.so
#19 0x0000003235650dce in ?? () from /usr/lib64/libkdeinit4_plasma-desktop.so
#20 0x0000003289d6fb4a in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#21 0x000000328b5b9f56 in QApplication::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#22 0x000000328b5b78c4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#23 0x000000328b5bc3da in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#24 0x0000003232e20566 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#25 0x0000003289d5b7ac in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#26 0x0000003289d5ef95 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#27 0x0000003289d86723 in ?? () from /usr/lib64/libQtCore.so.4
#28 0x00000039c4241e33 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#29 0x00000039c4242610 in ?? () from /lib64/libglib-2.0.so.0
#30 0x00000039c42428ad in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#31 0x0000003289d868bf in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#32 0x000000328b65c59e in ?? () from /usr/lib64/libQtGui.so.4
#33 0x0000003289d5ab42 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#34 0x0000003289d5ad8c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#35 0x0000003289d5f24b in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#36 0x0000003235637f88 in kdemain () from /usr/lib64/libkdeinit4_plasma-desktop.so
#37 0x00000039c261ee7d in __libc_start_main () from /lib64/libc.so.6
#38 0x0000000000400849 in _start ()

An https://bugs.kde.org berichten
Comment 5 Dario Andres 2011-01-01 16:56:29 UTC

*** This bug has been marked as a duplicate of bug 257741 ***