Bug 260159 - Underline is drawn incorrectly at line end for justified text.
Summary: Underline is drawn incorrectly at line end for justified text.
Status: RESOLVED FIXED
Alias: None
Product: calligracommon
Classification: Unclassified
Component: text-tool (show other bugs)
Version: 2.2
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Calligra Words Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-06 14:27 UTC by Leonardo La Malfa
Modified: 2011-02-09 17:23 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot (45.57 KB, image/png)
2010-06-06 14:27 UTC, David Faure
Details
Screenshot2, Screenshot3 and Untitled 1 (370.82 KB, application/x-compressed-tar)
2010-06-06 16:37 UTC, David Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Faure 2010-12-16 00:29:44 UTC


---- Reported by lamalfaleonardo@gmail.com 2010-06-06 14:27:06 ----

Created an attachment
screenshot

Version:           2.2 (using KDE 4.4.3) 
OS:                Linux

As shown in the screenshot, words close to the right margin don't show underline correctly. It's still there, for if I delete some words from the beginning of the sentence, they're correctly underlined, so it's a visual glitch, I guess. Sometimes this effect is present in single words two or thee words away from the right margin, and not necessarily part of a long sentence that continue in the following line, like in the examples from the screenshot.

This is not always reproducible, so in the same text sometimes it happens, sometimes I doesn't. It is worth noting, also, that the document had been created in OpenOffice. However, I tried reproducing the same issue in a new KWord document, and the effect was exactly the same.

Reproducible: Didn't try




OS: Linux (i686) release 2.6.32-22-generic
Compiler: cc



---- Additional Comments From zander@kde.org 2010-06-06 15:20:30 ----

Your report doesn't allow any way to reproduce this issue, please consider attaching a test document if this problem shows consistently for you.



---- Additional Comments From lamalfaleonardo@gmail.com 2010-06-06 16:37:40 ----

Created an attachment
Screenshot2, Screenshot3 and Untitled 1

Alright, sorry. This is how you can reproduce it:

1. Go to: http://www.unita.it/news/culture/99646/rai_chi_firma_per_saviano_appello_contro_il_taglio_delle_puntate_?
2. Copy the first paragraph.
3. Open OO Writer.
4. Paste the copied content in the new OO window.
5. Select all text, then apply Justified alignment.
6. Underline some random sentences, or single words, preferably closer to the right margin.
7. Save it, then open the document with KWord.

Screenshot2 and Screenshot3 show how the same text is shown in OpenOffice and KOffice, respectively, at my end. Attachment Untitled 1.odt is the file saved with OO. It's worth noting my KDE version is 4.4.4 but couldn't choose it because it doesn't show up in the options when filing bugs. Please let me know if I can be of further assistance.



--- Bug imported by faure@kde.org 2010-12-16 00:31  ---

This bug was previously known as bug 240895.

Imported an attachment (id=54753)
Imported an attachment (id=54754)

The original submitter of attachment 54753 [details] is unknown.
   Reassigning to the person who moved it here: faure@kde.org.
The original submitter of attachment 54754 [details] is unknown.
   Reassigning to the person who moved it here: faure@kde.org.

Comment 1 Sebastian Sauer 2011-02-09 17:23:03 UTC
Fixed with 932793fb322de2ae42b3f74de7bba64a580ee6bc