Bug 259955 - ksysguard crashed after kill process
Summary: ksysguard crashed after kill process
Status: RESOLVED DUPLICATE of bug 251719
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-15 14:18 UTC by ismailoff
Modified: 2011-03-19 13:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ismailoff 2010-12-15 14:18:33 UTC
Application: ksysguard (4.4.4 (KDE 4.4.4) "release 3")
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.5-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
New System, only updates

The crash can be reproduced every time.

 -- Backtrace:
Application: Системный монитор (kdeinit4), signal: Floating point exception
[KCrash Handler]
#6  0xb773110a in enter.8102 () from /lib/ld-linux.so.2
#7  0xb7731771 in do_lookup_x () from /lib/ld-linux.so.2
#8  0xb7731b49 in _dl_lookup_symbol_x () from /lib/ld-linux.so.2
#9  0xb773345b in _dl_relocate_object () from /lib/ld-linux.so.2
#10 0xb773a823 in dl_open_worker () from /lib/ld-linux.so.2
#11 0xb773650f in _dl_catch_error () from /lib/ld-linux.so.2
#12 0xb773a2e6 in _dl_open () from /lib/ld-linux.so.2
#13 0xb5ad2bdd in dlopen_doit () from /lib/libdl.so.2
#14 0xb773650f in _dl_catch_error () from /lib/ld-linux.so.2
#15 0xb5ad3342 in _dlerror_run () from /lib/libdl.so.2
#16 0xb5ad2ca7 in dlopen@@GLIBC_2.1 () from /lib/libdl.so.2
#17 0xb6bb0469 in ?? () from /usr/lib/libQtCore.so.4
#18 0xb6baa9c4 in ?? () from /usr/lib/libQtCore.so.4
#19 0xb6baaaa8 in ?? () from /usr/lib/libQtCore.so.4
#20 0xb6ba5223 in QPluginLoader::load() () from /usr/lib/libQtCore.so.4
#21 0xb6ba5252 in QPluginLoader::instance() () from /usr/lib/libQtCore.so.4
#22 0xb75771ac in KAuth::BackendsManager::retrieveInstancesIn(QString const&) () from /usr/lib/libkdecore.so.5
#23 0xb75ddc54 in KAuth::BackendsManager::init() () from /usr/lib/libkdecore.so.5
#24 0xb75de4a5 in KAuth::BackendsManager::authBackend() () from /usr/lib/libkdecore.so.5
#25 0xb75dee6f in KAuth::Action::Action(QString const&) () from /usr/lib/libkdecore.so.5
#26 0xb1b33f8e in KSysGuardProcessList::killProcesses (this=0x833c588, pids=..., sig=15) at /usr/src/debug/kdebase-workspace-4.4.4/libs/ksysguard/processui/ksysguardprocesslist.cpp:1193
#27 0xb1b3490f in KSysGuardProcessList::killSelectedProcesses (this=0x833c588) at /usr/src/debug/kdebase-workspace-4.4.4/libs/ksysguard/processui/ksysguardprocesslist.cpp:1251
#28 0xb1b36a6d in KSysGuardProcessList::actionTriggered (this=0x833c588, object=0x82f2a68) at /usr/src/debug/kdebase-workspace-4.4.4/libs/ksysguard/processui/ksysguardprocesslist.cpp:495
#29 0xb1b36c9e in KSysGuardProcessList::qt_metacall (this=0x833c588, _c=QMetaObject::InvokeMetaMethod, _id=23, _a=0xbfaa2b08)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/libs/ksysguard/processui/ksysguardprocesslist.moc:178
#30 0xb6bc5efd in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#31 0xb6bd4fe8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#32 0xb6bd8685 in QSignalMapper::mapped(QObject*) () from /usr/lib/libQtCore.so.4
#33 0xb6bd87c9 in QSignalMapper::map(QObject*) () from /usr/lib/libQtCore.so.4
#34 0xb6bd891e in QSignalMapper::map() () from /usr/lib/libQtCore.so.4
#35 0xb6bd8ec0 in QSignalMapper::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#36 0xb6bc5efd in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#37 0xb6bd4fe8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#38 0xb60f2a0d in QAction::triggered (this=0x82f2a68, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#39 0xb60f2cab in QAction::activate (this=0x82f2a68, event=QAction::Trigger) at kernel/qaction.cpp:1255
#40 0xb658cfb5 in QMenuPrivate::activateCausedStack (this=0x82baea0, causedStack=..., action=0x82f2a68, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1002
#41 0xb6593c87 in QMenuPrivate::activateAction (this=0x82baea0, action=0x82f2a68, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1094
#42 0xb6595058 in QMenu::mouseReleaseEvent (this=0x828fcb0, e=0xbfaa3464) at widgets/qmenu.cpp:2312
#43 0xb6152f00 in QWidget::event (this=0x828fcb0, event=0xbfaa3464) at kernel/qwidget.cpp:8044
#44 0xb65950dc in QMenu::event (this=0x828fcb0, e=0xbfaa3464) at widgets/qmenu.cpp:2421
#45 0xb60f9c64 in QApplicationPrivate::notify_helper (this=0x80ecfb0, receiver=0x828fcb0, e=0xbfaa3464) at kernel/qapplication.cpp:4302
#46 0xb6102750 in QApplication::notify (this=0xbfaa317c, receiver=0x828fcb0, e=0xbfaa3464) at kernel/qapplication.cpp:3867
#47 0xb6e039d1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#48 0xb6bbfe0e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#49 0xb60fac4c in sendSpontaneousEvent (receiver=0x828fcb0, event=0xbfaa3464, alienWidget=0x0, nativeWidget=0x828fcb0, buttonDown=0xb6a44078, lastMouseReceiver=..., spontaneous=true)
    at ../../src/corelib/kernel/qcoreapplication.h:218
#50 QApplicationPrivate::sendMouseEvent (receiver=0x828fcb0, event=0xbfaa3464, alienWidget=0x0, nativeWidget=0x828fcb0, buttonDown=0xb6a44078, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:2965
#51 0xb6182766 in QETWidget::translateMouseEvent (this=0x828fcb0, event=0xbfaa397c) at kernel/qapplication_x11.cpp:4314
#52 0xb618173e in QApplication::x11ProcessEvent (this=0x80ecf08, event=0xbfaa397c) at kernel/qapplication_x11.cpp:3391
#53 0xb61aa570 in x11EventSourceDispatch (s=0x80f00a8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#54 0xb5842b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#55 0xb5843350 in ?? () from /usr/lib/libglib-2.0.so.0
#56 0xb584360e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#57 0xb6bebd4b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#58 0xb61aa19a in QGuiEventDispatcherGlib::processEvents (this=0x805ee10, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#59 0xb6bbf11d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#60 0xb6bbf319 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#61 0xb6bc3c70 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#62 0xb60f7164 in QApplication::exec () at kernel/qapplication.cpp:3581
#63 0xb1c39335 in kdemain () from /usr/lib/libkdeinit4_ksysguard.so
#64 0x0804e5b1 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2010-12-15 14:52:45 UTC
[Comment from a bug triager]
- Do you use the NVidia official driver ? This bug may be related to bug 251719.
Regards
Comment 2 Dario Andres 2010-12-31 23:02:01 UTC
[Comment from a bug triager]
Waiting for a reply.
Comment 3 Christoph Feck 2011-03-19 13:43:40 UTC

*** This bug has been marked as a duplicate of bug 251719 ***