Bug 259899 - Crash/unstable when loading many torrents.
Summary: Crash/unstable when loading many torrents.
Status: RESOLVED DUPLICATE of bug 266622
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Slackware Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-14 23:33 UTC by thordn
Modified: 2011-02-19 18:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description thordn 2010-12-14 23:33:39 UTC
Application: ktorrent (4.0.4)
KDE Platform Version: 4.4.3 (KDE 4.4.3)
Qt Version: 4.6.2
Operating System: Linux 2.6.33.4 x86_64
Distribution (Platform): Slackware Packages

-- Information about the crash:
Tried to load ~20.000 torrents from folder, folder opened fast first time, took about 10 minutes att 100% cpu load on following openings. Selected all torrents, and clicked <open> got to open about 200 torrents before hang, then crash after a few minutes, tried this two times, started with 1400 torrents, then about 1600, so at last time was at about 1800 torrents. Settings: 200 max downloads, 100 max seeds. Crashed when looking for version info in "about ktorrent".

Also got an error for a torrent: "Too many open files."...


The crash can be reproduced every time.

 -- Backtrace:
Application: KTorrent (ktorrent), signal: Segmentation fault
Traceback (most recent call last):
  File "/usr/share/gdb/auto-load/usr/lib64/libgobject-2.0.so.0.2200.5-gdb.py", line 9, in <module>
    from gobject import register
  File "/usr/share/glib-2.0/gdb/gobject.py", line 3, in <module>
    import gdb.backtrace
ImportError: No module named backtrace
[Current thread is 1 (Thread 0x7f1a153d7760 (LWP 28302))]

Thread 5 (Thread 0x7f19f4060710 (LWP 28365)):
#0  0x00007f1a126cca49 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f1a12961195 in ?? () from /usr/lib64/libQtCore.so.4
#2  0x00007f1a129612f0 in QThread::msleep(unsigned long) () from /usr/lib64/libQtCore.so.4
#3  0x00007f1a14ef187d in net::DownloadThread::update (this=0x6e1ae0) at /thome/tn/sw/x/libktorrent-1.0.4/src/net/downloadthread.cpp:91
#4  0x00007f1a14ef2169 in net::NetworkThread::run (this=0x6e1ae0) at /thome/tn/sw/x/libktorrent-1.0.4/src/net/networkthread.cpp:48
#5  0x00007f1a12961815 in ?? () from /usr/lib64/libQtCore.so.4
#6  0x00007f1a126c7980 in start_thread () from /lib64/libpthread.so.0
#7  0x00007f1a10fbc57d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f19f285d710 (LWP 28366)):
#0  0x00007f1a126cca49 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f1a12961195 in ?? () from /usr/lib64/libQtCore.so.4
#2  0x00007f1a129612f0 in QThread::msleep(unsigned long) () from /usr/lib64/libQtCore.so.4
#3  0x00007f1a14ef0f2d in net::UploadThread::update (this=0x6e2130) at /thome/tn/sw/x/libktorrent-1.0.4/src/net/uploadthread.cpp:89
#4  0x00007f1a14ef2169 in net::NetworkThread::run (this=0x6e2130) at /thome/tn/sw/x/libktorrent-1.0.4/src/net/networkthread.cpp:48
#5  0x00007f1a12961815 in ?? () from /usr/lib64/libQtCore.so.4
#6  0x00007f1a126c7980 in start_thread () from /lib64/libpthread.so.0
#7  0x00007f1a10fbc57d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f19f305e710 (LWP 28420)):
#0  0x00007f1a126cca49 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f1a12962742 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f1a12957c19 in ?? () from /usr/lib64/libQtCore.so.4
#3  0x00007f1a12961815 in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007f1a126c7980 in start_thread () from /lib64/libpthread.so.0
#5  0x00007f1a10fbc57d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f19f385f710 (LWP 28428)):
#0  0x00007f1a10fb2ec3 in poll () from /lib64/libc.so.6
#1  0x00007f1a0d06e383 in send_dg () from /lib64/libresolv.so.2
#2  0x00007f1a0d070004 in __libc_res_nsend () from /lib64/libresolv.so.2
#3  0x00007f1a0d06c635 in __libc_res_nquery () from /lib64/libresolv.so.2
#4  0x00007f1a0d06cbf1 in __libc_res_nquerydomain () from /lib64/libresolv.so.2
#5  0x00007f1a0d06d775 in __libc_res_nsearch () from /lib64/libresolv.so.2
#6  0x00007f19f50662c8 in _nss_dns_gethostbyname3_r () from /lib64/libnss_dns.so.2
#7  0x00007f19f5066584 in _nss_dns_gethostbyname2_r () from /lib64/libnss_dns.so.2
#8  0x00007f1a10fa4cbb in gaih_inet () from /lib64/libc.so.6
#9  0x00007f1a10fa6712 in getaddrinfo () from /lib64/libc.so.6
#10 0x00007f1a1375fba3 in ?? () from /usr/lib64/libQtNetwork.so.4
#11 0x00007f1a1375573c in ?? () from /usr/lib64/libQtNetwork.so.4
#12 0x00007f1a12957b89 in ?? () from /usr/lib64/libQtCore.so.4
#13 0x00007f1a12961815 in ?? () from /usr/lib64/libQtCore.so.4
#14 0x00007f1a126c7980 in start_thread () from /lib64/libpthread.so.0
#15 0x00007f1a10fbc57d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f1a153d7760 (LWP 28302)):
[KCrash Handler]
#5  0x00007f1a12a6b4f1 in QObject::~QObject() () from /usr/lib64/libQtCore.so.4
#6  0x00007f1a14efb532 in ~Authenticate (this=0x4cd2a20, __in_chrg=<value optimized out>) at /thome/tn/sw/x/libktorrent-1.0.4/src/peer/authenticate.cpp:84
#7  0x00007f1a12a65add in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#8  0x00007f1a11bd8cbc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#9  0x00007f1a11bdf2bb in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#10 0x0000000000438e7a in kt::App::notify (this=0x4cd2a20, receiver=0x0, event=0x68) at /thome/tn/sw/x/ktorrent-4.0.4/ktorrent/app.cpp:97
#11 0x00007f1a12a55e1c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#12 0x00007f1a12a58597 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#13 0x00007f1a12a7f773 in ?? () from /usr/lib64/libQtCore.so.4
#14 0x00007f1a0c7acf9e in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#15 0x00007f1a0c7b0958 in ?? () from /usr/lib64/libglib-2.0.so.0
#16 0x00007f1a0c7b0a80 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#17 0x00007f1a12a7f2b3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#18 0x00007f1a11c8777e in ?? () from /usr/lib64/libQtGui.so.4
#19 0x00007f1a12a54742 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#20 0x00007f1a12a54b1c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#21 0x00007f1a12a5885b in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#22 0x000000000042852b in main (argc=<value optimized out>, argv=<value optimized out>) at /thome/tn/sw/x/ktorrent-4.0.4/ktorrent/main.cpp:176

Reported using DrKonqi
Comment 1 Joris Guisson 2011-02-19 18:57:33 UTC
This is fixed by the fix of bug 266622

*** This bug has been marked as a duplicate of bug 266622 ***