Bug 259857 - Kile crashed 3 times upon certain editing certain file
Summary: Kile crashed 3 times upon certain editing certain file
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kile
Classification: Applications
Component: general (show other bugs)
Version: 2.0.85
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michel Ludwig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-14 16:41 UTC by lev
Modified: 2010-12-15 14:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lev 2010-12-14 16:41:16 UTC
Application: kile (2.0.85)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-26-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
I was editing file mag_10.tex. After deleting these selected lines(>) from end of the file one empty string left, i hit backspace, kile crashes:
\end{equation}
>}{\omega_{\vec{k}}}$}\end{array}\right)
>\]
>\begin{equation}
>\approx
>\frac{T^2q^2\omega_H}{12(2\pi)^3\omega_{ex}^2}\ln^2\frac{T}
>{\omega_H}\qquad\textrm{при
>$\omega_{ex}(ka)^2\ll\omega_H$}
>\end{equation}
>в этом диапазоне
>\begin{equation}
>\gamma^{(4)}/\gamma^{(3)}\approx
>q\fr
>\end{document}							
I reproduced it three times and after that all worked fine.
Sorry for my english

The crash can be reproduced every time.

 -- Backtrace:
Application: Kile (kile), signal: Segmentation fault
[KCrash Handler]
#5  KateLineLayout::viewLineCount (this=0x0) at ../../kate/render/katelinelayout.cpp:173
#6  0x00007f028f413e2a in KateLayoutCache::viewLine (this=0x4126250, realCursor=...) at ../../kate/render/katelayoutcache.cpp:395
#7  0x00007f028f414421 in KateLayoutCache::textLayout (this=0x4126250, realCursor=...) at ../../kate/render/katelayoutcache.cpp:337
#8  0x00007f028f47994f in KateViewInternal::makeVisible (this=0x3f9a6c0, c=<value optimized out>, endCol=<value optimized out>, force=false, center=<value optimized out>, 
    calledExternally=<value optimized out>) at ../../kate/view/kateviewinternal.cpp:690
#9  0x00007f028f47a009 in KateViewInternal::updateCursor (this=0x3f9a6c0, newCursor=<value optimized out>, force=<value optimized out>, center=false, calledExternally=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:1914
#10 0x00007f028f47ac39 in KateViewInternal::editEnd (this=0x3f9a6c0, editTagLineStart=<value optimized out>, editTagLineEnd=<value optimized out>, tagFrom=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:3399
#11 0x00007f028f3d2d11 in KateDocument::editEnd (this=0x41d3b20) at ../../kate/document/katedocument.cpp:977
#12 0x00007f028f3d9aa6 in KateDocument::removeText (this=0x41d3b20, _range=<value optimized out>, block=<value optimized out>) at ../../kate/document/katedocument.cpp:821
#13 0x00007f028f3db61a in KateDocument::backspace (this=0x41d3b20, view=<value optimized out>, c=<value optimized out>) at ../../kate/document/katedocument.cpp:2906
#14 0x00007f028f460a5c in KateView::backspace (this=0x3c64850) at ../../kate/view/kateview.cpp:2295
#15 0x00007f028f465bbd in KateView::qt_metacall (this=0x3c64850, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffc8f64d70) at ./kateview.moc:373
#16 0x00007f02a06d2e3f in QMetaObject::activate (sender=0x42fbc80, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1) at kernel/qobject.cpp:3293
#17 0x00007f02a102e032 in QAction::triggered (this=0x0, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#18 0x00007f02a10300ab in QAction::activate (this=0x42fbc80, event=<value optimized out>) at kernel/qaction.cpp:1255
#19 0x00007f02a10319b7 in QAction::event (this=0x0, e=<value optimized out>) at kernel/qaction.cpp:1181
#20 0x00007f02a1ec4f3d in KAction::event (this=0x0, event=0x7fffc8f653e0) at ../../kdeui/actions/kaction.cpp:129
#21 0x00007f02a103422c in QApplicationPrivate::notify_helper (this=0x26723b0, receiver=0x42fbc80, e=0x7fffc8f653e0) at kernel/qapplication.cpp:4300
#22 0x00007f02a103a6fb in QApplication::notify (this=0x7fffc8f66990, receiver=0x42fbc80, e=0x7fffc8f653e0) at kernel/qapplication.cpp:4183
#23 0x00007f02a1f9a526 in KApplication::notify (this=0x7fffc8f66990, receiver=0x42fbc80, event=0x7fffc8f653e0) at ../../kdeui/kernel/kapplication.cpp:302
#24 0x00007f02a06c006c in QCoreApplication::notifyInternal (this=0x7fffc8f66990, receiver=0x42fbc80, event=0x7fffc8f653e0) at kernel/qcoreapplication.cpp:704
#25 0x00007f02a106fe86 in QCoreApplication::sendEvent (this=<value optimized out>, e=0x7fffc8f659e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QShortcutMap::dispatchEvent (this=<value optimized out>, e=0x7fffc8f659e0) at kernel/qshortcutmap.cpp:879
#27 0x00007f02a1071c97 in QShortcutMap::tryShortcutEvent (this=0x26724d8, o=<value optimized out>, e=0x7fffc8f659e0) at kernel/qshortcutmap.cpp:364
#28 0x00007f02a103c268 in QApplication::notify (this=0x7fffc8f66990, receiver=0x3f9a6c0, e=0x7fffc8f659e0) at kernel/qapplication.cpp:3746
#29 0x00007f02a1f9a526 in KApplication::notify (this=0x7fffc8f66990, receiver=0x3f9a6c0, event=0x7fffc8f659e0) at ../../kdeui/kernel/kapplication.cpp:302
#30 0x00007f02a06c006c in QCoreApplication::notifyInternal (this=0x7fffc8f66990, receiver=0x3f9a6c0, event=0x7fffc8f659e0) at kernel/qcoreapplication.cpp:704
#31 0x00007f02a10df16a in QKeyMapper::sendKeyEvent (keyWidget=0x3f9a6c0, grab=<value optimized out>, type=QEvent::KeyPress, code=16777219, modifiers=<value optimized out>, text=..., 
    autorepeat=false, count=1, nativeScanCode=22, nativeVirtualKey=65288, nativeModifiers=16) at kernel/qkeymapper_x11.cpp:1861
#32 0x00007f02a10e16f0 in QKeyMapperPrivate::translateKeyEvent (this=0x26adbf0, keyWidget=0x3f9a6c0, event=<value optimized out>, grab=80) at kernel/qkeymapper_x11.cpp:1831
#33 0x00007f02a10b8904 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fffc8f665b0) at kernel/qapplication_x11.cpp:3394
#34 0x00007f02a10e4882 in x11EventSourceDispatch (s=0x2675b30, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#35 0x00007f029c6d66c2 in g_main_dispatch (context=0x2674c40) at gmain.c:1960
#36 IA__g_main_context_dispatch (context=0x2674c40) at gmain.c:2513
#37 0x00007f029c6da548 in g_main_context_iterate (context=0x2674c40, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2591
#38 0x00007f029c6da6fc in IA__g_main_context_iteration (context=0x2674c40, may_block=1) at gmain.c:2654
#39 0x00007f02a06e9513 in QEventDispatcherGlib::processEvents (this=0x264d1a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#40 0x00007f02a10e446e in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x00007f02a06be992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#42 0x00007f02a06bed6c in QEventLoop::exec (this=0x7fffc8f668e0, flags=) at kernel/qeventloop.cpp:201
#43 0x00007f02a06c2aab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#44 0x00000000005f21f2 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2010-12-15 14:36:13 UTC
[Comment from a bug triager]
This is a Kate bug already fixed since KDE SC 4.4.4 and KDE SC 4.5.0. 
The reports were being tracked at bug 226409. Merging. Thanks

*** This bug has been marked as a duplicate of bug 226409 ***