Bug 259783 - picture-orientation is wrong
Summary: picture-orientation is wrong
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Metadata-Orientation (show other bugs)
Version: 1.2.0
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-13 22:40 UTC by Hartmut
Modified: 2017-08-12 06:45 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.5.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hartmut 2010-12-13 22:40:08 UTC
Version:           1.2.0 (using KDE 4.4.4) 
OS:                Linux

I think, we had this bug already in April this year.

My pictures are from several Canon-cameras. If I import them from the card-reader, portrait-photos are shown within the import-window as portrait. After Import the thumbs in the albums are shown portrait. When I click the picture itself, the enlarged view is landscape. When I try to edit the picture, it is shown within the editor-window landscape, same with lighttable. If I click on "rotate" (90 degrees, eg. clockwise), the photo is rotated 180 degrees. If I click on "rotate" again (this time anticlockwise), it is rotated 90 degrees to portrait. Now everything is OK.

Hartmut

This behavior is new, since last Saturday, when I updated everything from KDE. Last update was 4 weeks ago. I found the same behavior some weeks ago, when I tested the version 1.5

Reproducible: Always

Steps to Reproduce:
As mentioned above
Comment 1 caulier.gilles 2010-12-13 22:54:36 UTC
Can you provide some image to test ?

Gilles Caulier
Comment 2 Hartmut 2010-12-13 23:18:46 UTC
Here is the image. Sorry about the quality ;-)

Hartmut

Am 13.12.2010 22:54, schrieb Gilles Caulier:
> https://bugs.kde.org/show_bug.cgi?id=259783
>
>
> Gilles Caulier<caulier.gilles@gmail.com>  changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                   CC|                            |caulier.gilles@gmail.com
>            Component|general                     |Image Editor
>
>
>
>
> --- Comment #1 from Gilles Caulier<caulier gilles gmail com>   2010-12-13 22:54:36 ---
> Can you provide some image to test ?
>
> Gilles Caulier
>
Comment 3 Hartmut 2010-12-15 15:56:15 UTC
Additional information:

up to this bug while downloading the status-line showed "rotating" and "downloading" at every image regardless, if it was landscape ore portrait. And "rotating" took time. Now with landscape images no "rotating" appears and with portraits "rotating" appears so short time, I have look carefully to even see it. So downloading is a lot faster now. It seems that the images are not rotated.

But: the filemanager  and Gwenview show all photos in the correct way.

Hartmut
Comment 4 caulier.gilles 2011-12-18 17:09:55 UTC
Harmut,

This file still valid using digiKam 2.4 ?

Gilles Caulier
Comment 5 Hartmut 2011-12-19 15:44:06 UTC
Gilles,

no, this bug is fixed with digikam 1.8. Thanks a lot.

Hartmut Krummrei

Am 18.12.2011 18:09, schrieb Gilles Caulier:
> https://bugs.kde.org/show_bug.cgi?id=259783
>
>
>
>
>
> --- Comment #4 from Gilles Caulier<caulier gilles gmail com>   2011-12-18 17:09:55 ---
> Harmut,
>
> This file still valid using digiKam 2.4 ?
>
> Gilles Caulier
>