Bug 259706 - Amarok crashes immediately every time phonon-vlc is enabled
Summary: Amarok crashes immediately every time phonon-vlc is enabled
Status: RESOLVED DUPLICATE of bug 259269
Alias: None
Product: phonon-backend-vlc
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Harald Sitter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-13 12:01 UTC by Valorie Zimmerman
Modified: 2011-04-27 21:33 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Valorie Zimmerman 2010-12-13 12:01:22 UTC
My KDE version is actually 4.5.4, but not from git. VLC, phonon-vlc and Amarok are all built from GIT, however -- all up-to-date.

End of the readout right before segfault: 
[0x922480] main libvlc debug: module bank initialized (19 modules)
vlc: unknown option or missing mandatory argument `--logfile=/home/valorie/.vlc/log/vlc-log-4932.txt'
Try `vlc --help' for more information.
libvlc exception:  
"PVLC(2): Using VLC version 1.1.6-git The Luggage" 
bool Phonon::VLC::scanDevices(QList<Phonon::VLC::DeviceInfo>&) Probing for v4l2 devices 
found video capture device "/dev/video0" 
added device  HP Webcam id 0 

Program received signal SIGSEGV, Segmentation fault.
0x00007fffdb9211ae in libvlc_media_player_new () from /usr/lib/libvlc.so.5

(gdb) bt
#0  0x00007fffdb9211ae in libvlc_media_player_new () from /usr/lib/libvlc.so.5
#1  0x00007fffdbb4ef86 in Phonon::VLC::VLCMediaObject::VLCMediaObject (this=0x907bc0, parent=
    0x88d150) at /home/valorie/kde/src/phonon-vlc/vlc/vlcmediaobject.cpp:52
#2  0x00007fffdbb3c982 in Phonon::VLC::Backend::createObject (this=0x907a90, 
    c=Phonon::BackendInterface::MediaObjectClass, parent=0x88d150, args=...)
    at /home/valorie/kde/src/phonon-vlc/vlc/backend.cpp:134
#3  0x00007ffff0fb684f in Phonon::Factory::createMediaObject (parent=0x88d150)
    at ../../phonon/factory.cpp:336
#4  0x00007ffff0fa2c96 in Phonon::MediaObjectPrivate::createBackendObject (this=0x8b1040)
    at ../../phonon/mediaobject.cpp:47
#5  0x00007ffff0fa38cb in Phonon::MediaNodePrivate::backendObject (this=0x8b1040)
    at ../../phonon/medianode.cpp:63
#6  0x00007ffff0fa5876 in Phonon::Path::reconnect (this=0x7fffffffae30, source=0xb0, 
    sink=0x8a4a90) at ../../phonon/path.cpp:158
#7  0x00007ffff0fa5b9d in Phonon::createPath (source=0x88d160, sink=0x8a4a90)
    at ../../phonon/path.cpp:436
#8  0x00007ffff6e6f75b in EngineController::initializePhonon (this=0x8b1940)
    at /home/valorie/kde/src/amarok/src/EngineController.cpp:149
#9  0x00007ffff6e7a1b9 in EngineController::qt_metacall (this=0x8b1940, 
    _c=QMetaObject::InvokeMetaMethod, _id=37, _a=0x7fffffffb040)
    at /home/valorie/kde/build/amarok/src/EngineController.moc:202
#10 0x00007ffff53a5bf9 in QMetaMethod::invoke (this=0x7fffffffb2f0, object=0x8b1940, 
    connectionType=<value optimized out>, returnValue=..., val0=..., val1=..., val2=..., 
    val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...)
    at kernel/qmetaobject.cpp:1575
#11 0x00007ffff53a7306 in QMetaObject::invokeMethod (obj=0x8b1940, member=<value optimized out>, 
    type=<value optimized out>, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., 
    val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1148
#12 0x00007ffff6c8ac38 in QMetaObject::invokeMethod (obj=0x8b1940, 
    member=0x7ffff70e3389 "initializePhonon", type=Qt::DirectConnection, val0=..., val1=..., 
    val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...)
    at /usr/include/qt4/QtCore/qobjectdefs.h:408
#13 0x00007ffff6fa198b in Amarok::DefaultApplicationController::initEngineController (this=
    0x7ebe70)
    at /home/valorie/kde/src/amarok/src/statemanagement/DefaultApplicationController.cpp:89
#14 0x00007ffff6fa166e in Amarok::DefaultApplicationController::start (this=0x7ebe70)
    at /home/valorie/kde/src/amarok/src/statemanagement/DefaultApplicationController.cpp:48
#15 0x00007ffff6e60bd9 in App::continueInit (this=0x7fffffffbc90)
    at /home/valorie/kde/src/amarok/src/App.cpp:608
#16 0x00007ffff6e5d4df in App::App (this=0x7fffffffbc90)
    at /home/valorie/kde/src/amarok/src/App.cpp:209
#17 0x000000000040c932 in main (argc=3, argv=0x7fffffffe0f8)
    at /home/valorie/kde/src/amarok/src/main.cpp:259
(gdb)
Comment 1 Myriam Schweingruber 2010-12-13 14:45:03 UTC
Hm, do you really run Phonon from git or the one that comes with KDE? The vlc backend is a separate package.
Comment 2 Valorie Zimmerman 2010-12-14 12:36:18 UTC
I run the normal phonon from KDE. I build VLC and phonon-vlc from your blog instructions, and had built VLC afresh before filing the bug. Phonon-vlc hasn't changed in git for awhile.
Comment 3 Myriam Schweingruber 2010-12-17 10:39:18 UTC

*** This bug has been marked as a duplicate of bug 259269 ***
Comment 4 Myriam Schweingruber 2011-04-27 21:33:32 UTC
Reassigning to the new bugzilla product for better bug tracing of the various
backends. Sorry for the noise.