Bug 259658 - Deleting or moving file under nepomuk/strigi indexing crash
Summary: Deleting or moving file under nepomuk/strigi indexing crash
Status: RESOLVED DUPLICATE of bug 259723
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-12 22:29 UTC by Bruno Friedmann
Modified: 2011-01-04 18:43 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.37 KB, text/plain)
2010-12-14 06:44 UTC, Bruno Friedmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Friedmann 2010-12-12 22:29:31 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.5.85 (4.6 Beta2)
Qt Version: 4.7.1
Operating System: Linux 2.6.37-rc5-12-desktop x86_64
Distribution: "openSUSE 11.4 Milestone 4 of 6 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed: I was working with package, and after removing some ( plasmoid-translatoid ) I rebuild it with sources, do sudo make install, make sudo uninstall ( to check if something is wrong or forget) then plasma crash, and also nepomuk, but didn't remember which one is the first to crash.

A restart plasma-desktop has restored my session.

-- Backtrace:
Application: Nepomuk Service Stub (nepomukservicestub), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fc934aa8760 (LWP 4136))]

Thread 3 (Thread 0x7fc921470700 (LWP 4155)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fc9344c810b in wait (this=<value optimized out>, mutex=0x8190a8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x8190a8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fc9245d8bc5 in Nepomuk::Identifier::run (this=0x819090) at /usr/src/debug/kdebase-runtime-4.5.85/nepomuk/services/backupsync/service/identifier.cpp:132
#4  0x00007fc9344c7a1e in QThreadPrivate::start (arg=0x819090) at thread/qthread_unix.cpp:285
#5  0x00007fc934238a4f in start_thread (arg=0x7fc921470700) at pthread_create.c:297
#6  0x00007fc931fd652d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fc920c6f700 (LWP 4156)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fc9344c810b in wait (this=<value optimized out>, mutex=0x819f88, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x819f88, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fc9245da169 in Nepomuk::Merger::run (this=0x819f70) at /usr/src/debug/kdebase-runtime-4.5.85/nepomuk/services/backupsync/service/merger.cpp:123
#4  0x00007fc9344c7a1e in QThreadPrivate::start (arg=0x819f70) at thread/qthread_unix.cpp:285
#5  0x00007fc934238a4f in start_thread (arg=0x7fc920c6f700) at pthread_create.c:297
#6  0x00007fc931fd652d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc934aa8760 (LWP 4136)):
[KCrash Handler]
#6  QUrlPrivate::toEncoded (this=0x4545454545454545, options=...) at io/qurl.cpp:3901
#7  0x00007fc934570eed in QUrl::toEncoded (this=<value optimized out>, options=<value optimized out>) at io/qurl.cpp:5692
#8  0x00007fc9245de37b in qHash (this=0x7fff7d4997d8, akey=..., ahp=0x7fff7d4996dc) at /usr/include/QtCore/qurl.h:275
#9  QHash<QUrl, QHashDummyValue>::findNode (this=0x7fff7d4997d8, akey=..., ahp=0x7fff7d4996dc) at /usr/include/QtCore/qhash.h:880
#10 0x00007fc9245eaf95 in insert (this=0x7fff7d4997d0) at /usr/include/QtCore/qhash.h:757
#11 insert (this=0x7fff7d4997d0) at /usr/include/QtCore/qset.h:176
#12 (anonymous namespace)::IdentificationSetGenerator::iterate (this=0x7fff7d4997d0) at /usr/src/debug/kdebase-runtime-4.5.85/nepomuk/services/backupsync/service/identificationset.cpp:101
#13 0x00007fc9245eb750 in (anonymous namespace)::IdentificationSetGenerator::generate (this=0x7fff7d4997d0) at /usr/src/debug/kdebase-runtime-4.5.85/nepomuk/services/backupsync/service/identificationset.cpp:131
#14 0x00007fc9245ecd9c in Nepomuk::IdentificationSet::fromChangeLog (log=<value optimized out>, model=0x8135f0, ignoreList=...) at /usr/src/debug/kdebase-runtime-4.5.85/nepomuk/services/backupsync/service/identificationset.cpp:230
#15 0x00007fc9245ed98d in Nepomuk::SyncFile::SyncFile (this=0x7fff7d499970, log=..., model=0x8135f0) at /usr/src/debug/kdebase-runtime-4.5.85/nepomuk/services/backupsync/service/syncfile.cpp:81
#16 0x00007fc9245e5900 in Nepomuk::saveBackupSyncFile (url=...) at /usr/src/debug/kdebase-runtime-4.5.85/nepomuk/services/backupsync/service/tools.cpp:86
#17 0x00007fc9245de8cc in Nepomuk::BackupManager::backup (this=0x7fd140, oldUrl=<value optimized out>) at /usr/src/debug/kdebase-runtime-4.5.85/nepomuk/services/backupsync/service/backupmanager.cpp:88
#18 0x00007fc9245ded5a in Nepomuk::BackupManager::automatedBackup (this=0x7fd140) at /usr/src/debug/kdebase-runtime-4.5.85/nepomuk/services/backupsync/service/backupmanager.cpp:106
#19 0x00007fc9245df6d8 in Nepomuk::BackupManager::qt_metacall (this=0x7fd140, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0x7fff7d499be0) at /usr/src/debug/kdebase-runtime-4.5.85/build/nepomuk/services/backupsync/service/backupmanager.moc:96
#20 0x00007fc9345c5e8f in QMetaObject::activate (sender=0x7fd180, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#21 0x00007fc9345c4839 in QObject::event (this=0x7fd180, e=<value optimized out>) at kernel/qobject.cpp:1175
#22 0x00007fc932742d24 in QApplicationPrivate::notify_helper (this=0x6261c0, receiver=0x7fd180, e=0x7fff7d49a380) at kernel/qapplication.cpp:4445
#23 0x00007fc93274b21a in QApplication::notify (this=<value optimized out>, receiver=0x7fd180, e=0x7fff7d49a380) at kernel/qapplication.cpp:4324
#24 0x00007fc933669776 in KApplication::notify (this=0x7fff7d49a8c0, receiver=0x7fd180, event=0x7fff7d49a380) at /usr/src/debug/kdelibs-4.5.85/kdeui/kernel/kapplication.cpp:311
#25 0x00007fc9345b0c7c in QCoreApplication::notifyInternal (this=0x7fff7d49a8c0, receiver=0x7fd180, event=0x7fff7d49a380) at kernel/qcoreapplication.cpp:732
#26 0x00007fc9345de588 in sendEvent (this=0x629f90) at kernel/qcoreapplication.h:215
#27 QTimerInfoList::activateTimers (this=0x629f90) at kernel/qeventdispatcher_unix.cpp:618
#28 0x00007fc9345db2e4 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#29 0x00007fc9314312b3 in g_main_dispatch (context=0x628d20) at gmain.c:2267
#30 g_main_context_dispatch (context=0x628d20) at gmain.c:2824
#31 0x00007fc931431a90 in g_main_context_iterate (context=0x628d20, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2902
#32 0x00007fc931431d30 in g_main_context_iteration (context=0x628d20, may_block=1) at gmain.c:2965
#33 0x00007fc9345db9bf in QEventDispatcherGlib::processEvents (this=0x60f360, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#34 0x00007fc9327e7d2e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x00007fc9345b00b2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#36 0x00007fc9345b02c5 in QEventLoop::exec (this=0x7fff7d49a690, flags=...) at kernel/qeventloop.cpp:201
#37 0x00007fc9345b472b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#38 0x0000000000403ea2 in main (argc=1, argv=0x7fff7d49ad18) at /usr/src/debug/kdebase-runtime-4.5.85/nepomuk/servicestub/main.cpp:165

This bug may be a duplicate of or related to bug 251558.

Possible duplicates by query: bug 251558.

Reported using DrKonqi
Comment 1 Bruno Friedmann 2010-12-14 06:44:45 UTC
Created attachment 54535 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.5.85 (4.6 Beta2) using Qt 4.7.1

- What I was doing when the application crashed: After upgrading kde with the lastest kde build on opensuse, I've restart the computer. Open kde session, to let nepomuk indexing files. virtuosodb was new.

At 10pm, I've setup an automatic backup of it. But seems the crash happen before (no backup this morning).

I've limited my action for this session, there only the korganiser alarm daemon open in the task bar. and thunderbird open, and system settings with nepomuk tabs open to see the indexing running ( the taskbar icon is missing now version 4.6 where it was shown in 4.5.3)

-- Backtrace (Reduced):
#6  QUrlPrivate::toEncoded (this=0x4545454545454545, options=...) at io/qurl.cpp:3901
#7  0x00007fbff6646eed in QUrl::toEncoded (this=<value optimized out>, options=<value optimized out>) at io/qurl.cpp:5692
#8  0x00007fbfe66b234b in qHash (this=0x7fff439ca6b8, akey=..., ahp=0x7fff439ca5bc) at /usr/include/QtCore/qurl.h:275
#9  QHash<QUrl, QHashDummyValue>::findNode (this=0x7fff439ca6b8, akey=..., ahp=0x7fff439ca5bc) at /usr/include/QtCore/qhash.h:880
#10 0x00007fbfe66bef55 in insert (this=0x7fff439ca6b0) at /usr/include/QtCore/qhash.h:757
Comment 2 Sebastian Trueg 2011-01-04 18:43:46 UTC

*** This bug has been marked as a duplicate of bug 259723 ***