Bug 259467 - New feature "storing cover art in file" not in Settings
Summary: New feature "storing cover art in file" not in Settings
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Collections/Local (show other bugs)
Version: 2.3.90
Platform: Unlisted Binaries Linux
: NOR wishlist (vote)
Target Milestone: 2.4.0
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-10 19:54 UTC by Miguel
Modified: 2011-12-30 21:29 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miguel 2010-12-10 19:54:32 UTC
Version:           2.3.90 (2.4 beta 1) (using KDE 4.5.80) 
OS:                Linux

Hi

So a new feature was announced that would store the cover art in the music file under the cover art tag. But i cannot find in the settings, where i can enable this.

And in my opinion when introducing a such feature, an option to apply this to the whole collection at once has to be given! Otherwise there is no use for it if it is applied only song by song...

Reproducible: Didn't try

Steps to Reproduce:
Open amarok, look for the feature in the settings.

Actual Results:  
not found.


OS: Linux (i686) release 2.6.35-24-generic
Compiler: cc
Comment 1 Ralf Engels 2010-12-13 14:54:20 UTC
The option is not in the configuration dialog because other developers are against "crowding" the configuration dialog.

You need to add the following lines in your ~/.kde/share/config/amarokrc

[Collection]
Write Back Cover=true
Comment 2 Sebastian Schubert 2010-12-13 15:01:58 UTC
Is it on or off by default? Is this connected to writing the play statistics to the file?

Please make sure, that the user can say exactly what is written to the file. For me, the cover is good (belongs to the collection), the play count is just a number on one computer, so I don't want it in the file.
Comment 3 Miguel 2010-12-13 15:05:10 UTC
so then it is not an official feature...? in any case there is a
misunderstanding between the feature list of 3.4 and the gui-implementation.

surely, thanks for the info, i will add it for sure!

The only question i have left: in what moment does it write the album in the
tags?
  - when you edit the tag info ?
  - when you download and store a cover art to an album in the album
manager?
  - upon the activation off the settings for all albums?

sincerily
Miguel

On Mon, Dec 13, 2010 at 2:54 PM, Ralf Engels <ralf.engels@nokia.com> wrote:

> https://bugs.kde.org/show_bug.cgi?id=259467
>
>
>
>
>
> --- Comment #1 from Ralf Engels <ralf engels nokia com>  2010-12-13
> 14:54:20 ---
> The option is not in the configuration dialog because other developers are
> against "crowding" the configuration dialog.
>
> You need to add the following lines in your ~/.kde/share/config/amarokrc
>
> [Collection]
> Write Back Cover=true
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 4 Ralf Engels 2010-12-13 15:12:19 UTC
Hi Miguel,
there is no such thing as an "official" feature.
Currently we have some discussions how many settings should be displayed. For now this specific option is not visible in the UI.

Anyhow, the image is written for all files in an album when you set the album cover.
The image will not be written if the track is smaller than 1Mb.
The image will be scaled down to a maximum of 200x200 pixel.
Comment 5 Miguel 2010-12-25 00:25:37 UTC
i see the problem of bloating the gui

i suggest you too look the preferences of vlc. They make difference between the advanced and simple gui, this could be an approach!

But i think it is difficult to implement an option that is only available through editing configure files! This is not user friendly.

miguel
Comment 6 Ralf Engels 2011-01-10 17:31:21 UTC
Agreed and Agreed.

25 votes until now. So this feature is really something people want.
Comment 7 shaddowy2 2011-12-29 17:09:57 UTC
That bug can be marked as fixed. Amarok version 2.5 has the gui option under "Settings" --> "Collection" to Store cover art in files.
Thank you!
Comment 8 Myriam Schweingruber 2011-12-30 21:29:40 UTC
Indeed, we forgot to close this one.