Bug 259466 - "Send To" button fails if image is previously saved to different name.
Summary: "Send To" button fails if image is previously saved to different name.
Status: RESOLVED DUPLICATE of bug 258431
Alias: None
Product: ksnapshot
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Richard Moore
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-10 19:50 UTC by JanKusanagi
Modified: 2010-12-10 20:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description JanKusanagi 2010-12-10 19:50:16 UTC
Version:           unspecified (using KDE 4.5.85) 
OS:                Linux

After starting KSnapshot, and using the "save as" button to save the image to a non-default name, the "Send to" button does not use the new filename, so "sending" the image to other programs fails.

Reproducible: Always

Steps to Reproduce:
- Start KSnapShot.
- Use "Save as" button and save as a different filename than the proposed.
- After saving, use the "Send to" button, and choose Gwenview for instance.
- Gwenview will start and show an error message.


Actual Results:  
Gwenview starts and shows "Loading 'somefile.png' failed. Could not open the file"
somefile.png = original filename proposed by ksnapshot, but not the one I actually saved the image under.

Expected Results:  
KSnapshot should be aware of the actual filename used in last time I saved the file, or keep the original copy, so the "Send to" button works nicely.

OS: Linux (i686) release 2.6.36-ARCH
Compiler: gcc

This also happens on KDE 4.5 under Mandriva, so it's not new in 4.6 and not an Archlinux issue.
Comment 1 JanKusanagi 2010-12-10 20:00:18 UTC
Sorry, now I found this is a duplicate of this one https://bugs.kde.org/show_bug.cgi?id=258431
Comment 2 Dario Andres 2010-12-10 20:28:37 UTC
[Comment from a bug triager]
Indeed, this is bug 258431. Merging.
Thanks for your information

*** This bug has been marked as a duplicate of bug 258431 ***