Bug 259421 - Kmail 4.4.8 displays messages as empty
Summary: Kmail 4.4.8 displays messages as empty
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-10 10:35 UTC by mps
Modified: 2015-04-13 03:08 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshort showing how kmail shows messages as empty (154.75 KB, image/jpeg)
2010-12-10 10:35 UTC, mps
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mps 2010-12-10 10:35:46 UTC
Created attachment 54383 [details]
screenshort showing how kmail shows messages as empty

Version:           unspecified (using KDE 4.5.85) 
OS:                Linux


Kmail has suddenly started displaying messages as empty. The mails arrive ok in inbox on a pop mail check, headers and text are visible. However clicking on the messages in the message list causes the message to be displayed as empty and the subject and from headers to be "unknown" (in fact in one message subject and from have remained visible, but body is empty, for others headers are empty too). See attached screenshot. This happens with every message.

I am storing messages in maildir. Opening the maildir in another client - mutt or gnus (with kmail closed) shows the messages are still there and can be read normally. The files therefore seem not to be damaged, it is a display problem in kmail. However, the effect is equivalent to dataloss. 

I am running kdepim 4.4.8 on kde 4.6 beta 2.



Reproducible: Always
Comment 1 mps 2010-12-10 10:37:24 UTC
PS - I tried running kmail from the command line but there was no output (debug is on in kdebugdialog). If there is a way I can provide further info please let me know.
Comment 2 Con Kolivas 2011-03-05 02:33:28 UTC
I'm having the same problem now with an imap based account. If I send new emails to it, they appear okay, but all emails prior to now are dead empty body ones. It has the subject and names okay, but the body of each email is empty. I know the imap account is not corrupted because other mail readers can access the mail. This has happened before intermittently where I get an empty body and refreshing eventually brings up the body of the mail. However now I have a ton of emails I can no longer access.

Running kmail from a console gives me this:
kmail(26981) FolderStorage::getMsg: msg serial number == 0 
whenever I click on an email.

kdepim 4:4.4.9-0ubuntu1~maverick2~ppa1
Comment 3 Myrosia 2011-09-06 13:29:31 UTC
I am experiencing exactly the same problem with FC13, KMail Version 1.13.6, KDE 4.5.5. We had temporary trouble with our file server, KMail complained about not being able to access the local directory where it stores cached version, but after it was resolved, all the previous messages on my imap account come up with empty bodies. I can access them using other imap readers, but not KMail. I am seeing the same warning about message ID being 0.
Comment 4 Christophe Giboudeaux 2011-09-06 13:52:10 UTC
note that kmail 1.13.x is now unmaintained. Please retry with kmail2
Comment 5 Laurent Montel 2015-04-12 10:08:02 UTC
Thank you for taking the time to file a bug report.

KMail2 was released in 2011, and the entire code base went through significant changes. We are currently in the process of porting to Qt5 and KF5. It is unlikely that these bugs are still valid in KMail2.

We welcome you to try out KMail 2 with the KDE 4.14 release and give your feedback.
Comment 6 Con Kolivas 2015-04-12 10:11:56 UTC
I still have this problem on kmail 4.14.1 on kubuntu 14.10. I will click on some messages and the rest of the messages disappear. Clicking in a different folder and then clicking back to the first folder will make them visible again now but the problem still exists.
Comment 7 Alexander Potashev 2015-04-13 01:22:29 UTC
(In reply to Con Kolivas from comment #6)
> I still have this problem on kmail 4.14.1 on kubuntu 14.10. I will click on
> some messages and the rest of the messages disappear. Clicking in a
> different folder and then clicking back to the first folder will make them
> visible again now but the problem still exists.

Hi CK,

What you described sounds like a different bug if you mean it's the list of messages that misbehaves. The current bug report is instead about empty message body.

Please report the problem you described separately. It might have been reported already, for example the bug #331539 looks alike.
Comment 8 Con Kolivas 2015-04-13 03:08:51 UTC
(In reply to Alexander Potashev from comment #7)
> (In reply to Con Kolivas from comment #6)
> > I still have this problem on kmail 4.14.1 on kubuntu 14.10. I will click on
> > some messages and the rest of the messages disappear. Clicking in a
> > different folder and then clicking back to the first folder will make them
> > visible again now but the problem still exists.
> 
> Hi CK,
> 
> What you described sounds like a different bug if you mean it's the list of
> messages that misbehaves. The current bug report is instead about empty
> message body.
> 
> Please report the problem you described separately. It might have been
> reported already, for example the bug #331539 looks alike.

Thanks. You are right and that bug report is more what I'm seeing. I shall move my supporting report there.