Bug 259181 - Access to AdressBook by Filters is not working
Summary: Access to AdressBook by Filters is not working
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail
Classification: Unclassified
Component: filtering (show other bugs)
Version: 1.13.2
Platform: Ubuntu Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-08 01:17 UTC by Joe Hurke
Modified: 2015-04-12 10:05 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Hurke 2010-12-08 01:17:48 UTC
Version:           1.13.2 (using KDE 4.4.2) 
OS:                Linux

One of my KMail-Filters put all messages from senders from the KMail-AdressBook in a special folder e.g. "known senders".
But since I tried working with KDE 4, no senders are recognized any more.
On KDE 3.5.10 this was working.
The adress book is reachable from KMail, e.g. by menu item.
Other filters for putting eMails in special folders are working.
When I choose "add eMail-Adress to AdressBook" at an eMail-Adress, that is just listed in the AdressBook, it gets duplicated in the AdressBook.
Perhaps there is a problem with capiTALIsation:
Some of the letters of the "known adresses" in the adress book are writen with capitals. And in the arrived eMails they are all written without capitals.
Perhaps this is one reason for not working eMail-Filters based on the AdressBook.

Reproducible: Always

Steps to Reproduce:
It happens every time I receive eMails from "known adresses" since I switched from KDE 3.5.10 to KDE 4.
KDE 3 was not affected by this problem.




OS: Linux (i686) release 2.6.32-26-generic
Compiler: cc
Comment 1 Laurent Montel 2015-04-12 10:05:59 UTC
Thank you for taking the time to file a bug report.

KMail2 was released in 2011, and the entire code base went through significant changes. We are currently in the process of porting to Qt5 and KF5. It is unlikely that these bugs are still valid in KMail2.

We welcome you to try out KMail 2 with the KDE 4.14 release and give your feedback.