Bug 259143 - Kaddressbook loses addresses
Summary: Kaddressbook loses addresses
Status: RESOLVED WORKSFORME
Alias: None
Product: kaddressbook
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-07 16:48 UTC by mps
Modified: 2011-01-06 20:22 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot of kaddressbook (1) (135.51 KB, image/jpeg)
2010-12-07 16:48 UTC, mps
Details
screenshot of kaddressbook (2) (153.90 KB, image/jpeg)
2010-12-07 16:49 UTC, mps
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mps 2010-12-07 16:48:41 UTC
Created attachment 54260 [details]
screenshot of kaddressbook (1)

Version:           unspecified (using KDE 4.5.85) 
OS:                Linux

I restarted my computer normally, on using kmail I found that recently added addresses no longer appeared in the autocomplete list. Opening kaddressbook I found that the list of names was replaced by a list of the vcard filenames (see attached screenshots). Clicking on one of the filenames to try to show the address causes a crash (backtrace - a bit bizzare - below). It is impossible to add new addresses to either the local contacts or personal addressbook. The files do still exist.

I am running kdepim 4.4.8 on kde sc 4.6 beta 2. Akonadi is 1.4.80.

This is a dataloss bug.

Application: KAddressBook (kaddressbook), signal: Aborted
[KCrash Handler]
#6  0x00000038ca634065 in raise () from /lib64/libc.so.6
#7  0x00000038ca635a16 in abort () from /lib64/libc.so.6
#8  0x00000038ceabc08d in __gnu_cxx::__verbose_terminate_handler () at ../../../../libstdc++-v3/libsupc++/vterminate.cc:93
#9  0x00000038ceaba2a6 in __cxxabiv1::__terminate (handler=<value optimized out>) at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:39
#10 0x00000038ceaba2d3 in std::terminate () at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:49
#11 0x00000038ceaba426 in __cxxabiv1::__cxa_rethrow () at ../../../../libstdc++-v3/libsupc++/eh_throw.cc:116
#12 0x000000346f35ae82 in QEventLoop::exec (this=0x7fff8e0d99b0, flags=...) at kernel/qeventloop.cpp:214
#13 0x000000346f35f24b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#14 0x000000000040547d in _start ()






Reproducible: Always
Comment 1 mps 2010-12-07 16:49:25 UTC
Created attachment 54261 [details]
screenshot of kaddressbook (2)
Comment 2 mps 2010-12-07 16:59:01 UTC
slightly better backtrace:

Application: KAddressBook (kaddressbook), signal: Aborted
[KCrash Handler]
#6  0x00000038ca634065 in raise () from /lib64/libc.so.6
#7  0x00000038ca635a16 in abort () from /lib64/libc.so.6
#8  0x00000038ceabc08d in __gnu_cxx::__verbose_terminate_handler () at ../../../../libstdc++-v3/libsupc++/vterminate.cc:93
#9  0x00000038ceaba2a6 in __cxxabiv1::__terminate (handler=<value optimized out>) at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:39
#10 0x00000038ceaba2d3 in std::terminate () at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:49
#11 0x00000038ceaba426 in __cxxabiv1::__cxa_rethrow () at ../../../../libstdc++-v3/libsupc++/eh_throw.cc:116
#12 0x000000346f35ae82 in QEventLoop::exec (this=0x7fff34e40a00, flags=...) at kernel/qeventloop.cpp:214
#13 0x000000346f35f24b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#14 0x000000000040547d in main (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdepim-4.4.8/kaddressbook/main.cpp:58
Comment 3 Tobias Koenig 2010-12-09 18:49:49 UTC
Hej, 

if you use KDE 4.6 then please use also KDE-PIM 4.6, mixing versions are not supported.

Ciao,
Tobias
Comment 4 mps 2010-12-09 19:43:36 UTC
Hi Tobias,

Thanks for the clarification and advice - I shall have to go back to 4.5, which is a pity.

I must say that given the current state of kmail 2 (just look at the severity of the 200 or so open bugs - apart from the huge cpu use problem, there is data loss, missing core functionality, emails getting sent multiple times, you name it) I think this is extremely unfortunate. Releasing 4.6 with the only kdepim option being 4.6 in this state is going to get KDE *WAY* more flak than the 4.0 release ever did. 

I know there are a few more weeks of fixing to go before the release, so maybe I am too pessimistic, but something to consider I think.

Bon courage!
M.
Comment 5 David Faure 2010-12-09 22:28:00 UTC
Tobias: I'm surprised by your reply; this -is- the recommended combination currently, for kmail etc. to work.
Things might be different when it comes to kaddressbook, but then users have no good solution right now...

I'm starting to wonder if we should release a kdepim (called 4.5 maybe?) with kdepim-4.4.x and kaddressbook-4.6 :-)
Comment 6 Nicolas L. 2010-12-10 22:20:29 UTC
i think this can be a good "workaround" to let us provide the best kdepim.
Comment 7 Tobias Koenig 2010-12-11 10:56:43 UTC
Hej,

we as the KDE-PIM team decided to release KMail/KOrganizer together with 4.6 because we simply do not have the man power to maintain two versions (4.5 and 4.6) in parallel. I always hear people cry about the low quality of KMail2, however I can't agree on this. I use it on daily base and many smaller glitches have been fixed lately. There might be migration problems left, but how shall we fix them without the brave beta users who find them?!? So using KDE-PIM 4.6 is the recommended way for KDE 4.6.

Ciao,
Tobias
Comment 8 K G 2010-12-11 15:35:45 UTC
Hi,

as I see contacts are not only in Kaddresbook(4.4.8) displayed like this. It looks the same in AkonadiConsole (witch has 4.6b2 version).

I store contacts in one vcard file. The file wasn't damaged anyway and it seams to be valid.

In Console data are inaccessible by vcard recource as well as traditional Kdaddressbok recource. By Kaddressbok resource it sees only some rdf data, by vcard recource it sees nothing.

I've got the same configuration.
Comment 9 Tobias Koenig 2010-12-11 21:09:29 UTC
(In reply to comment #8)
> Hi,

> It looks the same in AkonadiConsole (witch has 4.6b2 version).
Akonadiconsole always shows the plain object information, because it's a debugging tool, no end user application.

> In Console data are inaccessible by vcard recource as well as traditional
> Kdaddressbok recource.
Please make sure to _not_ use any traditional resource but the native Akonadi resources (Personal Contacts is recommended).

Ciao,
Tobias
Comment 10 Balcaen John 2010-12-13 21:57:43 UTC
Just for testing purpose i reinstall kdepim 4.4.8 on a KDE SC 4.6 (beta 1) & i can confirme that i don't have any contact available (execept the name of the vcard files)on my akonadi google data addressbook.
Further more i add the « Personal Contacts » to follow the recommandation but when trying to add a contact kaddressbook simply crash :

(gdb) bt                                                                                                                                                             
#0  0x00007f6a26079075 in raise () from /lib64/libc.so.6                                                                                                             
#1  0x00007f6a2607a806 in abort () from /lib64/libc.so.6                                                                                                             
#2  0x00007f6a26688d1d in __gnu_cxx::__verbose_terminate_handler () at ../../../../libstdc++-v3/libsupc++/vterminate.cc:93                                           
#3  0x00007f6a26686f36 in __cxxabiv1::__terminate (handler=<value optimized out>) at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:39                           
#4  0x00007f6a26686f63 in std::terminate () at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:49                                                                 
#5  0x00007f6a266870b6 in __cxxabiv1::__cxa_rethrow () at ../../../../libstdc++-v3/libsupc++/eh_throw.cc:116                                                         
#6  0x00007f6a26a2ee22 in QEventLoop::exec (this=0x7fff42b123c0, flags=...) at kernel/qeventloop.cpp:214                                                             
#7  0x00007f6a26a331eb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009                                                                              
#8  0x0000000000404eee in main (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdepim-4.4.8/kaddressbook/main.cpp:51                      
(gdb) bt full                                                                                                                                                        
#0  0x00007f6a26079075 in raise () from /lib64/libc.so.6                                                                                                             
No symbol table info available.                                                                                                                                      
#1  0x00007f6a2607a806 in abort () from /lib64/libc.so.6                                                                                                             
No symbol table info available.                                                                                                                                      
#2  0x00007f6a26688d1d in __gnu_cxx::__verbose_terminate_handler () at ../../../../libstdc++-v3/libsupc++/vterminate.cc:93                                           
        terminating = true                                                                                                                                           
        t = <value optimized out>                                                                                                                                    
#3  0x00007f6a26686f36 in __cxxabiv1::__terminate (handler=<value optimized out>) at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:39                           
No locals.                                                                                                                                                           
#4  0x00007f6a26686f63 in std::terminate () at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:49                                                                 
No locals.                                                                                                                                                           
#5  0x00007f6a266870b6 in __cxxabiv1::__cxa_rethrow () at ../../../../libstdc++-v3/libsupc++/eh_throw.cc:116                                                         
        globals = <value optimized out>                                                                                                                              
        header = <value optimized out>                                                                                                                               
#6  0x00007f6a26a2ee22 in QEventLoop::exec (this=0x7fff42b123c0, flags=...) at kernel/qeventloop.cpp:214                                                             
        d = 0x1df9970                                                                                                                                                
        app = 0x7fff42b12420                                                                                                                                         
#7  0x00007f6a26a331eb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009                                                                              
        threadData = 0x1af67a0                                                                                                                                       
        eventLoop = {<QObject> = {_vptr.QObject = 0x7f6a26d60910, static staticMetaObject = {d = {superdata = 0x0, stringdata = 0x7f6a26aeaae0 "QObject",            
                data = 0x7f6a26aeab80, extradata = 0x7f6a26d58540}}, d_ptr = {d = 0x1df9970}, static staticQtMetaObject = {d = {superdata = 0x0,                     
                stringdata = 0x7f6a26af3740 "Qt", data = 0x7f6a26af6f40, extradata = 0x0}}}, static staticMetaObject = {d = warning: can't find linker symbol for virtual table for `(null)' value                                                                                                                                        
warning:   found `types' instead                                                                                                                                     
{superdata = 0x7f6a26d58520,                                                                                                                                         
              stringdata = 0x7f6a26afcec0 "QEventLoop", data = 0x7f6a26afcee0, extradata = 0x0}}}                                                                    
        returnCode = <value optimized out>                                                                                                                           
---Type <return> to continue, or q <return> to quit---                                                                                                               
#8  0x0000000000404eee in main (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdepim-4.4.8/kaddressbook/main.cpp:51                      
        about = {<KAboutData> = {d = 0x1afc910}, <No data fields>}                                                                                                   
        options = {d = 0x1b11540}                                                                                                                                    
        app = {<KApplication> = {<QApplication> = {<QCoreApplication> = {<QObject> = {_vptr.QObject = 0x7f6a28a27eb0, static staticMetaObject = {d = {               
                      superdata = 0x0, stringdata = 0x7f6a26aeaae0 "QObject", data = 0x7f6a26aeab80, extradata = 0x7f6a26d58540}}, d_ptr = {d = 0x1b207a0},          
                  static staticQtMetaObject = {d = {superdata = 0x0, stringdata = 0x7f6a26af3740 "Qt", data = 0x7f6a26af6f40, extradata = 0x0}}},                    
                static staticMetaObject = {d = warning: can't find linker symbol for virtual table for `(null)' value                                                
warning:   found `types' instead                                                                                                                                     
{superdata = 0x7f6a26d58520, stringdata = 0x7f6a26afcf60 "QCoreApplication", data = 0x7f6a26afd000,                                                                  
                    extradata = 0x0}}, static self = 0x7fff42b12420}, static staticMetaObject = {d = {superdata = 0x7f6a26d609a0,                                    
                  stringdata = 0x7f6a27a6e9a0 "QApplication", data = 0x7f6a27a6ebe0, extradata = 0x0}}}, static staticMetaObject = {d = warning: can't find linker symbol for virtual table for `(null)' value                                                                                                                            
warning:   found `typeinfo for QActionGroupPrivate' instead                                                                                                          
{                                                                                                                                                                    
                superdata = 0x7f6a27e92340, stringdata = 0x7f6a2872e7e0 "KApplication", data = 0x7f6a2872e980, extradata = 0x0}}, static loadedByKdeinit = false,    
            static KApp = 0x7fff42b12420, d = 0x1b64c60}, static staticMetaObject = {d = {superdata = 0x7f6a28a27c40,                                                
              stringdata = 0x7f6a2872f1e0 "KUniqueApplication", data = 0x7f6a2872f2e0, extradata = 0x0}}, d = 0x1c345d0}                                             
        window = 0x1c38ef0
Comment 11 Balcaen John 2010-12-18 00:26:49 UTC
Hum, since KDEPIM 4.6 is delayed, maybe we can reopen this bug ?
Comment 12 Balcaen John 2010-12-23 09:42:54 UTC
For info it's now working (at least here) with kdepim 4.4.9,akonadi 1.90 & KDE SC 4.6 beta2 (4.8.85)

Regards,
Comment 13 Tobias Koenig 2011-01-06 20:22:18 UTC
Yepp, KDE-PIM 4.6 or KDE-PIM 4.4.9 shall both work.