Bug 259088 - random plasma crash
Summary: random plasma crash
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-07 11:23 UTC by jos poortvliet
Modified: 2010-12-07 14:54 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jos poortvliet 2010-12-07 11:23:50 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.4 (KDE 4.5.4) "release 9"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.5-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
Nothing really... Just logged in and decided to close KTorrent. Boom.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5a94710 (LWP 3684))]

Thread 3 (Thread 0xa9c1ab70 (LWP 3752)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6e01125 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb3c60fa7 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xb3d481a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2304
#3  0xb3c60fef in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb3d481a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1438
#4  0xb6dfcb25 in start_thread () from /lib/libpthread.so.0
#5  0xb61e946e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xa63fbb70 (LWP 3774)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6e01125 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb3ffe1f7 in ?? () from /usr/lib/libQtWebKit.so.4
#3  0xb3ffe23f in ?? () from /usr/lib/libQtWebKit.so.4
#4  0xb6dfcb25 in start_thread () from /lib/libpthread.so.0
#5  0xb61e946e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5a94710 (LWP 3684)):
[KCrash Handler]
#7  QMutex::lock (this=0x2c) at thread/qmutex.cpp:150
#8  0xb5fec17b in relock (this=0x95969c8) at ../../src/corelib/thread/qmutex.h:120
#9  QMutexLocker (this=0x95969c8) at ../../src/corelib/thread/qmutex.h:102
#10 QDBusPendingCall::isFinished (this=0x95969c8) at qdbuspendingcall.cpp:320
#11 0xb60424f3 in waitForWatcher (this=0x95969c8) at /usr/src/debug/libdbusmenu-qt-0.3.3/src/dbusmenuimporter.cpp:398
#12 DBusMenuImporter::slotMenuAboutToShow (this=0x95969c8) at /usr/src/debug/libdbusmenu-qt-0.3.3/src/dbusmenuimporter.cpp:439
#13 0xb6046a5c in DBusMenuImporter::qt_metacall (this=0x9388bb8, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbff5613c)
    at /usr/src/debug/libdbusmenu-qt-0.3.3/build/src/dbusmenuimporter.moc:94
#14 0xb6f76efd in QMetaObject::metacall (object=0x9388bb8, cl=QMetaObject::InvokeMetaMethod, idx=9, argv=0xbff5613c) at kernel/qmetaobject.cpp:237
#15 0xb6f85fe8 in QMetaObject::activate (sender=0x97b1348, m=0xb6ddf6c8, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3295
#16 0xb693cc65 in QMenu::aboutToShow (this=0x97b1348) at .moc/release-shared/moc_qmenu.cpp:151
#17 0xb69403c9 in QMenu::popup (this=0x97b1348, p=..., atAction=0x0) at widgets/qmenu.cpp:1823
#18 0xb6940eaf in QMenu::exec (this=0x97b1348, p=..., action=0x0) at widgets/qmenu.cpp:2060
#19 0xa9d8619e in SystemTray::DBusSystemTrayWidget::showContextMenu (this=0x97eb628, job=0x821fe50)
    at /usr/src/debug/kdebase-workspace-4.5.4/plasma/generic/applets/systemtray/protocols/dbussystemtray/dbussystemtraywidget.cpp:124
#20 0xa9d757d5 in SystemTray::DBusSystemTrayWidget::qt_metacall (this=0x97eb628, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbff56498)
    at /usr/src/debug/kdebase-workspace-4.5.4/build/plasma/generic/applets/systemtray/moc_dbussystemtraywidget.cpp:82
#21 0xb6f76efd in QMetaObject::metacall (object=0x97eb628, cl=QMetaObject::InvokeMetaMethod, idx=33, argv=0xbff56498) at kernel/qmetaobject.cpp:237
#22 0xb6f85fe8 in QMetaObject::activate (sender=0x821fe50, m=0xb731bac0, local_signal_index=3, argv=0xbff56498) at kernel/qobject.cpp:3295
#23 0xb7128715 in KJob::result (this=0x821fe50, _t1=0x821fe50) at /usr/src/debug/kdelibs-4.5.4/build/kdecore/kjob.moc:194
#24 0xb7128768 in KJob::emitResult (this=0x821fe50) at /usr/src/debug/kdelibs-4.5.4/kdecore/jobs/kjob.cpp:312
#25 0xb5013b48 in Plasma::ServiceJob::setResult (this=0x821fe50, result=...) at /usr/src/debug/kdelibs-4.5.4/plasma/servicejob.cpp:80
#26 0xa9dc1646 in StatusNotifierItemJob::contextMenuReady (this=0x821fe50, menu=0x97b1348)
    at /usr/src/debug/kdebase-workspace-4.5.4/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#27 0xa9dc16d7 in StatusNotifierItemJob::qt_metacall (this=0x821fe50, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbff56648)
    at /usr/src/debug/kdebase-workspace-4.5.4/build/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.moc:75
#28 0xb6f76efd in QMetaObject::metacall (object=0x821fe50, cl=QMetaObject::InvokeMetaMethod, idx=27, argv=0xbff56648) at kernel/qmetaobject.cpp:237
#29 0xb6f85fe8 in QMetaObject::activate (sender=0x97eb3d8, m=0xa9dcfb7c, local_signal_index=0, argv=0xbff56648) at kernel/qobject.cpp:3295
#30 0xa9dc1255 in StatusNotifierItemSource::contextMenuReady (this=0x97eb3d8, _t1=0x97b1348)
    at /usr/src/debug/kdebase-workspace-4.5.4/build/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.moc:109
#31 0xa9dc12b4 in StatusNotifierItemSource::contextMenuReady (this=0x97eb3d8) at /usr/src/debug/kdebase-workspace-4.5.4/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:369
#32 0xa9dc72dc in StatusNotifierItemSource::qt_metacall (this=0x97eb3d8, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbff5675c)
    at /usr/src/debug/kdebase-workspace-4.5.4/build/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.moc:90
#33 0xb6f76efd in QMetaObject::metacall (object=0x97eb3d8, cl=QMetaObject::InvokeMetaMethod, idx=11, argv=0xbff5675c) at kernel/qmetaobject.cpp:237
#34 0xb6f85fe8 in QMetaObject::activate (sender=0x9388bb8, m=0xb6057de4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3295
#35 0xb6042c25 in DBusMenuImporter::menuReadyToBeShown (this=0x9388bb8) at /usr/src/debug/libdbusmenu-qt-0.3.3/build/src/dbusmenuimporter.moc:108
#36 0xb6045385 in DBusMenuImporter::slotAboutToShowDBusCallFinished (this=0x9388bb8, watcher=0x9208390) at /usr/src/debug/libdbusmenu-qt-0.3.3/src/dbusmenuimporter.cpp:475
#37 0xb60469a5 in DBusMenuImporter::qt_metacall (this=0x9388bb8, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbff56ab8)
    at /usr/src/debug/libdbusmenu-qt-0.3.3/build/src/dbusmenuimporter.moc:96
#38 0xb6f76efd in QMetaObject::metacall (object=0x9388bb8, cl=QMetaObject::InvokeMetaMethod, idx=11, argv=0xbff56ab8) at kernel/qmetaobject.cpp:237
#39 0xb6f85fe8 in QMetaObject::activate (sender=0x8d95ce0, m=0xb6008b68, local_signal_index=0, argv=0xbff56ab8) at kernel/qobject.cpp:3295
#40 0xb5fec7a5 in QDBusPendingCallWatcher::finished (this=0x8d95ce0, _t1=0x8d95ce0) at .moc/release-shared/moc_qdbuspendingcall.cpp:92
#41 0xb5fec853 in _q_finished (this=0x8d95ce0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x93bcb78) at qdbuspendingcall.cpp:480
#42 QDBusPendingCallWatcher::qt_metacall (this=0x8d95ce0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x93bcb78) at .moc/release-shared/moc_qdbuspendingcall.cpp:80
#43 0xb6f76efd in QMetaObject::metacall (object=0x8d95ce0, cl=QMetaObject::InvokeMetaMethod, idx=5, argv=0x93bcb78) at kernel/qmetaobject.cpp:237
#44 0xb6f80945 in QMetaCallEvent::placeMetaCall (this=0x82fa938, object=0x8d95ce0) at kernel/qobject.cpp:561
#45 0xb6f8393f in QObject::event (this=0x8d95ce0, e=0x82fa938) at kernel/qobject.cpp:1248
#46 0xb64a9c64 in QApplicationPrivate::notify_helper (this=0x80c4ee8, receiver=0x8d95ce0, e=0x82fa938) at kernel/qapplication.cpp:4302
#47 0xb64b1bf7 in QApplication::notify (this=0x80bea50, receiver=0x8d95ce0, e=0x82fa938) at kernel/qapplication.cpp:3706
#48 0xb758f991 in KApplication::notify (this=0x80bea50, receiver=0x8d95ce0, event=0x82fa938) at /usr/src/debug/kdelibs-4.5.4/kdeui/kernel/kapplication.cpp:310
#49 0xb6f70e0e in QCoreApplication::notifyInternal (this=0x80bea50, receiver=0x8d95ce0, event=0x82fa938) at kernel/qcoreapplication.cpp:726
#50 0xb6f749b4 in sendEvent (receiver=0x8d95ce0, event_type=43, data=0x8057368) at kernel/qcoreapplication.h:215
#51 QCoreApplicationPrivate::sendPostedEvents (receiver=0x8d95ce0, event_type=43, data=0x8057368) at kernel/qcoreapplication.cpp:1367
#52 0xb6f74b9c in QCoreApplication::sendPostedEvents (receiver=0x8d95ce0, event_type=43) at kernel/qcoreapplication.cpp:1260
#53 0xb5fec74f in QDBusPendingCallWatcher::waitForFinished (this=0x8d95ce0) at qdbuspendingcall.cpp:530
#54 0xb60427b0 in waitForWatcher (this=0x8d95ce8) at /usr/src/debug/libdbusmenu-qt-0.3.3/src/dbusmenuimporter.cpp:406
#55 DBusMenuImporter::slotMenuAboutToShow (this=0x8d95ce8) at /usr/src/debug/libdbusmenu-qt-0.3.3/src/dbusmenuimporter.cpp:439
#56 0xb6046a5c in DBusMenuImporter::qt_metacall (this=0x9388bb8, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbff5725c)
    at /usr/src/debug/libdbusmenu-qt-0.3.3/build/src/dbusmenuimporter.moc:94
#57 0xb6f76efd in QMetaObject::metacall (object=0x9388bb8, cl=QMetaObject::InvokeMetaMethod, idx=9, argv=0xbff5725c) at kernel/qmetaobject.cpp:237
#58 0xb6f85fe8 in QMetaObject::activate (sender=0x97b1348, m=0xb6ddf6c8, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3295
#59 0xb693cc65 in QMenu::aboutToShow (this=0x97b1348) at .moc/release-shared/moc_qmenu.cpp:151
#60 0xb69433d8 in QMenu::qt_metacall (this=0x97b1348, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbff5739c) at .moc/release-shared/moc_qmenu.cpp:97
#61 0xb6f76efd in QMetaObject::metacall (object=0x97b1348, cl=QMetaObject::InvokeMetaMethod, idx=27, argv=0xbff5739c) at kernel/qmetaobject.cpp:237
#62 0xb6f799c9 in QMetaMethod::invoke (this=0xbff5753c, object=0x97b1348, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., 
    val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1533
#63 0xb6f7a943 in QMetaObject::invokeMethod (obj=0x97b1348, member=0xa9dcbdce "aboutToShow", type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., 
    val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1113
#64 0xa9dc0d9e in invokeMethod (this=0x97eb3d8, x=1411, y=1030) at /usr/include/QtCore/qobjectdefs.h:416
#65 StatusNotifierItemSource::contextMenu (this=0x97eb3d8, x=1411, y=1030) at /usr/src/debug/kdebase-workspace-4.5.4/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:481
#66 0xa9dc3765 in StatusNotifierItemJob::start (this=0x821fe50) at /usr/src/debug/kdebase-workspace-4.5.4/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#67 0xb501399b in slotStart (this=0x821fe50, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbff57b0c) at /usr/src/debug/kdelibs-4.5.4/plasma/servicejob.cpp:37
#68 Plasma::ServiceJob::qt_metacall (this=0x821fe50, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbff57b0c) at /usr/src/debug/kdelibs-4.5.4/build/plasma/servicejob.moc:72
#69 0xa9dc16b2 in StatusNotifierItemJob::qt_metacall (this=0x821fe50, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0xbff57b0c)
    at /usr/src/debug/kdebase-workspace-4.5.4/build/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.moc:70
#70 0xb6f76efd in QMetaObject::metacall (object=0x821fe50, cl=QMetaObject::InvokeMetaMethod, idx=26, argv=0xbff57b0c) at kernel/qmetaobject.cpp:237
#71 0xb6f85fe8 in QMetaObject::activate (sender=0x8e4e720, m=0xb708c188, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3295
#72 0xb6f8b9d5 in QSingleShotTimer::timeout (this=0x8e4e720) at .moc/release-shared/qtimer.moc:82
#73 0xb6f8ba8c in QSingleShotTimer::timerEvent (this=0x8e4e720) at kernel/qtimer.cpp:308
#74 0xb6f83774 in QObject::event (this=0x8e4e720, e=0xbff58040) at kernel/qobject.cpp:1212
#75 0xb64a9c64 in QApplicationPrivate::notify_helper (this=0x80c4ee8, receiver=0x8e4e720, e=0xbff58040) at kernel/qapplication.cpp:4302
#76 0xb64b1bf7 in QApplication::notify (this=0x80bea50, receiver=0x8e4e720, e=0xbff58040) at kernel/qapplication.cpp:3706
#77 0xb758f991 in KApplication::notify (this=0x80bea50, receiver=0x8e4e720, event=0xbff58040) at /usr/src/debug/kdelibs-4.5.4/kdeui/kernel/kapplication.cpp:310
#78 0xb6f70e0e in QCoreApplication::notifyInternal (this=0x80bea50, receiver=0x8e4e720, event=0xbff58040) at kernel/qcoreapplication.cpp:726
#79 0xb6f9f70e in sendEvent (this=0x80cb2a4) at kernel/qcoreapplication.h:215
#80 QTimerInfoList::activateTimers (this=0x80cb2a4) at kernel/qeventdispatcher_unix.cpp:618
#81 0xb6f9c642 in timerSourceDispatch (source=0x80cb270) at kernel/qeventdispatcher_glib.cpp:184
#82 0xb5cf7b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#83 0xb5cf8350 in ?? () from /usr/lib/libglib-2.0.so.0
#84 0xb5cf860e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#85 0xb6f9cd4b in QEventDispatcherGlib::processEvents (this=0x80c5830, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#86 0xb655a19a in QGuiEventDispatcherGlib::processEvents (this=0x80c5830, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#87 0xb6f7011d in QEventLoop::processEvents (this=0xbff58304, flags=...) at kernel/qeventloop.cpp:149
#88 0xb6f70319 in QEventLoop::exec (this=0xbff58304, flags=...) at kernel/qeventloop.cpp:201
#89 0xb6f74c70 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#90 0xb64a7164 in QApplication::exec () at kernel/qapplication.cpp:3581
#91 0xb178466a in kdemain (argc=1, argv=0x80bbaa8) at /usr/src/debug/kdebase-workspace-4.5.4/plasma/desktop/shell/main.cpp:118
#92 0x0804e3f1 in _start ()

This bug may be a duplicate of or related to bug 229049.

Possible duplicates by query: bug 235830, bug 232249, bug 232142, bug 230673, bug 229049.

Reported using DrKonqi
Comment 1 Marco Martin 2010-12-07 14:16:24 UTC
seems to have something to do with dbusmenu-qt?
Comment 2 Aurelien Gateau 2010-12-07 14:54:52 UTC
Should be fixed in 4.6. Please reopen if it's not.

*** This bug has been marked as a duplicate of bug 241562 ***