Bug 258993 - when kdevelop crashes, project build configuration is not saved
Summary: when kdevelop crashes, project build configuration is not saved
Status: RESOLVED FIXED
Alias: None
Product: kdevelop
Classification: Unclassified
Component: Build tools: CMake (show other bugs)
Version: 4.1.0
Platform: Debian unstable Linux
: NOR minor (vote)
Target Milestone: 4.2.0
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-06 11:25 UTC by George Kiagiadakis
Modified: 2011-03-26 03:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description George Kiagiadakis 2010-12-06 11:25:37 UTC
Version:           4.1.0 (using KDE 4.5.3) 
OS:                Linux

Sometimes kdevelop crashes (unfortunately). When this happens, however, it is not a disaster as the unsaved contents of the editor, the open files, the open projects, etc are preserved, so I can just reopen it and continue (good!).

The problem however is that if I import a new cmake project, configure its build directory in the dialog that pops up and later kdevelop crashes, the build directory configuration is not saved, so when I re-open kdevelop, it asks me again to configure the build directory. This is highly annoying when I have a lot of projects open and especially since I have to change each one of the build directories to point to ~/kde/build/foo instead of ~/kde/src/foo/build that kdevelop shows by default.

The problem can go away only if I import a new project, close kdevelop and reopen it. It seems that this configuration is only saved when kdevelop closes.

I guess it shouldn't be too hard to change the code so that it saves this configuration right after closing the configuration dialog and not when closing kdevelop. Please :)


Reproducible: Always
Comment 1 Milian Wolff 2010-12-06 12:10:53 UTC
++ I'd like that as well
Comment 2 Aleix Pol 2011-03-26 03:54:07 UTC
Git commit 160ca1b0425330de26c5c530181cbba1c540b06b by Aleix Pol.
Committed on 08/03/2011 at 03:36.
Pushed by apol into branch '4.2'.

Sync config changes made while importing to the disk,
so that they're not lost if your computer doesn't work well.
(yep, can't be that kdevelop doesn't ;))

BUG: 258993

M  +1    -0    projectmanagers/cmake/cmakemanager.cpp     

http://commits.kde.org/kdevelop/160ca1b0425330de26c5c530181cbba1c540b06b