Bug 258965 - crash on save
Summary: crash on save
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Showfoto-Save (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-06 02:26 UTC by Nancy Hand
Modified: 2022-02-05 04:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nancy Hand 2010-12-06 02:26:50 UTC
Application: showfoto (1.2.0)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.3-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
I'd cropped a photo and was trying to save the .PNG with a new file name.

 -- Backtrace:
Application: showFoto (showfoto), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f0a0b83b7c0 (LWP 6134))]

Thread 6 (Thread 0x7f09f80c3710 (LWP 6135)):
#0  0x00007f0a0672939c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0a098622bb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f0a0b25f492 in Digikam::LoadSaveThread::run (this=0x8a40b0) at /usr/src/debug/digikam-1.2.0/libs/threadimageio/loadsavethread.cpp:131
#3  0x00007f0a09861bf5 in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007f0a06724a4f in start_thread () from /lib64/libpthread.so.0
#5  0x00007f0a083ca82d in clone () from /lib64/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f09f78c2710 (LWP 6136)):
[KCrash Handler]
#5  0x00007f0a083766a2 in strlen () from /lib64/libc.so.6
#6  0x00007f0a06dd488b in png_set_text_2 (png_ptr=0x7f09e0024f10, info_ptr=0x7f09e004c740, text_ptr=<value optimized out>, num_text=1) at pngset.c:707
#7  0x00007f0a06dd4ac9 in png_set_text (png_ptr=0x7f09e0024f10, info_ptr=<value optimized out>, text_ptr=<value optimized out>, num_text=<value optimized out>) at pngset.c:629
#8  0x00007f0a0b13dba8 in Digikam::PNGLoader::save (this=0x7f09f78c1ac0, filePath=..., observer=0x2100f60) at /usr/src/debug/digikam-1.2.0/libs/dimg/loaders/pngloader.cpp:797
#9  0x00007f0a0b12c7fb in Digikam::DImg::save (this=0x2100f78, filePath=..., format=<value optimized out>, observer=0x2100f60) at /usr/src/debug/digikam-1.2.0/libs/dimg/dimg.cpp:578
#10 0x00007f0a0b26ec9e in Digikam::SavingTask::execute (this=0x2100f50) at /usr/src/debug/digikam-1.2.0/libs/threadimageio/loadsavetask.cpp:418
#11 0x00007f0a0b25f4d6 in Digikam::LoadSaveThread::run (this=0x8c9ed0) at /usr/src/debug/digikam-1.2.0/libs/threadimageio/loadsavethread.cpp:134
#12 0x00007f0a09861bf5 in ?? () from /usr/lib64/libQtCore.so.4
#13 0x00007f0a06724a4f in start_thread () from /lib64/libpthread.so.0
#14 0x00007f0a083ca82d in clone () from /lib64/libc.so.6
#15 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f09f562e710 (LWP 6137)):
#0  0x00007f0a0672939c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0a098622bb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f0a0b25f492 in Digikam::LoadSaveThread::run (this=0xa7d850) at /usr/src/debug/digikam-1.2.0/libs/threadimageio/loadsavethread.cpp:131
#3  0x00007f0a09861bf5 in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007f0a06724a4f in start_thread () from /lib64/libpthread.so.0
#5  0x00007f0a083ca82d in clone () from /lib64/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f09ee7fc710 (LWP 6144)):
#0  0x00007f0a0672939c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0a098622bb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f0a0b25f492 in Digikam::LoadSaveThread::run (this=0xb7aae0) at /usr/src/debug/digikam-1.2.0/libs/threadimageio/loadsavethread.cpp:131
#3  0x00007f0a09861bf5 in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007f0a06724a4f in start_thread () from /lib64/libpthread.so.0
#5  0x00007f0a083ca82d in clone () from /lib64/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f09f4e2d710 (LWP 6145)):
#0  0x00007f0a0672939c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0a098622bb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f0a0b25f492 in Digikam::LoadSaveThread::run (this=0x2054e00) at /usr/src/debug/digikam-1.2.0/libs/threadimageio/loadsavethread.cpp:131
#3  0x00007f0a09861bf5 in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007f0a06724a4f in start_thread () from /lib64/libpthread.so.0
#5  0x00007f0a083ca82d in clone () from /lib64/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f0a0b83b7c0 (LWP 6134)):
#0  0x00007f0a083c16b3 in poll () from /lib64/libc.so.6
#1  0x00007f09ff921c0a in ?? () from /usr/lib64/libxcb.so.1
#2  0x00007f09ff922169 in ?? () from /usr/lib64/libxcb.so.1
#3  0x00007f09ff9221f7 in xcb_writev () from /usr/lib64/libxcb.so.1
#4  0x00007f0a0603f776 in _XSend () from /usr/lib64/libX11.so.6
#5  0x00007f0a0602bda7 in ?? () from /usr/lib64/libX11.so.6
#6  0x00007f0a0602bf8d in XPutImage () from /usr/lib64/libX11.so.6
#7  0x00007f0a08e1e400 in QX11PixmapData::fromImage(QImage const&, QFlags<Qt::ImageConversionFlag>) () from /usr/lib64/libQtGui.so.4
#8  0x00007f0a08e0b62f in QPixmap::fromImage(QImage const&, QFlags<Qt::ImageConversionFlag>) () from /usr/lib64/libQtGui.so.4
#9  0x00007f0a0b131793 in Digikam::DImg::convertToPixmap (this=0x7fff7da60e40) at /usr/src/debug/digikam-1.2.0/libs/dimg/dimg.cpp:1572
#10 0x00007f0a0b354e0b in Digikam::DImgInterface::paintOnDevice (this=0x814d90, p=<value optimized out>, sx=<value optimized out>, sy=0, sw=<value optimized out>, sh=<value optimized out>, dx=0, dy=
    0, dw=128, dh=128) at /usr/src/debug/digikam-1.2.0/utilities/imageeditor/canvas/dimginterface.cpp:715
#11 0x00007f0a0b36164c in Digikam::Canvas::paintViewport (this=0x87aaa0, er=..., antialias=true) at /usr/src/debug/digikam-1.2.0/utilities/imageeditor/canvas/canvas.cpp:647
#12 0x00007f0a0b361bc7 in Digikam::Canvas::viewportPaintEvent (this=0x87aaa0, e=<value optimized out>) at /usr/src/debug/digikam-1.2.0/utilities/imageeditor/canvas/canvas.cpp:540
#13 0x00007f0a07601f78 in Q3ScrollView::eventFilter(QObject*, QEvent*) () from /usr/lib64/libQt3Support.so.4
#14 0x00007f0a09948fd7 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#15 0x00007f0a08d3a4a1 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#16 0x00007f0a08d42aca in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#17 0x00007f0a0a22bc06 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#18 0x00007f0a09948e4c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#19 0x00007f0a08d861b2 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/libQtGui.so.4
#20 0x00007f0a08f3a1d8 in ?? () from /usr/lib64/libQtGui.so.4
#21 0x00007f0a08d7c940 in QWidgetPrivate::syncBackingStore() () from /usr/lib64/libQtGui.so.4
#22 0x00007f0a08d8b272 in QWidget::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#23 0x00007f0a09136a6b in QMainWindow::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#24 0x00007f0a0a2a94a3 in KXmlGuiWindow::event(QEvent*) () from /usr/lib64/libkdeui.so.5
#25 0x00007f0a08d3a4d4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#26 0x00007f0a08d42aca in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#27 0x00007f0a0a22bc06 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#28 0x00007f0a09948e4c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#29 0x00007f0a0994c5ba in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#30 0x00007f0a09971173 in ?? () from /usr/lib64/libQtCore.so.4
#31 0x00007f0a02349a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#32 0x00007f0a0234a270 in ?? () from /usr/lib64/libglib-2.0.so.0
#33 0x00007f0a0234a510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#34 0x00007f0a0997167f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#35 0x00007f0a08ddb14e in ?? () from /usr/lib64/libQtGui.so.4
#36 0x00007f0a09948292 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#37 0x00007f0a09948495 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#38 0x00007f0a0994c88b in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#39 0x000000000042c00b in main (argc=1, argv=0x7fff7da63708) at /usr/src/debug/digikam-1.2.0/showfoto/main.cpp:87

This bug may be a duplicate of or related to bug 247908.

Possible duplicates by query: bug 247908, bug 231631.

Reported using DrKonqi
Comment 1 caulier.gilles 2010-12-06 08:28:22 UTC

*** This bug has been marked as a duplicate of bug 247908 ***
Comment 2 caulier.gilles 2022-01-20 06:44:17 UTC
Fixed with https://bugs.kde.org/show_bug.cgi?id=247908