Bug 258852 - Unplug directly nokia n97 mini ( PC suite mode ) lead to crash
Summary: Unplug directly nokia n97 mini ( PC suite mode ) lead to crash
Status: RESOLVED FIXED
Alias: None
Product: solid
Classification: Unclassified
Component: networkmanagement-mobile (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lamarque V. Souza
URL:
Keywords:
: 266818 270337 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-12-04 22:41 UTC by Bruno Friedmann
Modified: 2011-06-13 21:25 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (11.48 KB, text/plain)
2010-12-25 12:17 UTC, Bruno Friedmann
Details
New crash information added by DrKonqi (9.20 KB, text/plain)
2011-01-05 15:40 UTC, Bruno Friedmann
Details
Fix memory leak (7.45 KB, patch)
2011-01-05 19:16 UTC, Lamarque V. Souza
Details
crashlog upon unplugging option icon 225 (6.55 KB, text/plain)
2011-02-22 13:12 UTC, Tamás Németh
Details
New crash information added by DrKonqi (8.89 KB, text/plain)
2011-03-14 07:02 UTC, Bruno Friedmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Friedmann 2010-12-04 22:41:14 UTC
Application: kded4 ($Id: kded.cpp 1192875 2010-11-04 08:22:15Z ervin $)
KDE Platform Version: 4.5.80 (4.6 Beta1)
Qt Version: 4.7.1
Operating System: Linux 2.6.37-rc3-git6-8-desktop x86_64
Distribution: "openSUSE 11.4 Milestone 4 of 6 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed: I've plug 2 hours before my nokia n97 mini to refill the battery, I've set it in "PC Suite mode". Now it was full I unplug it from the usb cable, without any other attention. I know it's bad :-) 

So I get this crash, and you this report :-)

The crash can be reproduced some of the time.

-- Backtrace:
Application: Démon de KDE (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f552a9b0760 (LWP 7104))]

Thread 2 (Thread 0x7f550b15c700 (LWP 7127)):
#0  0xffffffffff600177 in ?? ()
#1  0x00007fffa97d07a1 in ?? ()
#2  0x00007f55251f82b3 in clock_gettime () from /lib64/librt.so.1
#3  0x00007f55295ff272 in qt_gettime() () from /usr/lib64/libQtCore.so.4
#4  0x00007f55296c22ed in QTimerInfoList::updateCurrentTime() () from /usr/lib64/libQtCore.so.4
#5  0x00007f55296c2675 in QTimerInfoList::timerWait(timeval&) () from /usr/lib64/libQtCore.so.4
#6  0x00007f55296c114c in timerSourcePrepareHelper(GTimerSource*, int*) () from /usr/lib64/libQtCore.so.4
#7  0x00007f55296c11f5 in timerSourcePrepare(_GSource*, int*) () from /usr/lib64/libQtCore.so.4
#8  0x00007f5524f4b787 in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#9  0x00007f5524f4c689 in g_main_context_iterate () from /lib64/libglib-2.0.so.0
#10 0x00007f5524f4cd30 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#11 0x00007f55296c1936 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#12 0x00007f5529695fe2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#13 0x00007f55296961f5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#14 0x00007f55295ab0d4 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#15 0x00007f5529677918 in QInotifyFileSystemWatcherEngine::run() () from /usr/lib64/libQtCore.so.4
#16 0x00007f55295ad94e in QThreadPrivate::start(void*) () from /usr/lib64/libQtCore.so.4
#17 0x00007f551cb2aa33 in ?? () from /usr/lib64/libGL.so.1
#18 0x00007f552931ea4f in start_thread () from /lib64/libpthread.so.0
#19 0x00007f55280da52d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#20 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f552a9b0760 (LWP 7104)):
[KCrash Handler]
#6  0x00007f55296addb1 in QObject::~QObject() () from /usr/lib64/libQtCore.so.4
#7  0x00007f54feb99c9e in MMModemGsmNetworkInterface::~MMModemGsmNetworkInterface (this=0xcfac50, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.5.80/solid/modemmanager-0.4/modemgsmnetworkinterface.cpp:48
#8  0x00007f54feb99ce9 in MMModemGsmNetworkInterface::~MMModemGsmNetworkInterface (this=0xcfac50, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.5.80/solid/modemmanager-0.4/modemgsmnetworkinterface.cpp:51
#9  0x00007f550bc5444d in Solid::Control::ModemManagerPrivate::_k_modemInterfaceRemoved (this=0xa50410, udi=...) at /usr/src/debug/kdebase-workspace-4.5.80/libs/solid/control/modemmanager.cpp:166
#10 0x00007f550bc54699 in Solid::Control::ModemManagerPrivate::qt_metacall (this=0xa50410, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffa9708d30) at /usr/src/debug/kdebase-workspace-4.5.80/build/libs/solid/control/modemmanager_p.moc:82
#11 0x00007f55296abdbf in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#12 0x00007f54feb8e4e5 in MMModemManager::modemInterfaceRemoved (this=<value optimized out>, _t1=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.5.80/build/solid/modemmanager-0.4/manager.moc:123
#13 0x00007f54feb8e87a in MMModemManager::deviceRemoved (this=0xd04ee0, objpath=...) at /usr/src/debug/kdebase-workspace-4.5.80/solid/modemmanager-0.4/manager.cpp:145
#14 0x00007f54feb8ea40 in MMModemManager::qt_metacall (this=0xd04ee0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffa9708ee0) at /usr/src/debug/kdebase-workspace-4.5.80/build/solid/modemmanager-0.4/manager.moc:95
#15 0x00007f55296abdbf in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#16 0x00007f54feba0035 in OrgFreedesktopModemManagerInterface::DeviceRemoved (this=<value optimized out>, _t1=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.5.80/build/solid/modemmanager-0.4/mm-manager-clientinterface.moc:102
#17 0x00007f54feba01d8 in OrgFreedesktopModemManagerInterface::qt_metacall (this=0xd04100, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x7fffa9709110) at /usr/src/debug/kdebase-workspace-4.5.80/build/solid/modemmanager-0.4/mm-manager-clientinterface.moc:81
#18 0x00007f55264edd08 in QDBusConnectionPrivate::deliverCall(QObject*, int, QDBusMessage const&, QList<int> const&, int) () from /usr/lib64/libQtDBus.so.4
#19 0x00007f55264f8daf in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib64/libQtDBus.so.4
#20 0x00007f55296aaa3a in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#21 0x00007f5528846d24 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#22 0x00007f552884f21a in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#23 0x00007f552a3395a6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#24 0x00007f5529696bac in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#25 0x00007f552969a3a5 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#26 0x00007f55296c1743 in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /usr/lib64/libQtCore.so.4
#27 0x00007f5524f4c2b3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#28 0x00007f5524f4ca90 in g_main_context_iterate () from /lib64/libglib-2.0.so.0
#29 0x00007f5524f4cd30 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#30 0x00007f55296c18df in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#31 0x00007f55288ebd2e in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtGui.so.4
#32 0x00007f5529695fe2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#33 0x00007f55296961f5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#34 0x00007f552969a65b in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#35 0x00007f5518974657 in kdemain (argc=1, argv=0x6cd090) at /usr/src/debug/kdelibs-4.5.80/kded/kded.cpp:907
#36 0x00000000004075f9 in launch (argc=1, _name=0x40b4bc "kded4", args=<value optimized out>, cwd=0x0, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40b357 "0") at /usr/src/debug/kdelibs-4.5.80/kinit/kinit.cpp:730
#37 0x0000000000409e0a in main (argc=4, argv=0x7fffa970ac48, envp=0x7fffa970ac70) at /usr/src/debug/kdelibs-4.5.80/kinit/kinit.cpp:1844

Reported using DrKonqi
Comment 1 Bruno Friedmann 2010-12-25 12:17:46 UTC
Created attachment 55225 [details]
New crash information added by DrKonqi

kded4 ($Id: kded.cpp 1204125 2010-12-06 11:17:10Z dfaure $) on KDE Platform 4.5.90 (4.6 RC1) using Qt 4.7.1

- What I was doing when the application crashed: After recharging the phone by the usb plug, (This time I didn't activate the PC Suite mode, just let the phone doing it's charging phase) 
After several hours (+5 or 6) I get this crash.

Here's what the kernel said in dmesg 
[31158.448416] process `sysctl' is using deprecated sysctl (syscall) net.ipv6.neigh.default.retrans_time; Use net.ipv6.neigh.default.retrans_time_ms instead.
[37593.158449] usb 2-4.4: new high speed USB device using ehci_hcd and address 8
[37593.244181] usb 2-4.4: New USB device found, idVendor=0421, idProduct=026a
[37593.244190] usb 2-4.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[37593.244198] usb 2-4.4: Product: Nokia N97 mini
[37593.244204] usb 2-4.4: Manufacturer: Nokia
[37593.244209] usb 2-4.4: SerialNumber: 358315039835228
[37593.245801] scsi5 : usb-storage 2-4.4:1.0
[37594.245829] scsi 5:0:0:0: Direct-Access     Nokia    S60              1.0  PQ: 0 ANSI: 0
[37594.246083] sd 5:0:0:0: Attached scsi generic sg2 type 0
[37594.248118] scsi 5:0:0:1: Direct-Access     Nokia    S60              1.0  PQ: 0 ANSI: 0
[37594.248289] sd 5:0:0:1: Attached scsi generic sg3 type 0
[37594.249121] sd 5:0:0:0: [sdb] 15638528 512-byte logical blocks: (8.00 GB/7.45 GiB)
[37594.250185] sd 5:0:0:0: [sdb] Write Protect is off
[37594.250189] sd 5:0:0:0: [sdb] Mode Sense: 03 00 00 00
[37594.250191] sd 5:0:0:0: [sdb] Assuming drive cache: write through
[37594.251254] sd 5:0:0:1: [sdc] Attached SCSI removable disk
[37594.252835] sd 5:0:0:0: [sdb] Assuming drive cache: write through
[37594.347378]  sdb: sdb1
[37594.347385] sdb: p1 size 15720448 extends beyond EOD, enabling native capacity
[37594.350825] sd 5:0:0:0: [sdb] Assuming drive cache: write through
[37594.351604]  sdb: sdb1
[37594.351608] sdb: p1 size 15720448 extends beyond EOD, truncated
[37594.356201] sd 5:0:0:0: [sdb] Assuming drive cache: write through
[37594.356205] sd 5:0:0:0: [sdb] Attached SCSI removable disk
[40374.034002] usb 2-4.4: USB disconnect, address 8
[40430.022255] usb 2-4.4: new high speed USB device using ehci_hcd and address 9
[40430.108247] usb 2-4.4: New USB device found, idVendor=0421, idProduct=026c
[40430.108250] usb 2-4.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[40430.108253] usb 2-4.4: Product: Nokia N97 mini
[40430.108255] usb 2-4.4: Manufacturer: Nokia
[40430.108257] usb 2-4.4: SerialNumber: 358315039835228
[40430.337432] cdc_acm 2-4.4:1.1: ttyACM0: USB ACM device
[40430.338283] cdc_acm 2-4.4:1.3: ttyACM1: USB ACM device
[40430.338579] usbcore: registered new interface driver cdc_acm
[40430.338581] cdc_acm: v0.26:USB Abstract Control Model driver for USB modems and ISDN adapters
[40430.374438] NET: Registered protocol family 35
[40430.380766] usbcore: registered new interface driver cdc_ether
[40430.387276] usbcore: registered new interface driver rndis_host
[40430.397076] cdc_phonet: probe of 2-4.4:1.12 failed with error -22
[40430.397091] usbcore: registered new interface driver cdc_phonet
[40430.420474] usbcore: registered new interface driver rndis_wlan
[94609.561713] usb 2-4.4: USB disconnect, address 9

Nothing really related was found in .xsession-errors ( or I didn't catch it, due to the noise of others messages )

-- Backtrace (Reduced):
#6  QObject::~QObject (this=0xc8cb20, __in_chrg=<value optimized out>) at kernel/qobject.cpp:922
#7  0x00007f48d356fd4e in MMModemGsmNetworkInterface::~MMModemGsmNetworkInterface (this=0xc8cb20, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.5.90/solid/modemmanager-0.4/modemgsmnetworkinterface.cpp:48
#8  0x00007f48d356fd99 in MMModemGsmNetworkInterface::~MMModemGsmNetworkInterface (this=0xc8cb20, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.5.90/solid/modemmanager-0.4/modemgsmnetworkinterface.cpp:51
#9  0x00007f48ded8e10d in Solid::Control::ModemManagerPrivate::_k_modemInterfaceRemoved (this=0xa68bc0, udi=...) at /usr/src/debug/kdebase-workspace-4.5.90/libs/solid/control/modemmanager.cpp:166
#10 0x00007f48ded8e359 in Solid::Control::ModemManagerPrivate::qt_metacall (this=0xa68bc0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff28b3080) at /usr/src/debug/kdebase-workspace-4.5.90/build/libs/solid/control/modemmanager_p.moc:82
Comment 2 Bruno Friedmann 2011-01-05 15:40:47 UTC
Created attachment 55606 [details]
New crash information added by DrKonqi

kded4 ($Id: kded.cpp 1204125 2010-12-06 11:17:10Z dfaure $) on KDE Platform 4.5.90 (4.6 RC1) using Qt 4.7.1

- What I was doing when the application crashed:
I've to start quickly, and remove the phone from the computer, without using anything

-- Backtrace (Reduced):
#6  QObject::~QObject (this=0xc9e730, __in_chrg=<value optimized out>) at kernel/qobject.cpp:922
#7  0x00007f42f9b7bd4e in MMModemGsmNetworkInterface::~MMModemGsmNetworkInterface (this=0xc9e730, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.5.90/solid/modemmanager-0.4/modemgsmnetworkinterface.cpp:48
#8  0x00007f42f9b7bd99 in MMModemGsmNetworkInterface::~MMModemGsmNetworkInterface (this=0xc9e730, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.5.90/solid/modemmanager-0.4/modemgsmnetworkinterface.cpp:51
#9  0x00007f4308a3f10d in Solid::Control::ModemManagerPrivate::_k_modemInterfaceRemoved (this=0xd42340, udi=...) at /usr/src/debug/kdebase-workspace-4.5.90/libs/solid/control/modemmanager.cpp:166
#10 0x00007f4308a3f359 in Solid::Control::ModemManagerPrivate::qt_metacall (this=0xd42340, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff29c4af40) at /usr/src/debug/kdebase-workspace-4.5.90/build/libs/solid/control/modemmanager_p.moc:82
Comment 3 Lamarque V. Souza 2011-01-05 19:15:06 UTC
Well, I have investigated the problem but I still have no clue to why that is happening to your N97. There is no crash with my Samsung i8910 and my Sony MD300 when I remove them, actually I have not faced a crash for months when using my MD300 modem. I still use KDE SC 4.5.4 and Qt 4.6.3 though.

During my investigations I have found a small memory leak in my Solid MM implementation. The leak happens when someone hooks the modem up and it happens only once per hook up, which is not that often so the "small" in my statement. I have a patch to fix it. I am not sure it breaks binary compatibility so I have not commit it yet. I will attach it and you can try it to see if it also fixes your problem. I think it will not, but hey, I am not always right :-)
Comment 4 Lamarque V. Souza 2011-01-05 19:16:51 UTC
Created attachment 55621 [details]
Fix memory leak

Fix a small memory leak in Solid MM backend.
Comment 5 Bruno Friedmann 2011-01-05 21:10:57 UTC
Thanks to have a look at it.

I will try to build with the patch, but no guaranty about that, I'm normally using already made packages. 

But I've request some help. Next time I will check if the modem is know by networkmanager
Comment 6 Lamarque V. Souza 2011-02-21 21:56:46 UTC
*** Bug 266818 has been marked as a duplicate of this bug. ***
Comment 7 Tamás Németh 2011-02-22 13:12:17 UTC
Created attachment 57441 [details]
crashlog upon unplugging option icon 225

This happens when unplugging my Option iCon 225 while using software version 0.9.1git20110127, too.
Comment 8 Lamarque V. Souza 2011-02-23 03:17:10 UTC
Git commit 800a48c828704c3d00f70e3296ca3dcf9947f302 by Lamarque V. Souza.
Committed on 23/02/2011 at 03:12.
Pushed by lvsouza into branch 'master'.

Try to avoid the crash reported in bug 258852. I have not been able to
reproduce it, I am not sure if this will work it out.

CCBUG: 258852

M  +1    -1    solid/modemmanager-0.4/modeminterface.cpp     
M  +1    -1    solid/modemmanager-0.4/modeminterface.h     

http://commits.kde.org/kde-workspace/800a48c828704c3d00f70e3296ca3dcf9947f302
Comment 9 Bruno Friedmann 2011-03-14 07:02:46 UTC
Created attachment 57951 [details]
New crash information added by DrKonqi

kded4 ($Id$) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.2

- What I was doing when the application crashed:
Unplug uncarefully my nokia n97 mini. When plugged no choice have been made between mode (Pc suite, mass storage etc).

-- Backtrace (Reduced):
#6  QObject::~QObject (this=0xe369d0, __in_chrg=<optimized out>) at kernel/qobject.cpp:923
#7  0x00007fdb1db95d4e in MMModemGsmNetworkInterface::~MMModemGsmNetworkInterface (this=0xe369d0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdebase-workspace-4.6.1/solid/modemmanager-0.4/modemgsmnetworkinterface.cpp:48
#8  0x00007fdb1db95d99 in MMModemGsmNetworkInterface::~MMModemGsmNetworkInterface (this=0xe369d0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdebase-workspace-4.6.1/solid/modemmanager-0.4/modemgsmnetworkinterface.cpp:51
#9  0x00007fdb2381a0fd in Solid::Control::ModemManagerPrivate::_k_modemInterfaceRemoved (this=0x95d6e0, udi=...) at /usr/src/debug/kdebase-workspace-4.6.1/libs/solid/control/modemmanager.cpp:166
#10 0x00007fdb2381a349 in Solid::Control::ModemManagerPrivate::qt_metacall (this=0x95d6e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe7e4cdf0) at /usr/src/debug/kdebase-workspace-4.6.1/build/libs/solid/control/modemmanager_p.moc:82
Comment 10 Lamarque V. Souza 2011-04-08 01:14:01 UTC
*** Bug 270337 has been marked as a duplicate of this bug. ***
Comment 11 Lamarque V. Souza 2011-04-12 23:54:54 UTC
Git commit e831217493451118982629fb747dac04b5628076 by Lamarque V. Souza.
Committed on 23/02/2011 at 03:12.
Pushed by lvsouza into branch 'KDE/4.6'.

Try to avoid the crash reported in bug 258852. I have not been able to
reproduce it, I am not sure if this will work it out.

CCBUG: 258852

M  +1    -1    solid/modemmanager-0.4/modeminterface.cpp     
M  +1    -1    solid/modemmanager-0.4/modeminterface.h     

http://commits.kde.org/kde-workspace/e831217493451118982629fb747dac04b5628076
Comment 12 Lamarque V. Souza 2011-04-15 03:26:52 UTC
Git commit a0fc87f7e8ef5b01290a3ca5d2db59928e3d6449 by Lamarque V. Souza.
Committed on 15/04/2011 at 03:19.
Pushed by lvsouza into branch 'KDE/4.6'.

Reverting e831217493451118982629fb747dac04b5628076 and applying a better
solution suggested by André Wöbbeking. Thanks for helping me solve the
MMModemInterface invalid free problem.

CCBUG: 258852

M  +6    -1    solid/modemmanager-0.4/modeminterface.cpp     
M  +1    -1    solid/modemmanager-0.4/modeminterface.h     
M  +1    -0    solid/modemmanager-0.4/modeminterface_p.h     

http://commits.kde.org/kde-workspace/a0fc87f7e8ef5b01290a3ca5d2db59928e3d6449
Comment 13 Lamarque V. Souza 2011-04-15 03:29:49 UTC
Git commit 56e1371b47c3ca2000728ac4d6d7d6025fe09974 by Lamarque V. Souza.
Committed on 15/04/2011 at 03:19.
Pushed by lvsouza into branch 'master'.

Reverting e831217493451118982629fb747dac04b5628076 and applying a better
solution suggested by André Wöbbeking. Thanks for helping me solve the
MMModemInterface invalid free problem.

CCBUG: 258852
(cherry picked from commit a0fc87f7e8ef5b01290a3ca5d2db59928e3d6449)

M  +6    -1    solid/modemmanager-0.4/modeminterface.cpp     
M  +1    -1    solid/modemmanager-0.4/modeminterface.h     
M  +1    -0    solid/modemmanager-0.4/modeminterface_p.h     

http://commits.kde.org/kde-workspace/56e1371b47c3ca2000728ac4d6d7d6025fe09974
Comment 14 Lamarque V. Souza 2011-06-13 09:10:11 UTC
I did some changes some weeks ago, can you test if this problem still happens?
Comment 15 Bruno Friedmann 2011-06-13 18:28:34 UTC
Hi Vincent, actually on a kde 4.6.4 base + Networkmanager 0.9.2 + 
Network plamoid (which didn't contain anymore thx NetworkManager) my phone provider connection.
When I unplug, I didn't see any crash actually.

Seems to be fixed. I let you close it with appropriate fix resolution