Bug 258611 - Whole desktop(with KDE desktop efects turned on) becomes black after exiting VLC fulscreen.
Summary: Whole desktop(with KDE desktop efects turned on) becomes black after exiting ...
Status: RESOLVED DUPLICATE of bug 177495
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-02 21:09 UTC by peto.milan
Modified: 2010-12-02 22:23 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peto.milan 2010-12-02 21:09:20 UTC
Version:           4.5 (using KDE 4.5.1) 
OS:                Linux

This problem happens only if the desktop effects are on (probably it is issue mainly of transparent panels). After exiting VLC fulscreeen entire desktop is black. after maximinizing any window from taskbar, everything is again fine.

Reproducible: Always

Steps to Reproduce:
every time exit fullscreen with desktop effects turned oon

Actual Results:  
black desktop
Comment 1 Martin Flöser 2010-12-02 21:59:44 UTC
Could this be a duplicate of bug #177495
Comment 2 peto.milan 2010-12-02 22:22:10 UTC
yes thanks for link with this bug. Its second comment really helped for me :

> If we don't find a solution for it than we should set UnredirectFullscreen to
> false by default. I think the flickering is worse than the problems with videos
> or OpenGL application and for these cases we have the shortcut to suspend
> compositing.
> 
> You can disable unredirecting the following way:
> 1. open ~/.kde/share/config/kwinrc in an editor
> 2. go to section [Compositing]
> 3. Add following line:
> UnredirectFullscreen=false
> 4. Save file and restart kwin (alt+f2 and kwin --replace)
Comment 3 peto.milan 2010-12-02 22:23:20 UTC

*** This bug has been marked as a duplicate of bug 177495 ***