Bug 258600 - transupp.cpp fails to compile on emerged kde
Summary: transupp.cpp fails to compile on emerged kde
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Portability-Compilation (show other bugs)
Version: 2.0.0
Platform: Microsoft Windows Microsoft Windows
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-02 19:46 UTC by Gert Kello
Modified: 2017-08-19 20:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 1.7.0


Attachments
jpegutils compilation fix (1.86 KB, patch)
2010-12-02 19:46 UTC, Gert Kello
Details
jpeglossless kipi-plugin fix (2.83 KB, patch)
2010-12-02 19:50 UTC, Gert Kello
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gert Kello 2010-12-02 19:46:24 UTC
Created attachment 54001 [details]
jpegutils compilation fix

Version:           2.0.0 (using KDE 4.5.3) 
OS:                MS Windows

Digikam fails to compile transupp.cpp on emerged windows kde (mingw4), due to way the libjpeg is built by emerge. Same problem with lossless jpeg operations kipi-plugin

Reproducible: Didn't try
Comment 1 Gert Kello 2010-12-02 19:50:31 UTC
Created attachment 54002 [details]
jpeglossless kipi-plugin fix
Comment 2 caulier.gilles 2010-12-02 20:24:02 UTC
Gert,

You assign this patch to 2.0.0. it's the same for current implementation from svn (next 1.7.0) ?

Gilles Caulier
Comment 3 Gert Kello 2010-12-03 11:13:02 UTC
Yes, the same problem with 1.7.0 svn and patch applies cleanly (the jpeg code part seems to be identical in 1.7.0 and GoSC2010 branch)

Gert
Comment 4 caulier.gilles 2010-12-03 11:30:42 UTC
SVN commit 1203150 by cgilles:

apply patch #54001 from Gert Kello
CCBUGS: 258600


 M  +8 -0      jpegutils.cpp  
 M  +8 -0      libjpeg-62/transupp.cpp  
 M  +8 -0      libjpeg-80/transupp.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1203150
Comment 5 caulier.gilles 2010-12-03 11:32:34 UTC
SVN commit 1203152 by cgilles:

apply patch #54002 from Gert Kello
BUGS: 258600


 M  +8 -0      convert2grayscale.cpp  
 M  +8 -0      imageflip.cpp  
 M  +8 -0      imagerotate.cpp  
 M  +8 -0      jpegtransform.cpp  
 M  +8 -0      transupp.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1203152