Bug 258559 - Logout & Shutdown pop-up doesn't work with enter and escape key
Summary: Logout & Shutdown pop-up doesn't work with enter and escape key
Status: RESOLVED WORKSFORME
Alias: None
Product: ksmserver
Classification: Plasma
Component: ui (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR minor with 20 votes (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-02 13:34 UTC by Luke
Modified: 2011-11-25 12:06 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
btw. why there are black corners? i have these on two different machines one on xf86-video-ati second on nvidia, and this glitch appears since kde4 (18.42 KB, image/jpeg)
2010-12-02 13:34 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2010-12-02 13:34:08 UTC
Created attachment 53975 [details]
btw. why there are black corners? i have these on two different machines one on xf86-video-ati second on nvidia, and this glitch appears since kde4

Version:           unspecified (using KDE 4.5.80) 
OS:                Linux

Shutdown/logout pop-up dialog doesn't co-operate with keyboard.

Reproducible: Always

Steps to Reproduce:
kmenu -> leave -> shutdown or logout -> popup will be launched, there is no way to cofirm with enter or cancel with escape key


Expected Results:  
It suposed to be confirmed with enter and canceled with escape, doesn't it?

Clean kde sc 4.6 beta1 on archlinux x86_64
Comment 1 Jerry L Kreps 2011-03-01 19:47:52 UTC
I am running Kubuntu 10.4 LTS fully updated.  For the past couple of weeks the Lock/Logout plasmoid has not worked properly.  It will work right after I log in, but after a short while it refuses to react to a click so I can log out or shut down.   Currently I have ctrl+alt+del set to kill the xserver, which throws be back to the login screen.  The button on that screen does work.  IF I log back in the Lock/Logout button refuses to work after I have used a few applications.   I am not able to pin it down to a specific application which causes the problem.
Comment 2 Aaron J. Seigo 2011-11-24 12:08:47 UTC
escape works here.. can't try enter, unfortunately as i can't exit my session at the moment.. can you confirm that this still affects you?

(also: comment #1 is a distribution issue and unrelated to this report)
Comment 3 Luke 2011-11-24 12:38:47 UTC
Right now I can test only my virtual machine Archlinux x86_64 with KDE 4.7.3 and it still doesn't react on escape or enter

BTW I just realized: canceling restart dialog is giving me an error: 
Executable: kdeinit4 PID: 2817 Signal: Segmentation fault (11)
Comment 4 Fabio 2011-11-24 13:45:12 UTC
I can confirm that there isn't focus on that widget.
Comment 5 Luke 2011-11-24 18:36:29 UTC
I've just tried 4.8 beta 1 (4.7.80) and pop-ups dialogs seems to work with escape and enter :)
Comment 6 Beat Wolf 2011-11-25 11:49:22 UTC
so in that case this can be marked as fixed/worksforme?
Comment 7 Luke 2011-11-25 12:01:54 UTC
I don't know, it was broken since 4.0 and now in 4.8 beta 1 is fixed but I can't tell if it's intentional or just coincidence and with final release it'll stop working again?
Comment 8 Beat Wolf 2011-11-25 12:06:17 UTC
if it works now in 4.8 then its fixed. if it breaks again, then a new bugreport should be opened.