Bug 258369 - different behavior on return-key and mouse click usage in file manager mode
Summary: different behavior on return-key and mouse click usage in file manager mode
Status: RESOLVED DUPLICATE of bug 250475
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords: reproducible
Depends on:
Blocks:
 
Reported: 2010-11-30 13:06 UTC by cbaabc
Modified: 2011-02-12 19:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cbaabc 2010-11-30 13:06:49 UTC
Version:           unspecified (using KDE 4.5.3) 
OS:                Linux

I use Konqueror as a file manager and if I try to open an application with the return-key or with a left mouse click, something different happens.

A application opens with the return-key the "open with" dialog while the left click starts it.

Reproducible: Always

Steps to Reproduce:
1. Open a application file with a left click.

2. Open a application file with the return key.

Actual Results:  
1. Application starts.

2. "open with" dialog opens.

Expected Results:  
Both should start the application.

Konqueror version 4.5.3 but happend with prior versions too
Comment 1 Frank Reininghaus 2010-11-30 21:25:47 UTC
Thanks for the bug report! I'll reassign to Dolphin because Konqueror uses Dolphin's file management code and I can also reproduce this in Dolphin (to be precise, I don't get the "Open With" dialog, but Dolphin tries to open the application in KWrite, but the root cause is most likely the same):

1. Run 'dolphin applications:'
2. Click an application -> it is run
3. Navigate to an application with the arrow keys and press Enter -> Dolphin tries to open the application in KWrite.

Reproduced in yesterday's trunk.
Comment 2 Frank Reininghaus 2011-02-12 19:14:06 UTC
This will be fixed in 4.6.1.

*** This bug has been marked as a duplicate of bug 250475 ***