Bug 258350 - choose special transport dialog: Not possible to select second account
Summary: choose special transport dialog: Not possible to select second account
Status: RESOLVED UNMAINTAINED
Alias: None
Product: KMail Mobile
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Windows CE Microsoft Windows CE
: HI normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-30 11:09 UTC by Ludwig Reiter
Modified: 2016-09-29 07:54 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ludwig Reiter 2010-11-30 11:09:30 UTC
Version:           unspecified (using Devel) 
OS:                Linux

version: 20101122.1199643-1maemo1 (enterprise5 experimental)



Reproducible: Always

Steps to Reproduce:
Configure two Kolab accounts.
Open identity configure dialog.
Select advanced tab.
Try to change the special transport.

Actual Results:  
The first account is doubled and the second is not displayed.
(e.g. two times "demo", no "demo2")

Expected Results:  
Can select both accounts. The special transport is used in sending the mails of this identity.
Comment 1 Tobias Koenig 2010-12-28 11:24:08 UTC
Hej Ludwig,

maybe this is a misunderstanding here. The special transport combobox shows the names of the configured SMTP accounts, not of the IMAP accounts. The default names of the SMTP accounts are the hostname of the SMTP server (e.g. demo.kolab.org), so if you configure two accounts that use the same SMTP server, the name of the SMTP server will be shown twice correctly.

Can you confirm this? Or do you see another bug?

Ciao,
Tobias
Comment 2 Ludwig Reiter 2011-01-20 15:01:01 UTC
tested with Mail Touch (Windows CE) 2011-01-16

Note: To configure a transport use Composer/actions/transport

I found two problems:
* The pw of a transport is not used in sending a mail.
1. Open composer 
2. Open Special trans dialog
3. Select default SMTP transport
4. change the Pw to something wrong.
5. Ok(2times)
6. Try to send a mail
=> Worked, but How can this work I changed the passw, how can it auth itself?

* The special transport of non-default id is not used.
1. Configure another special transport in the composer
2. Open the identities configuration dialog.
3. Add another id with the configured special transport.
4. Open a composer.
5. Change to the second id.
6. Write a mail and send it.
7. Look at the mail.
Comment 3 Tobias Koenig 2011-01-21 15:30:43 UTC
SVN commit 1216136 by tokoe:

Update the password of all Transport instances when
changing the password in the configuration dialog.

Fixes first part of bug 258350

CCBUG: 258350


 M  +21 -17    transport.cpp  
 A             transport_p.h   [License: LGPL (v2+)]
 M  +2 -0      transportmanager.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1216136
Comment 4 Tobias Koenig 2011-01-21 16:12:40 UTC
Git commit a3c49aa18e41ce9a038b1f5e6c88ba381a79b5d9 by Tobias Koenig
Pushed by tokoe into branch master

Update the Transport combobox on identity change

This ensures that a special transport, configured for an identity,
is used in the message composer.

Fixes second part of 258350 -> closing

BUG: 258350

M  +5    -0    mobile/mail/composerview.cpp     

http://commits.kde.org/ee6cc38b/a3c49aa18e41ce9a038b1f5e6c88ba381a79b5d9
Comment 5 Andre Heinecke 2011-02-15 19:23:57 UTC
As far as i know bricks has tested this. I myself can not verify this fix since i have not tested it again.
Comment 6 Bjoern Ricks 2011-02-16 11:01:46 UTC
I didn't test this issue in the past. Tried to reproduce the second part of the issue (special transport is set but not used) but I am not sure if that works. Ludwig could you please re-test it?
Comment 7 Ludwig Reiter 2011-02-18 10:58:45 UTC
Kontact Touch Windows CE 2011-02-11

My test show, that the pasword handling still has a problem.

I open the send default transport and change the password. But can still send a mail. (Wrong)

Special transport seems to be recognized. 
But he asked me with a dialog for the password of the special transport, even when I have entered the right password in the dialog before.

So Reopened
Comment 8 Tobias Koenig 2011-05-15 11:36:40 UTC
Git commit a7e1a4007a2ef07e05d61ea1e47cbb2e04d7f3bf by Tobias Koenig.
Committed on 21/01/2011 at 15:29.
Pushed by tokoe into branch '4.6'.

Update the password of all Transport instances when
changing the password in the configuration dialog.

Fixes first part of bug 258350

CCBUG: 258350

svn path=/trunk/KDE/kdepimlibs/; revision=1216136
(cherry picked from commit ca66cebdaca1ab8c360ed42604f63fae1556cea8)

M  +21   -17   mailtransport/transport.cpp     
A  +42   -0    mailtransport/transport_p.h         [License: LGPL (v2+)]
M  +2    -0    mailtransport/transportmanager.cpp     

http://commits.kde.org/kdepimlibs/a7e1a4007a2ef07e05d61ea1e47cbb2e04d7f3bf