Bug 258322 - Crash when clickin wikipedia's embedded player button
Summary: Crash when clickin wikipedia's embedded player button
Status: RESOLVED DUPLICATE of bug 258452
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-30 00:14 UTC by Cyrille Dunant
Modified: 2010-12-12 14:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cyrille Dunant 2010-11-30 00:14:47 UTC
Application: konqueror (4.5.80 (4.6 Beta1))
KDE Platform Version: 4.5.80 (4.6 Beta1)
Qt Version: 4.7.1
Operating System: Linux 2.6.31.14-0.4-desktop x86_64
Distribution: "openSUSE 11.2 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I clicked on the video found in the caesium article of wikipedia, and this crashed the browser.

The crash can be reproduced every time.

-- Backtrace:
Application: Konqueror (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f3e85cca750 (LWP 25173))]

Thread 7 (Thread 0x7f3e67a38910 (LWP 25204)):
#0  0x00007f3e83318472 in select () from /lib64/libc.so.6
#1  0x00007f3e848f9ad3 in QProcessManager::run (this=0x7f3e84c4ef80) at io/qprocess_unix.cpp:245
#2  0x00007f3e8482a06e in QThreadPrivate::start (arg=0x7f3e84c4ef80) at thread/qthread_unix.cpp:285
#3  0x00007f3e77dcca33 in ?? () from /usr/X11R6/lib64/libGL.so.1
#4  0x00007f3e8459965d in start_thread () from /lib64/libpthread.so.0
#5  0x00007f3e8331eecd in clone () from /lib64/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f3e667f4910 (LWP 25292)):
#0  0x00007f3e8459e2cd in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f3e8482ab92 in wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f3e848204f2 in QThreadPoolThread::run (this=0x39c88b0) at concurrent/qthreadpool.cpp:140
#4  0x00007f3e8482a06e in QThreadPrivate::start (arg=0x39c88b0) at thread/qthread_unix.cpp:285
#5  0x00007f3e77dcca33 in ?? () from /usr/X11R6/lib64/libGL.so.1
#6  0x00007f3e8459965d in start_thread () from /lib64/libpthread.so.0
#7  0x00007f3e8331eecd in clone () from /lib64/libc.so.6
#8  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f3e6459f910 (LWP 25299)):
#0  0x00007f3e8459e2cd in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f3e8482ab92 in wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f3e848204f2 in QThreadPoolThread::run (this=0x11e0aa0) at concurrent/qthreadpool.cpp:140
#4  0x00007f3e8482a06e in QThreadPrivate::start (arg=0x11e0aa0) at thread/qthread_unix.cpp:285
#5  0x00007f3e77dcca33 in ?? () from /usr/X11R6/lib64/libGL.so.1
#6  0x00007f3e8459965d in start_thread () from /lib64/libpthread.so.0
#7  0x00007f3e8331eecd in clone () from /lib64/libc.so.6
#8  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f3e61b3c910 (LWP 25304)):
#0  0x00007f3e8459e2cd in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f3e8482ab92 in wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f3e848204f2 in QThreadPoolThread::run (this=0x118f0e0) at concurrent/qthreadpool.cpp:140
#4  0x00007f3e8482a06e in QThreadPrivate::start (arg=0x118f0e0) at thread/qthread_unix.cpp:285
#5  0x00007f3e77dcca33 in ?? () from /usr/X11R6/lib64/libGL.so.1
#6  0x00007f3e8459965d in start_thread () from /lib64/libpthread.so.0
#7  0x00007f3e8331eecd in clone () from /lib64/libc.so.6
#8  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f3e6333f910 (LWP 25313)):
#0  0x00007f3e8459e2cd in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f3e8482ab92 in wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f3e848204f2 in QThreadPoolThread::run (this=0x300d8e0) at concurrent/qthreadpool.cpp:140
#4  0x00007f3e8482a06e in QThreadPrivate::start (arg=0x300d8e0) at thread/qthread_unix.cpp:285
#5  0x00007f3e77dcca33 in ?? () from /usr/X11R6/lib64/libGL.so.1
#6  0x00007f3e8459965d in start_thread () from /lib64/libpthread.so.0
#7  0x00007f3e8331eecd in clone () from /lib64/libc.so.6
#8  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f3e62b3e910 (LWP 25333)):
#0  0x00007f3e8459e2cd in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f3e8482ab92 in wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f3e848204f2 in QThreadPoolThread::run (this=0x39cbc40) at concurrent/qthreadpool.cpp:140
#4  0x00007f3e8482a06e in QThreadPrivate::start (arg=0x39cbc40) at thread/qthread_unix.cpp:285
#5  0x00007f3e77dcca33 in ?? () from /usr/X11R6/lib64/libGL.so.1
#6  0x00007f3e8459965d in start_thread () from /lib64/libpthread.so.0
#7  0x00007f3e8331eecd in clone () from /lib64/libc.so.6
#8  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f3e85cca750 (LWP 25173)):
[KCrash Handler]
#6  deref (this=<value optimized out>) at ../../src/corelib/arch/qatomic_x86_64.h:133
#7  QString::operator= (this=<value optimized out>) at tools/qstring.cpp:1358
#8  0x00007f3e67bdb9d3 in ?? () from /usr/lib64/kde4/kjavaappletviewer.so
#9  0x00007f3e6d063129 in create<KParts::ReadOnlyPart> (args=<value optimized out>, keyword=<value optimized out>, parent=<value optimized out>, parentWidget=<value optimized out>, 
    this=<value optimized out>) at /usr/src/debug/kdelibs-4.5.80/kdecore/util/kpluginfactory.h:527
#10 KHTMLPart::createPart (args=<value optimized out>, keyword=<value optimized out>, parent=<value optimized out>, parentWidget=<value optimized out>, this=<value optimized out>)
    at /usr/src/debug/kdelibs-4.5.80/khtml/khtml_part.cpp:4625
#11 0x00007f3e6d056920 in KHTMLPart::processObjectRequest (this=0xef08f0, child=0x191aa30, _url=<value optimized out>, mimetype=...) at /usr/src/debug/kdelibs-4.5.80/khtml/khtml_part.cpp:4388
#12 0x00007f3e6d057a76 in KHTMLPart::requestObject (this=0xef08f0, child=0x191aa30, url=..., _args=<value optimized out>, browserArgs=<value optimized out>)
    at /usr/src/debug/kdelibs-4.5.80/khtml/khtml_part.cpp:4277
#13 0x00007f3e6d058d86 in KHTMLPart::loadObjectElement (this=0xef08f0, frame=<value optimized out>, url=<value optimized out>, serviceType=<value optimized out>, params=<value optimized out>)
    at /usr/src/debug/kdelibs-4.5.80/khtml/khtml_part.cpp:4198
#14 0x00007f3e6d152c44 in DOM::HTMLObjectBaseElementImpl::computeContent (this=<value optimized out>) at /usr/src/debug/kdelibs-4.5.80/khtml/html/html_objectimpl.cpp:538
#15 0x00007f3e6d153ca2 in DOM::HTMLAppletElementImpl::computeContent (this=0x191e5c0) at /usr/src/debug/kdelibs-4.5.80/khtml/html/html_objectimpl.cpp:695
#16 0x00007f3e6d10fae3 in khtml::KHTMLParser::popOneBlock (this=0x4b660b0, delBlock=true) at /usr/src/debug/kdelibs-4.5.80/khtml/html/htmlparser.cpp:1865
#17 0x00007f3e6d110e01 in khtml::KHTMLParser::popBlock (this=0x4b660b0, _id=5) at /usr/src/debug/kdelibs-4.5.80/khtml/html/htmlparser.cpp:1806
#18 0x00007f3e6d1139fc in khtml::KHTMLParser::parseToken (this=0x4b660b0, t=0xff5388) at /usr/src/debug/kdelibs-4.5.80/khtml/html/htmlparser.cpp:253
#19 0x00007f3e6d114331 in khtml::HTMLTokenizer::processToken (this=0xff5360) at /usr/src/debug/kdelibs-4.5.80/khtml/html/htmltokenizer.cpp:2040
#20 0x00007f3e6d11b4a7 in khtml::HTMLTokenizer::parseTag (this=0xff5360, src=...) at /usr/src/debug/kdelibs-4.5.80/khtml/html/htmltokenizer.cpp:1501
#21 0x00007f3e6d11cc1f in khtml::HTMLTokenizer::write (this=0xff5360, str=<value optimized out>, appendData=<value optimized out>) at /usr/src/debug/kdelibs-4.5.80/khtml/html/htmltokenizer.cpp:1798
#22 0x00007f3e6d0c1066 in DOM::DocumentImpl::write (this=0x4b7b190, text=...) at /usr/src/debug/kdelibs-4.5.80/khtml/xml/dom_docimpl.cpp:1688
#23 0x00007f3e6d288c43 in KJS::HTMLDocFunction::callAsFunction (this=<value optimized out>, exec=0x7fffbd9ea850, thisObj=<value optimized out>, args=...)
    at /usr/src/debug/kdelibs-4.5.80/khtml/ecma/kjs_html.cpp:135
#24 0x00007f3e6c9afef7 in call (args=<value optimized out>, thisObj=<value optimized out>, exec=<value optimized out>, this=<value optimized out>) at /usr/src/debug/kdelibs-4.5.80/kjs/object.h:626
#25 KJS::Machine::runBlock (args=<value optimized out>, thisObj=<value optimized out>, exec=<value optimized out>, this=<value optimized out>) at codes.def:1204
#26 0x00007f3e6c98ed04 in KJS::FunctionImp::callAsFunction (this=0x7f3e6711a500, exec=0x7fffbd9eb0d0, thisObj=<value optimized out>, args=<value optimized out>)
    at /usr/src/debug/kdelibs-4.5.80/kjs/function.cpp:172
#27 0x00007f3e6c9afef7 in call (args=<value optimized out>, thisObj=<value optimized out>, exec=<value optimized out>, this=<value optimized out>) at /usr/src/debug/kdelibs-4.5.80/kjs/object.h:626
#28 KJS::Machine::runBlock (args=<value optimized out>, thisObj=<value optimized out>, exec=<value optimized out>, this=<value optimized out>) at codes.def:1204
#29 0x00007f3e6c98ed04 in KJS::FunctionImp::callAsFunction (this=0x7f3e67119980, exec=0x7fffbd9eb950, thisObj=<value optimized out>, args=<value optimized out>)
    at /usr/src/debug/kdelibs-4.5.80/kjs/function.cpp:172
#30 0x00007f3e6c9afef7 in call (args=<value optimized out>, thisObj=<value optimized out>, exec=<value optimized out>, this=<value optimized out>) at /usr/src/debug/kdelibs-4.5.80/kjs/object.h:626
#31 KJS::Machine::runBlock (args=<value optimized out>, thisObj=<value optimized out>, exec=<value optimized out>, this=<value optimized out>) at codes.def:1204
#32 0x00007f3e6c98ed04 in KJS::FunctionImp::callAsFunction (this=0x7f3e645c6040, exec=0x3cf1300, thisObj=<value optimized out>, args=<value optimized out>)
    at /usr/src/debug/kdelibs-4.5.80/kjs/function.cpp:172
#33 0x00007f3e6d2dc57a in call (args=<value optimized out>, thisObj=<value optimized out>, exec=<value optimized out>, this=<value optimized out>) at /usr/src/debug/kdelibs-4.5.80/kjs/object.h:626
#34 KJS::JSEventListener::handleEvent (args=<value optimized out>, thisObj=<value optimized out>, exec=<value optimized out>, this=<value optimized out>)
    at /usr/src/debug/kdelibs-4.5.80/khtml/ecma/kjs_events.cpp:108
#35 0x00007f3e6d0fbd1d in DOM::EventTargetImpl::handleLocalEvents (this=<value optimized out>, evt=<value optimized out>, useCapture=<value optimized out>)
    at /usr/src/debug/kdelibs-4.5.80/khtml/xml/dom2_eventsimpl.cpp:75
#36 0x00007f3e6d0d2842 in DOM::NodeImpl::dispatchGenericEvent (this=0x4491910, evt=0x1ab2ea0) at /usr/src/debug/kdelibs-4.5.80/khtml/xml/dom_nodeimpl.cpp:469
#37 0x00007f3e6d0d293e in DOM::NodeImpl::dispatchEvent (this=0x4491910, evt=0x1ab2ea0, exceptioncode=@0x7fffbd9ebddc, tempEvent=true) at /usr/src/debug/kdelibs-4.5.80/khtml/xml/dom_nodeimpl.cpp:401
#38 0x00007f3e6d023b49 in KHTMLView::dispatchMouseEvent (this=0x3ad6ef0, eventId=<value optimized out>, targetNode=0x4491910, targetNodeNonShared=<value optimized out>, 
    cancelable=<value optimized out>, detail=<value optimized out>, _mouse=<value optimized out>, setUnder=true, mouseEventType=1, orient=0) at /usr/src/debug/kdelibs-4.5.80/khtml/khtmlview.cpp:3609
#39 0x00007f3e6d031af5 in KHTMLView::mouseReleaseEvent (this=0x3ad6ef0, _mouse=0x7fffbd9ec9d0) at /usr/src/debug/kdelibs-4.5.80/khtml/khtmlview.cpp:1576
#40 0x00007f3e83ad7172 in QWidget::event (this=0x3ad6ef0, event=0x7fffbd9ec9d0) at kernel/qwidget.cpp:8200
#41 0x00007f3e83e9d2b6 in QFrame::event (this=0x3ad6ef0, e=0x7fffbd9ec9d0) at widgets/qframe.cpp:557
#42 0x00007f3e6d02f695 in KHTMLView::widgetEvent (this=0x3ad6ef0, e=0x7fffbd9e8c50) at /usr/src/debug/kdelibs-4.5.80/khtml/khtmlview.cpp:2208
#43 0x00007f3e6d02f9af in KHTMLView::eventFilter (this=0x3ad6ef0, o=0xf84a30, e=0x7fffbd9ec9d0) at /usr/src/debug/kdelibs-4.5.80/khtml/khtmlview.cpp:2053
#44 0x00007f3e8491ca07 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0xf84a30, event=0x7fffbd9ec9d0) at kernel/qcoreapplication.cpp:847
#45 0x00007f3e83a811dc in QApplicationPrivate::notify_helper (this=0x7043b0, receiver=0xf84a30, e=0x7fffbd9ec9d0) at kernel/qapplication.cpp:4441
#46 0x00007f3e83a865be in QApplication::notify (this=0x7fffbd9ed7d0, receiver=0xf84a30, e=0x7fffbd9ec9d0) at kernel/qapplication.cpp:4006
#47 0x00007f3e856545a6 in KApplication::notify (this=0x7fffbd9ed7d0, receiver=0xf84a30, event=0x7fffbd9ec9d0) at /usr/src/debug/kdelibs-4.5.80/kdeui/kernel/kapplication.cpp:311
#48 0x00007f3e8491d1dc in QCoreApplication::notifyInternal (this=0x7fffbd9ed7d0, receiver=0xf84a30, event=0x7fffbd9ec9d0) at kernel/qcoreapplication.cpp:732
#49 0x00007f3e83a85746 in sendEvent (event=<value optimized out>, receiver=<value optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:215
#50 QApplicationPrivate::sendMouseEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qapplication.cpp:3105
#51 0x00007f3e83b094b5 in QETWidget::translateMouseEvent (this=0x764f70, event=<value optimized out>) at kernel/qapplication_x11.cpp:4438
#52 0x00007f3e83b0814a in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fffbd9ed2f0) at kernel/qapplication_x11.cpp:3564
#53 0x00007f3e83b32bc2 in x11EventSourceDispatch (s=0x708140, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#54 0x00007f3e8018c880 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#55 0x00007f3e801906e8 in ?? () from /usr/lib64/libglib-2.0.so.0
#56 0x00007f3e8019089c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#57 0x00007f3e84949333 in QEventDispatcherGlib::processEvents (this=0x6173d0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#58 0x00007f3e83b3252e in QGuiEventDispatcherGlib::processEvents (this=0x15fa558, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#59 0x00007f3e8491bf02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#60 0x00007f3e8491c2ec in QEventLoop::exec (this=0x7fffbd9ed620, flags=) at kernel/qeventloop.cpp:201
#61 0x00007f3e849212a9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#62 0x00007f3e7469b214 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdebase-4.5.80/apps/konqueror/src/konqmain.cpp:219
#63 0x0000000000408087 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2010-12-12 14:49:21 UTC
[Comment from a bug triager]
This issue is being tracked at bug 258452. Merging. Thanks

*** This bug has been marked as a duplicate of bug 258452 ***