Bug 25820 - feature wish: graphic image resize with embedded viewer
Summary: feature wish: graphic image resize with embedded viewer
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: khtml image part (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 446 votes (vote)
Target Milestone: ---
Assignee: Simon Hausmann
URL:
Keywords:
: 154414 (view as bug list)
Depends on:
Blocks:
 
Reported: 2001-05-16 22:33 UTC by Matt Vaughan
Modified: 2008-12-04 22:18 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Vaughan 2001-05-16 22:24:08 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           konqueror
Version:           unknown (using KDE 2.2.0 CVS >=20010503)
Severity:          wishlist
Installed from:    compiled sources
Compiler:          gcc version 2.95.2 19991024 (release)
OS:                Linux (i686) release 2.4.4-ac6
OS/Compiler notes: 

when viewing a graphic image (jpg gif) in konqueror using the embedded viewer have the image resize (shrink grow) to the size of the active window.  currently images must be scrolled around to see or resized w/ gimp or something but it would be nice to have the ability for these 'previews' to shrink to the active window.  i particularly like this functionality with windows me/2000 (puke).  :)  using something like pixie or kview by itself just isn't convenient when doing file (image) management.

thanks.  


(Submitted via bugs.kde.org)
(Called from KBugReport dialog)
Comment 1 olistrut 2003-05-06 18:37:38 UTC
With KView this works when used as a stand-alone image viewer (configurable 
in settings), but for the embedded viewer no similar option is available. 
 
(KDE 3.1) 
 
Comment 2 markus 2004-01-14 02:34:20 UTC
This issue is still open for konqueror / KDE 3.1.4.

 Application: HTML Viewer Component Image Part

Operating System: Linux (i686) release 2.4.24-pre1-xfs (DEBIAN WOODY)

Compiler: gcc version 2.95.4 20011002 (Debian prerelease)
Comment 3 markus 2004-07-21 02:56:34 UTC
This issue is still open for konqueror / KDE 3.2.3
Comment 4 Jason Ahrens 2004-09-03 05:12:57 UTC
Still on wishlist for konqueror 3.3 (kde 3.3.0)
Comment 5 markus 2005-01-01 23:22:43 UTC
I don't know if 236 votes is quite much or not, but this issue is still open in KDE 3.3.1. I this so difficult to fix? BTW: Happy New Year! :-)
Comment 6 markus 2005-01-01 23:48:50 UTC
The code for this feature should be available in the "digiKam" application which allows automatic resize of a picture. (DigiKam Image Editor)
Comment 7 Georg Prager 2005-01-23 11:54:54 UTC
Try gwenview kparts. Unfortunately gwenview is not available in the official kde.
Comment 8 Jason Ahrens 2005-01-23 17:37:21 UTC
Unfortunately the latest 'stable' gwenview is for KDE 3.0. Any reports on how it interacts with 3.3?
Comment 9 jamethknorth 2005-02-20 22:47:02 UTC
The recommendation really shouldn't be to use a different viewer that has about thirty other options I really don't want and an interface I don't like, the wishlist item should just be solved.

Just add a 'Fit-to-Screen' button to the toolbar and have it remember state between uses so that most users will either just leave it on or off (IE and FireFox both let you swap between modes, but always start in the scaled mode, even if you always just turn it off).
Comment 10 markus 2005-05-04 23:52:46 UTC
***PLEASE***
Dear developers, why don't you implement this. 470 votes is quite an argument, isn't it? And digikam can do it, why should it be so difficult... Everytime I view photos, I dearly miss this feature. IE can do it and users really appreciate it there, why don't we have this feature long ahead of that drowsy sleepy Redmond giant....? :-)) 
Comment 11 markus 2005-05-05 00:20:03 UTC
I just discovered a new feature in KDE 3.4.0: There is a new view ("PhotoBook"). It is able to resize photos to the screen. It should be able to take exactly this code and reuse it in order to do what's this ticket is about. 
Comment 12 markus 2006-02-27 03:51:14 UTC
... still does not work in Konqueror 3.5.1 (520 votes)
Comment 13 Thiago Macieira 2006-02-28 20:24:29 UTC
Are you volunteering to write the feature?
Comment 14 Teemu Rytilahti 2006-03-01 19:40:59 UTC
I am using Gwenview as it has a KPart and it does resizing if wanted so. Not a solution for the bug, but if someone wants this functionality now one can try it out.
Comment 15 Tommi Tervo 2007-12-21 08:35:56 UTC
*** Bug 154414 has been marked as a duplicate of this bug. ***
Comment 16 Dotan Cohen 2007-12-22 22:26:24 UTC
This bug is confirmed in Ubuntu packages. There is no way to display an image as fit-to-window in Kubuntu 7.04 with KDE 3.5.8.
Comment 17 Rafał Malinowski 2008-07-21 13:23:08 UTC
Still exists in KDE 4.1 - png files are resisable, jpg ones are not.
Comment 18 Dotan Cohen 2008-12-04 22:18:27 UTC
In KDE 4.1 as installed by Kubuntu 8.10 I see that the issue is resolved for JPG images as well. Closing. Thanks.