Bug 258171 - Annoyed by 'Nepomuk Indexing Disabled - Akonadi Agent' message
Summary: Annoyed by 'Nepomuk Indexing Disabled - Akonadi Agent' message
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Unclassified
Component: Nepomuk Feeder Agents (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR wishlist with 388 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-28 13:36 UTC by Johannes Obermayr
Modified: 2012-04-17 09:18 UTC (History)
30 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
ksnapshot (37.79 KB, image/png)
2010-11-28 13:36 UTC, Johannes Obermayr
Details
nepomuk notification (46.40 KB, image/png)
2011-07-09 10:23 UTC, Johannes Obermayr
Details
Quick and dirty patch for annoying nepomuk-disabled window (965 bytes, patch)
2011-07-09 15:58 UTC, Andrea Cascio
Details
Quick and dirty patch for annoying nepomuk-disabled notification (919 bytes, patch)
2011-07-09 16:00 UTC, Andrea Cascio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Obermayr 2010-11-28 13:36:37 UTC
Created attachment 53824 [details]
ksnapshot

Version:           unspecified (using Devel) 
OS:                Linux

Each time I start KDE I am annoyed by 'Nepomuk Indexing Disabled - Akonadi Agent' message (see ksnapshot).

I know it is disabled - so there is no need to annoy me each time ...

Sometimes it appears even two times in one session :-(

Reproducible: Always
Comment 1 Sebastian Trueg 2011-01-05 16:38:24 UTC
This is an Akonadi dialog.
Comment 2 Andrea Cascio 2011-06-25 19:36:53 UTC
Second this, absolutely annoying as there is no way to simply answer "I want it disabled, live with it".
Comment 3 Alexander Potashev 2011-06-26 18:14:27 UTC
This is how Nepomuk feeders can be disables (including error messages from them):
1. Go to /usr/share/akonadi/agents/
2. Remove "Autostart" from the "X-Akonadi-Capabilities" parameter in all files named nepomuk*.desktop (nepomukcalendarfeeder.desktop, nepomukcontactfeeder.desktop, ...)
3. Run "akonadiconsole" and remove all resources related to Nepomuk
4. You might also need to run "kbuildsycoca4" after editing .desktop files, but I'm not sure if it's necessary
Comment 4 Alexander 2011-06-26 19:48:25 UTC
(In reply to comment #3)
Thank you very much :)
Comment 5 Igor Strelnikoff 2011-07-09 09:04:00 UTC
I confirm this bug, this message appears I have too.

KDE 4.6.5 with opensuse 11.3
Comment 6 Christophe Giboudeaux 2011-07-09 10:03:34 UTC
Fixed long ago. This warning is now displayed using a systray notification.
Comment 7 Alexander Potashev 2011-07-09 10:06:23 UTC
You can't disable that notification, that's the problem now.
Comment 8 Alexander 2011-07-09 10:18:47 UTC
Why akonadi run these resources when nepomuk is turned off? It shouldn't do that at all, so I think the more correct way to fix this problem is to check if nepomuk is enabled and launched before run akonadi nepomuk-* resources.
Comment 9 Johannes Obermayr 2011-07-09 10:23:17 UTC
Created attachment 61719 [details]
nepomuk notification

Here you can see that it tells me that stupid notification even 3 times (on each start of KDE).
No - I am not stupid - I would understand it also if it was displayed once ...
Comment 10 Christophe Giboudeaux 2011-07-09 10:28:01 UTC
Don't get me wrong, the warning means you turned off Nepomuk. Only you can fix that.

Disabling the notification is a wontfix
Comment 11 Andrea Cascio 2011-07-09 11:10:23 UTC
wontfix? The notification should not exist in first place!
AFAIK Nepomuk can ONLY be disabled by user choice. What's the use of a notification telling the user that he has done what he already knows he has done?

Intentional nagging apart, ofc.
Comment 12 Alexander 2011-07-09 11:44:05 UTC
(In reply to comment #11)
Absolutely agree. But this notification annoying me every launch instead...

I hate nepomuk, it is absolutely unusable thing for me, I'll never enable it! So, why akonadi torment me by its notification? I already good know that nepomuk was disabled, akonadi is unable to work properly without it?
Othervise it looks like you force me to enable nepomuk and if I'll disagree I should suffer from constants notifications.

Just disable the functional which depend from nepomuk before akonadi start, that's all.
Comment 13 Johannes Obermayr 2011-07-09 11:58:40 UTC
Reopen since I want an explanation why KDE will become like Microsoft and Apple where one word has priority: patronization
(If you do not enable sth. you do not want we will annoy you [or we *simple* do not let you disable it] ...)
Comment 14 Christophe Giboudeaux 2011-07-09 12:47:37 UTC
What's the next step ? you will roll on the floor crying ?

Please refrain from adopting a childish attitude and read http://userbase.kde.org/KAddressBook_4.4#Initial_Requirements. (the statement is also valid for kmail)
Comment 15 Alexander 2011-07-09 14:10:08 UTC
Really? Where does it say that akonadi should annoy users? There is users problem if something won't work without required components, otherwise why needed the possibility to disable nepomuk if it's "so required"?. I use kmail and kaddressbook when nepomuk is disabled and no one died because of this.

Anyway, KDE could notify users once, when they disable nepomuk, that some apps won't work without it, also it could notify users that something not working because of missed dependency, BUT ONLY in case when user tries to use this "something" and leave users in peace when they don't.

But now I see that the boorish software behaves in a boorish way. I don't care about it any more.
Comment 16 Andrea Cascio 2011-07-09 15:58:08 UTC
Created attachment 61725 [details]
Quick and dirty patch for annoying nepomuk-disabled window

MY next step is fixing the problem myself (it takes less than quarreling with hostile wontfixers).

For openSUSE 11.3 (same for other releases, I think) the problem is as simple as disabling the patch 4_4_BRANCH.diff in the source-package kdepim4-runtime-4.4.11.1-xxx.src.rpm. Open the .spec file and comment the lines:
Patch: 4_4_BRANCH.diff
and
%patch -p2
rebuild the package (rpmbuild -ba kdepim4-runtime.spec), install it and live happy... until the (very near) day when you will not be able to send a single e-mail without a working suckonadi/strigi/soprano/neposuck/mysql/whateverTHEYlike environment.

I have added a quick and dirty (and totally untested :( ) patch for other kdepim-runtime-4.4 based distros:
if you are nagged by the message window:
nepomukagent_window.diff
if you are nagged by the notification:
nepomukagent_notification.diff

Ofc I know this is by no means the right solution. Which would be:
- a checkbox "don't show anymore" on the notification
or better yet
- move the message to the "System Settings", thus showing it at the right time: WHEN THE DECISION TO DISABLE NEPOMUK IS TAKEN. Then, live with the user's choice.

I would do it, but I have better use for my time than working on patch that would never be accepted anyway.
Comment 17 Andrea Cascio 2011-07-09 16:00:49 UTC
Created attachment 61726 [details]
Quick and dirty patch for annoying nepomuk-disabled notification

The second patch
Comment 18 Johannes Obermayr 2011-07-10 18:41:43 UTC
A good reason not to use it:
http://kate-editor.org/2011/07/10/kde-4-6-5-starcraft-2/
Comment 19 Panagiotis Papadopoulos 2011-07-11 17:00:29 UTC
“- move the message to the "System Settings", thus showing it at the right time:
WHEN THE DECISION TO DISABLE NEPOMUK IS TAKEN. Then, live with the user's
choice.”

I think that is a good idea :-)

btw: Is it just my system or is the message in the notification not even fully readable? On my system it looks like it is truncated after some lines. And I cannot expand the notification, so that I could read the whole message in it. (Which would be another reason against the notification.)

I’ll try to make a screenshot once the notification pops up again. :-)
Comment 20 Panagiotis Papadopoulos 2011-07-11 17:02:06 UTC
https://bugs.kde.org/attachment.cgi?id=61719

On Johannes’ screenshot it looks to be truncated too, so I assume it looks like that everywhere?
Comment 21 tony 2011-07-16 16:47:03 UTC
Wontfix?
Oh my, go to make an empty folder and say nepomuk to indicize just that.
Comment 22 Igor Strelnikoff 2011-07-23 13:16:36 UTC
Why "Wontfix"?? 0_o
Comment 23 Victor 2011-07-23 15:45:37 UTC
Please fix this annoying and broken notification! :)
Comment 24 Johannes Obermayr 2011-07-23 16:38:34 UTC
Intermediate result:
8 persons want it fixed (pano and tony have not voted)
1 person does not want it fixed

Reasons for "WONTFIX":
Christophe Giboudeaux have not explained exactly why an enabled nepomuk is needed (only some vague / not really valid reasons).
Reality shows that needs of most users (including some power users) are also fulfilled without nepomuk in use.
But there is a reason for disabling nepomuk: http://kate-editor.org/2011/07/10/kde-4-6-5-starcraft-2/

Suggestion:
You should make people understanding why you "WONTFIX" the notification issue at all and at least fix the three notifications in a row since one is enough and avoids annoyance (if the notification is really needed each time).

Btw.:
These are valid reasons for reopening it (objective reflection).
Comment 25 Christophe Giboudeaux 2011-07-23 16:49:17 UTC
sigh...

Please refrain from reopening this report
Comment 26 Christophe Giboudeaux 2011-07-23 16:55:30 UTC
(In reply to comment #21)
> Oh my, go to make an empty folder and say nepomuk to indicize just that.

I'll just answer to this comment since it is a misinformed user:
The file indexer has no relation with the Akonadi usage of Nepomuk.
(ie, the Nepomuk feeders don't care about what you set in the Nepomuk KCM)
Comment 27 Dariusz Pakulski 2011-07-27 12:55:42 UTC
I'am voting for reopen and fix this _BUG_ !
It is first time in my Linux experience when i can't imagine "wontfix" developer reaction.
Maybe option to disable nepomuk should have label "Select nepomuk or switch to another window manager because we will torture you with notifications" ?
Please fix this behavior.
Comment 28 Christophe Giboudeaux 2011-07-27 19:55:05 UTC
This is not a bug, enable nepomuk and you won't see the notification.
Comment 29 Igor Strelnikoff 2011-07-27 20:21:20 UTC
>>This is not a bug, enable nepomuk and you won't see the notification.

And he eats all the RAM and CPU
Comment 30 Vishesh Handa 2011-07-27 21:32:38 UTC
As a Nepomuk developer, I really want everyone to use Nepomuk, but I do not believe it should be forced down on anyone.

As I understand, KDE PIM requires Nepomuk, but it can function in a reduced state if Nepomuk is not enabled. Is there any reason that can't be achieved? I'll take a look at the underlying code.

This is something we can discuss in detail at the Desktop Summit, and find a solution that suits everyone. At the end of the day, the users should be happy.

I'm letting the status of the bug be as it is - WONTFIX, as I don't think I should be changing it without discussing it with the others.

PS: I hate the message as well, it annoys me as I restart Nepomuk 10 times a day.
Comment 31 Dariusz Pakulski 2011-07-28 09:00:52 UTC
Thank You very much Vishesh Handa for the first reasonable comment in contrast to comments given by Christophe Giboudeaux.

It gives us hope for future. As a gentoo+kde user I'am using nepomuk+akonadi on my desktop system but on my netbook i'am trying to switch everything unnecessary services off.
I'am curious why this particular notification can't be turned off in standard KDE system settings -> program notifications panel like many other notifications ?

Regards for all KDE developers :-)
Comment 32 Igor Strelnikoff 2011-07-29 13:13:26 UTC
Well, please, mark this bug as a wish
Comment 33 Johannes Obermayr 2011-08-19 11:40:26 UTC
(In reply to comment #30)
> 
> This is something we can discuss in detail at the Desktop Summit, and find a
> solution that suits everyone. At the end of the day, the users should be happy.
> 
Any status update?
Comment 34 Johannes Obermayr 2011-08-30 21:24:31 UTC
ping^
Comment 35 Christophe Giboudeaux 2011-09-06 09:06:35 UTC
*** Bug 277381 has been marked as a duplicate of this bug. ***
Comment 36 Christophe Giboudeaux 2011-09-06 09:07:20 UTC
seems someone forgot to read comment#25.
Comment 37 Christophe Giboudeaux 2011-09-06 09:24:17 UTC
reassign. We don't need to annoy Tobias with non-issues.

@commenters: if you wonder why "invalid" was chosen, blame the unacceptable attitude from the bug reporter which is even more unacceptable when it is a KDE developer. (comment #13,18,24...)

Disabling Nepomuk (from an Akonadi pov) means:
- No tooltip in kmail,
- No contact search in kmail's composer,
- No mail search either.
(and obviously no tagging).

There is also some kind of confusion between the way Nepomuk as a file indexer works and how the Akonadi feeders work (comment #21): Whatever you set up in the Nepomuk configuration module has no influence on the Akonadi feeders work.

In the Nepomuk configuration module ("system settings"/"Desktop Search"/"Desktop Query" tab/"Customize Index folders"), you can disable all the folders to index and even add a wildcard in the exclude filters without breaking the Akonadi feeders.
Comment 38 Andrea Cascio 2011-09-06 09:48:21 UTC
Having resorted to patch it myself, I don't care much about this bug anymore.

But, frankly, choosing the state of a bug because of the "attitude of the reporter", is childish at best. I'd say THIS attitude is unacceptable, sir.

Even worst, you still don't seem to understand what this bug is about. It's not about the "right" way to disempower Nepomuk. It's about not being nagged THOUSANDS TIMES by a useless message saying we cannot use some features... that we will never miss anyway, but that's not the point! The point is about "how many times to warn". 

ONCE is enough, I would SIMPLY like to click on "I understand", and the message goes away. Invalid, uh?

37 comments and 160 votes for such an obvious thing... speaking about bad attitude...
Comment 39 Loris Boillet 2011-10-17 19:21:28 UTC
This bug is definitely not invalid.

And there are some more dups: 283865, 281788, 271558.

But I don't know how to mark them as such (probably I just don't have the perms).
Comment 40 Jesse 2011-10-17 22:23:39 UTC
Why is this bug report marked as invalid? Every time I login to KDE I receive three reports informing me the Nepomuk indexing is disabled. I know it's disabled, I disabled it.

The response, "turn on indexing and the message will go away" is not acceptable. I turned off indexing for a good reason, there should be no reason to remind the user they did this. At the very least there should be a "Don't remind me again" button.
Comment 41 Alexander 2011-10-18 07:12:23 UTC
(In reply to comment #37)
I satisfied with how kmail works without nepomuk.

To tell truth — I really tried to use nepomuk, but what can I do if it's an unusable thing? I set only one folder for indexing, which contains ruby/ruby on rails projects, but nepomuk fails to index it, it prefer to crash instead. So, my solution is in use mc. When you need to find something, it works perfectly, eat less that 10Mb of memory, doesn't need a half an hour for indexing before (I also can't understand what nepomuk indexing every time I power on my PC, when it was configured to not index anything?).

I don't understand a reason to have such thing as nepomuk, when I need to search something once a month... Why should I need a such kind of primitive google on my desktop? It only makes my PC slow and don't give any profit and I think that at least 50% (if not all 95%) of KDE users will agree with that.

If kmail requires such thing — let it be smoother and faster, invisible for users. You should separate nepomuk system and make it configurable in a bit other way:
1. Remove option "disable nepomuk" at all. If it's required by system it should be always enabled.
2. Load it in as minimal configuration as possible to perform only system requirements (if additional folders for indexing was not specified).
3. Remove all preselected by default folders for indexing. So when user run KDE first time it will have positive impression. Then it even will not has a thoughts to disable something (when I had to run KDE first time I was a bit shocked and my first thought was like: "***** ***** *****, how can I stop it!?").
4. In system settings you should leave only indexing configuration, so users which needs such indexing will be able to enable and configure it.

If there is not possible to do that, you definitely should add a tick "don't ask again", instead of sending tons of notifications later.
Comment 42 Leo Milano 2011-10-18 17:07:07 UTC
I am also affected by this bug. People should definitely refrain from opinionated posts: this is a bug tracker, not a user forum.

On the bug itself, the description is simple: a pop-up reappears over and over and it really gives the user the feeling that something is broken in her/his system, when all that the user did was to disable an optional feature. This needs to be fixed. The standard approach is to offer a check-box with the option  "do not show this warning in the future".

Finally, thanks a lot to the awesome community that makes KDE possible (this means developers, testers, web-admins, and the list goes). Thank you all.

Cheers,
Leo
Comment 43 Antonio 2011-10-20 08:01:05 UTC
I concur with comment #42, a checkbox to disable the warning in the future would be nice. Furthermore, thank goodness for KDE!
Comment 44 Jjohn 2011-10-26 14:52:57 UTC
As a NEW user with a fresh install and can't understand why it keeps happening 3 times in a row. This popup is HIGHLY annoying in a Micr$oft type of way. A simple friggen checkbox to ignore it would help. Quite frankly, just because of Christopher Giboudeaux attitude, I almost feel like moving on to something different.
Comment 45 Hans 2011-10-30 10:51:16 UTC
As I understand nepomuk it is a substitute for "grep -r" used by Kmail and KAddressbook. But if one try to uninstall libnepomuk4 you are informed that packages like konsole, ktuberling and kdm are going to be uninstalled. It looks like the problem is that these 3 packages depends (nested) on libnepomuk4 without using it. A lot of applications (the above) works fine when nepomuk is disabled and then the solution could be to move nepomuk to a package where only KMail and KAddressBook depends on it. Is that possible?


Personally I removed 'Autostart' from:
egrep "^X-Akonadi-Capabilities.*Autostart" /usr/share/akonadi/agents/nepomuk*.desktop
Comment 46 Christophe Giboudeaux 2011-10-30 11:21:00 UTC
(In reply to comment #44)
> [...] Quite frankly, just because of
> Christopher Giboudeaux attitude, I almost feel like moving on to something
> different.

Feel free.

(In reply to comment #45)
> [...] could be to move nepomuk to a package where only
>KMail and KAddressBook depends on it. Is that possible?

Hardly. you would also have to split some core packages (kde-apps,kde-runtime, kde-workspace, kactivities) and a lot of applications.
Comment 47 Jjohn 2011-10-31 13:34:52 UTC
Will do, and I will make sure I leave a review where ever I can.Good luck imitating with Microsoft, 



________________________________
From: Christophe Giboudeaux <cgiboudeaux@gmx.com>
To: schmidt.john21@yahoo.com
Sent: Sunday, October 30, 2011 7:21 AM
Subject: [Bug 258171] Annoyed by 'Nepomuk Indexing Disabled - Akonadi Agent' message

https://bugs.kde.org/show_bug.cgi?id=258171





--- Comment #46 from Christophe Giboudeaux <cgiboudeaux gmx com>  2011-10-30 11:21:00 ---
(In reply to comment #44)
> [...] Quite frankly, just because of
> Christopher Giboudeaux attitude, I almost feel like moving on to something
> different.

Feel free.

(In reply to comment #45)
> [...] could be to move nepomuk to a package where only
>KMail and KAddressBook depends on it. Is that possible?

Hardly. you would also have to split some core packages (kde-apps,kde-runtime,
kde-workspace, kactivities) and a lot of applications.
Comment 48 Jjohn 2011-10-31 13:42:13 UTC
BTW this happens 4 times in a row. On a clean install of KDE, I did NOTHING too it to cause this. If this is the reputation you want for this software, then good luck. I was willing to deal with KDEs horrible monitor management, but this now takes it over the line. Hello GNOME.Good bye Christopher. Sorry for everyone else that has to deal with you.



________________________________
From: Christophe Giboudeaux <cgiboudeaux@gmx.com>
To: schmidt.john21@yahoo.com
Sent: Sunday, October 30, 2011 7:21 AM
Subject: [Bug 258171] Annoyed by 'Nepomuk Indexing Disabled - Akonadi Agent' message

https://bugs.kde.org/show_bug.cgi?id=258171





--- Comment #46 from Christophe Giboudeaux <cgiboudeaux gmx com>  2011-10-30 11:21:00 ---
(In reply to comment #44)
> [...] Quite frankly, just because of
> Christopher Giboudeaux attitude, I almost feel like moving on to something
> different.

Feel free.

(In reply to comment #45)
> [...] could be to move nepomuk to a package where only
>KMail and KAddressBook depends on it. Is that possible?

Hardly. you would also have to split some core packages (kde-apps,kde-runtime,
kde-workspace, kactivities) and a lot of applications.
Comment 49 Sebastian Trueg 2011-11-01 14:04:58 UTC
*** Bug 285391 has been marked as a duplicate of this bug. ***
Comment 50 Albert P. 2011-11-04 01:51:10 UTC
I can understand why this isn't necessarily considered a bug, but it is fairly annoying. I personally chose not to use the KDE PIM suite of applications; therefore, I am not impacted at all by the fact that Nepomuk being disabled will reduce the KDE PIM application capabilities.

Disabling Nepomuk is a user request, and being notified of it is sensible, but there really should be an option to ignore future notifications.

1. I don't use KDE PIM applications.
2. Nepomuk is disabled, affecting KDE PIM.
3. I knowingly disable Nepomuk.
4. I am constantly reminded I have reduced capabilities for KDE PIM, of which I do not use.

Additionally, I'm notified that Nepomuk is disabled three times in a row on every system boot. It is rather irritating.
Comment 51 Leonardo La Malfa 2011-11-07 13:24:19 UTC
As far as I understand it, people in this bug report are complaining because they actually have turned Nepomuk off, so they don't want to be bothered with notifications about what they already know. In fact, more than a proper bug, it's reported as a whishlist, and currently marked as invalid.

But I haven't turned anything off myself, I just want things to work properly because I haven't tinkered with their settings. Simply, after startup, I'm greeted by three of these notifications in a row. Is this a new bug I should report, since i didn't disable anything? Many thanks for your time!
Comment 52 Lydia Pintscher 2011-11-07 13:41:06 UTC
Folks, I've just been pointed to this bug report and would like to remind everyone that this isn't exactly how we want to interact in this community. In case you need to refresh that knowldege: http://kde.org/code-of-conduct/

Thanks. Let's get back to making our software rock together.
Comment 53 Elvis Stansvik 2011-11-07 20:37:21 UTC
I agree with Albert P here, and also with Lydia, let's be polite here. That said, I just don't understand. For me it's like this:

1) I have disabled Nepomuk, which is an optional feature.
2) I don't use KDE-PIM.
3) Each time I log in, I have to click 3-4 times to close the notifications.

I don't understand how this can't be considered a bug. In my use case, which I think is a perfectly normal one, why would I need to be shown those notifications 3-4 times on _every_ login?
Comment 54 Jesse Lucas 2011-11-09 01:05:43 UTC
I think I found the answer:

http://www.trinitydesktop.org/
Comment 55 James Roe 2011-11-13 17:33:00 UTC
Besides the bug of Nepomuk having serious problems. I disabled it and it's still showing these popups regardless as well. Can't see how this isn't a bug.
Comment 56 James Roe 2011-11-13 17:35:41 UTC
@Leonardo: I'm having the exact same issue. I think you should report it. I can't fix the problem, even if I delete all nepomuk and akonadi settings, and databases, and everywhere the files are. The error comes back eventually. It's getting really annoying.

On top of that, my desktop no longer stays logged in anymore. I leave it, and when I come back, kwin has crashed somehow and it's back in the login screen, and I've lost everything, happens nearly every time now. I have no idea how to track down the issue either. :(
Comment 57 Alexander 2011-11-14 06:54:48 UTC
(In reply to comment #56)
I've had the similar issue and nepomuk was a reason for that. In some cases it starts to spam in your ~/.xsession-errors, this file will grow up until it will not eat all the free space in your ~ partition. In that case KDE may crash and you will lost some of KDE configuration and perhaps some other more important files from ~/ This is how it was for me and I know at least one more man who suffered from the same problem.
Comment 58 Edo 2011-11-16 06:14:48 UTC
I agree with most of the people here.  I have deliberately disabled the service since I know exactly where my files are and I have no need for an indexing service.  The intent to "punish" the user for opting out of unnessary software is rather self-defeating.
Comment 59 James Roe 2011-11-16 09:35:59 UTC
#57: Thanks. I found the issue, and it was related to some driver bugs with X and/or the kernel. I disabled desktop effects and get no more crashes. Of course, the nepomuk dialogs are still a problem, however I haven't seen any of them anymore since I deleted all akonadi and nepomuk app data and settings, and everything stopped crashing for me.
Comment 60 Sebastian Trueg 2011-11-16 10:07:08 UTC
Just as a side-note: the dialog does NOT come from Nepomuk. It is an Akonadi message and it is up to the Akonadi devels to solve this issue.
The problem is that for Akonadi Nepomuk is not really optional. And the Plasma Calendar uses Akonadi. So maybe what we need is a way to disable that Akonadi integration into Plasma?
Comment 61 Elmar Baumann 2011-11-20 18:22:19 UTC
I'm surprised how the responsible persons are reacting to a bug that leads users at least to switch from the whole K desktop environment to another (and I'm considering that too). In my opinion it's even a bug in the notification system that I can't disable specialized messages. 

In other words, to disable the that annoying message, I have only the choice to do stupid workarounds (e.g. enabling nepomuk and let it index only one empty directory) or using another desktop. It's easy for the developers to say: That's "INVALID" in my opinion, but more than 60 comments and more than 300 votes shouldn't be ignored. It's also  uncooperatively to other KDE developers who have done good work that will be ignored due switching to another desktop because the Akonadi developers are "too lazy" to program at least a short statement like that (I know, it will consume some time to implement that and it's more complex):

if (displayError) { displayError(); }
Comment 62 Christophe Giboudeaux 2011-11-20 18:52:53 UTC
(In reply to comment #61)
> It's easy for the developers to say:
> That's "INVALID" in my opinion, but more than 60 comments and more than 300
> votes shouldn't be ignored. It's also  uncooperatively to other KDE developers
> who have done good work that will be ignored due switching to another desktop
> because the Akonadi developers are "too lazy" to program at least a short
> statement like that (I know, it will consume some time to implement that and
> it's more complex):


To make it clear one more time:
It's marked as invalid because of the uneducated comments and the attitude of a few commenters.

We have another bug report for useful contributions on the same topic.
Comment 63 Elvis Stansvik 2011-11-20 18:57:41 UTC
Which bug is that so that I can vote on that too?
Comment 64 Elmar Baumann 2011-11-20 19:36:57 UTC
@Christophe: A bug report should remain if it's a bug, even if some reporters are not polite. That does speak against the reporters and not against the bug (it shows how angray these people are and should be an indicator for a developer to think about a fix, even if the "form" of the report is bad).

I can't see a link like "this is a duplicate of bug xyz", so where is the other bug report for this bug? If it does not exist, I suggest, to reopen this bug, it's better not to have multiple bug id's for the same bug.
Comment 65 flan_suse 2011-11-22 20:52:53 UTC
(In reply to comment #62)
> To make it clear one more time:
> It's marked as invalid because of the uneducated comments and the attitude of a few commenters.

It sounds like you're personalizing this issue.

> We have another bug report for useful contributions on the same topic.

Link, please?

I have suffered from this bug (yes, *bug*) since KDE 4.6.2 on openSUSE 11.4. According to KDE forum posts and this bug report, it happens on *any* distro. With high hopes, I installed a fresh copy of openSUSE 12.1 (KDE 4.7.2) on a test machine, hoping that this annoying bug was fixed. Unfortunately, it is not. I even disabled "events" in the Digital Clock settings: no difference.

Here is why we, the users, are annoyed:

1.) We *intentionally* (I repeat, *intentionally*) disabled Nepomuk. We don't want it enabled, period.
2.) We do *not* use KDE PIM. Some of us don't even use Kmail, but rather Thunderbird, et al.
3.) After a certain amount of time passes after logging in, we receive multiple redundant notifications telling us what we *already* know.
4.) There is no way to disable these pointless notifications.

It's that simple. Stop nagging the user about something he is already aware of. This is akin to constantly notifying the user that "Apache Server is not running. You will not be able to host a web site without a web server! Just wanted to let you know!"

The notifications are pointless and annoying. We disabled Nepomuk. We already know it's not running. This problem has been around for at least a year, and the best we get is "re-enabled Nepomuk" or "apply this dirty workaround" or "WONTFIX" or "INVALID".

So please, do link us to the "new and improved" bug report that is not marked as "invalid".
Comment 66 Elmar Baumann 2011-11-22 22:09:25 UTC
I activated the desktop search to get rid that message and defined an empty folder for indexing. Then I got 5 and more notifications, more than before, messages like "redland can't be found" etc. Always after starting KDE I'm distracted through (loud) notification sounds and messages. This can lead to ignore important messages in future. It can lead to say Goodbye to KDE to avoid "dirty hacks" like let rpm uninstalling Akonadi ignoring dependencies.

These messages are "unpolite" and are ignoring some points like (ignored by most programs):
* Don't tell only that an error occurred, tell how it can be fixed
* Better: Don't let me make much afford to fix it, e.g. don't tell: Start abc and set there xyz, but present within the error message an option to display a dialog to set xyz
* These error messagees are decoupled from their scope. If I don't use desktop search, that message is a bug. If e.g. KMail does not work correctly, KMail should display that message.

Last but not least: The users using this bug reporting system are some of the most valuable persons whithin the software developing process. They spend much time to improve the software and having some knowledge: Most users don't know what a bug reporting system is, where to find it, how to use it or willed spent time to report bugs or how to do that in a useful way. And: Why should thousands spend much time to work around bugs and not one or a few devolopers to fix that bug. I know, bugfixing costs time, but in my opinion bug fixes should have top level priority and should be done before any other things like adding features.
Comment 67 Alexander 2011-11-22 22:17:53 UTC
It's marked as invalid because of the attitude of a developer, which he showed from the very start. By the same reason there is over 60 "uneducated" comments here.
Comment 68 Panagiotis Papadopoulos 2011-11-22 22:23:48 UTC
I'd like to bring up comment 19:
https://bugs.kde.org/show_bug.cgi?id=258171#c19
https://bugs.kde.org/attachment.cgi?id=61719

Should I file a new report for that?
Because if this bug (id 258171) apparently is a WONTFIX (for whatever IMHO wrong reason), then at least the bug described in comment 19 should be fixed, right?
Comment 69 Leo Milano 2011-11-23 05:57:24 UTC
Elmar Baumann <eb@elmar-baumann.de> wrote:

>https://bugs.kde.org/show_bug.cgi?id=258171
>
>
>
>
>
>--- Comment #66 from Elmar Baumann <eb elmar-baumann de>  2011-11-22 22:09:25 ---
>I activated the desktop search to get rid that message and defined an empty
>folder for indexing. Then I got 5 and more notifications, more than before,
>messages like "redland can't be found" etc. Always after starting KDE I'm
>distracted through (loud) notification sounds and messages. This can lead to
>ignore important messages in future. It can lead to say Goodbye to KDE to avoid
>"dirty hacks" like let rpm uninstalling Akonadi ignoring dependencies.
>
>These messages are "unpolite" and are ignoring some points like (ignored by
>most programs):
>* Don't tell only that an error occurred, tell how it can be fixed
>* Better: Don't let me make much afford to fix it, e.g. don't tell: Start abc
>and set there xyz, but present within the error message an option to display a
>dialog to set xyz
>* These error messagees are decoupled from their scope. If I don't use desktop
>search, that message is a bug. If e.g. KMail does not work correctly, KMail
>should display that message.
>
>Last but not least: The users using this bug reporting system are some of the
>most valuable persons whithin the software developing process. They spend much
>time to improve the software and having some knowledge: Most users don't know
>what a bug reporting system is, where to find it, how to use it or willed spent
>time to report bugs or how to do that in a useful way. And: Why should
>thousands spend much time to work around bugs and not one or a few devolopers
>to fix that bug. I know, bugfixing costs time, but in my opinion bug fixes
>should have top level priority and should be done before any other things like
>adding features.
>
>-- 
>Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
>------- You are receiving this mail because: -------
>You are a voter for the bug.
>You are on the CC list for the bug.
Comment 70 Tristan Miller 2011-11-23 13:05:45 UTC
On Sunday 20 November 2011, Christophe Giboudeaux wrote:
> It's marked as invalid because of the uneducated comments and the
> attitude of a few commenters.

I presume you are referring to the fact that some people are conflating Nepomuk with the Strigi indexing service.  This is an unfortunate but understandable confusion, but it also has no bearing on this bug (and its many duplicates, not all of which have been marked as such in Bugzilla), which is about an unwanted notification.  One doesn't need a correct understanding of the roles of and relationship between Nepomuk, Akonadi, and Strigi to know that the notification is unwanted.

> We have another bug report for useful contributions on the same topic.

At this point I think the only sort of bug reports which might attract useful (developer) contributions would be on downstream bug trackers.  I'd encourage other users and testers to open a report with their respective OS distributions, as there doesn't appear to be any prospect of getting this bug fixed at its source.
Comment 71 Sebastian Trueg 2011-11-23 13:33:14 UTC
I just discussed this problem with the KDEPIM developers and was told that this bug can be closed as FIXED.
In the upcoming major release of KDEPIM this message will only be shown if you are using a component that actually depends on Nepomuk - like the KMail composer window.
Sadly this cannot be ported back to 4.7 due to the string freeze: no new translatable strings can be introduced in a bugfix release.
Comment 72 Alexander 2011-11-23 13:44:40 UTC
How I understand, this mean that if I use Kmail with disabled nepomuk I still will get these annoying messages without any chance to disable them? Nice fix, thanks! This is "almost" exactly what people requesting in 70 comments...
Comment 73 tim blechmann 2011-11-23 14:12:47 UTC
... just for the record (without caring about any flamewar that might have been here) ... i do consider this as a bug, because i get an error message every time i start kde because of a setting that i have been doing willingly.

it might be more user friendly to have a dialog, where a user can select if he wants to silence this warning.
Comment 74 Elvis Stansvik 2011-11-23 14:19:20 UTC
@Sebastian: Great! This at least makes me very happy, since I don't use KMail. I'll just live with the notifications until 4.8 is out.
Comment 75 Joe Biden 2011-12-04 05:48:09 UTC
Oh God, please, make Nepomuk entirely optional. It, and Akonadi, are so terrible. So, so terrible. They get in your way.

I search emails maybe once every other day. I don't need search functionality pestering me all of the time!
Comment 76 Peter Ambroz 2012-04-17 09:18:53 UTC
OK, this just can't be responsibility of one developer, who thinks that we must use nepomuk. bug is not fixed. fixing of this bug involves an option for user to disable notifications. I don't want to disable apps. I want to disable the notification. We aren't using MS windows, which forces users to do everything it says, are we? Linux should be about choices. I don't mean "choose gnome if you don't like nepomuk notifications". I mean "choose not to receive notifications and continue to use otherwise very fine K Destkop Environment".. consider this please.