Bug 258097 - minimized windows play "minimization" sound on restoring session
Summary: minimized windows play "minimization" sound on restoring session
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: core (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-27 19:02 UTC by Alexander Potashev
Modified: 2013-11-25 19:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.11


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Potashev 2010-11-27 19:02:56 UTC
Version:           unspecified (using KDE 4.5.80) 
OS:                Linux



Reproducible: Always

Steps to Reproduce:
1. start a KDE session
2. run Okular or other application
3. minimize Okular window
4. log out
5. log on again

Actual Results:  
You hear the sound usually played when you minimize a window.

Expected Results:  
That sound should be played. This break the concept of saving/restoring sessions: the window was minimized in the last session, then why it should be minimized again?
Comment 1 Martin Flöser 2012-04-08 20:52:14 UTC
The described behavior is technically correct. On session restore the window is first opened and then minimized. So playing the minimization sound is technically spoken correct.

Because of that I change to feature request as functionality needs to be extended.
Comment 2 Thomas Lübking 2012-04-16 18:08:50 UTC
question: should actually all Notify::raise annoyance be blocked until the client is fully managed?

Ie. when starting up a client minimized (regardless of session restoring) or on all desktops or whatever, does one really want to get a notification for it?
Comment 3 Martin Flöser 2013-04-23 14:25:04 UTC
Git commit d65334da3fb770bbcffea293d75e99130e12b0a8 by Martin Gräßlin.
Committed on 21/04/2013 at 13:31.
Pushed by graesslin into branch 'master'.

Remove KWin::Notifications

Overall all notifications except compositing suspended by DBus were
configured by default to not have any action. This means all the time we
emit a notification we keep DBus and KDED busy for nothing.

All the cases when a notification is triggered ire also exported to
KWin scripting, so if one really needs to handle something in case a
window is moved, it could be done through a KWin script with much more
context about the event.

REVIEW: 110113
FIXED-IN: 4.11

M  +0    -1    kwin/CMakeLists.txt
M  +0    -1    kwin/activation.cpp
M  +0    -1    kwin/client.cpp
M  +1    -0    kwin/composite.cpp
M  +0    -1    kwin/geometry.cpp
M  +0    -1    kwin/manage.cpp
D  +0    -78   kwin/notifications.cpp
D  +0    -57   kwin/notifications.h
M  +0    -2    kwin/utils.cpp
M  +0    -1    kwin/workspace.cpp

http://commits.kde.org/kde-workspace/d65334da3fb770bbcffea293d75e99130e12b0a8