Bug 258082 - FacesEngine doesn't increment ids' while saving hash database
Summary: FacesEngine doesn't increment ids' while saving hash database
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Faces (show other bugs)
Version: 2.0.0
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-27 17:00 UTC by Teemu Autto
Modified: 2018-04-01 09:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 2.0.0


Attachments
set returned vector values to reflect ids' (351 bytes, patch)
2010-12-06 13:17 UTC, Teemu Autto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Teemu Autto 2010-11-27 17:00:46 UTC
Version:           2.0.0 (using KDE 4.5.4) 
OS:                Linux

When Database save is called, name/id pair passed to KFaceUtils::addNameToFile() gets "-1" as ID, and so every pair contains "name", "-1".

Reproducible: Always

Steps to Reproduce:
- Detect new faces for picture, add names, and save database.
- restart detection program, load old database.
- Try recognizing faces, get "empty" results.

Actual Results:  
Faces are recognized, but names aren't loaded.

Expected Results:  
- Names are assigned.

OpenCV Version: 2.1.0-0.pm.15.11
QT Version: 4.7.1-141.2
Comment 1 Teemu Autto 2010-12-06 13:17:33 UTC
Created attachment 54203 [details]
set returned vector values to reflect ids'
Comment 2 Teemu Autto 2010-12-06 13:19:18 UTC
Problem seems to be in libfaces' Eingenfaces.cpp, where result vector isn't updated accordingly.
Comment 3 caulier.gilles 2010-12-06 13:24:36 UTC
SVN commit 1204177 by cgilles:

apply patch #54203 from Teemu Autto to return updated vector value ID
BUGS: 258082


 M  +1 -0      Eigenfaces.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1204177