Bug 257970 - Message won't be shown in preview pane
Summary: Message won't be shown in preview pane
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail2
Classification: Unclassified
Component: general (show other bugs)
Version: 2.0.90
Platform: openSUSE RPMs Linux
: NOR normal with 41 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
: 271014 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-26 14:24 UTC by Gael Beaudoin
Modified: 2018-10-27 02:54 UTC (History)
14 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
I clicked on a mail and no preview was displayed, it stays like this... (503.02 KB, image/png)
2010-12-02 13:01 UTC, Anne-Marie Mahfouf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gael Beaudoin 2010-11-26 14:24:08 UTC
Version:           2.0 beta1 (using KDE 4.5.80) 
OS:                Linux

I click on a message in the message list and the preview pane shows me the "Retrieving Folder Contents

Please wait . . ." message. Permanantly.

On the console, there are a few lines each time I click a message:

kmail2(10630)/kdewebkit KWebPage::acceptNavigationRequest: url:   QUrl( "file:///usr/share/kde4/apps/kmail/about/main.html" )  , type:  5 , frame:  QWebFrame(0x85167e0)
kmail2(10630)/kio (Scheduler) KIO::SchedulerPrivate::doJob: KIO::SimpleJob(0x8472510)
kmail2(10630)/kio (KIOJob) KIO::SlaveInterface::dispatch: error  111   "/usr/share/kde4/apps/kdeui/about/body-background.png"
kmail2(10630)/kio (KIOJob) KIO::TransferJob::slotFinished: KUrl("file:///usr/share/kde4/apps/kdeui/about/body-background.png")
kmail2(10630)/kio (Scheduler) KIO::SchedulerPrivate::jobFinished: KIO::TransferJob(0x8472510) KIO::Slave(0x8c1f7e0)
kmail2(10630)/kio (AccessManager) KDEPrivate::AccessManagerReply::slotResult: KIO::ERR_DOES_NOT_EXIST -> QNetworkReply::ContentNotFoundError

In the background, virtuoso is working like mad, I don't know if it could be related.

Restarting kmail do not fix the problem.

Restarting akonadi, and then kmail : an email appeared in the preview pane, and then same waiting message and stuck, with same messages in the console.

It happens for all my three resources that used to work a few minutes ago.

There is no "cache refresh", force complete sync option/tool that would allow me to fix the problem besides deleting and creating the resource again I guess.

Reproducible: Always
Comment 1 Gael Beaudoin 2010-11-26 14:43:30 UTC
After a few minutes, the messages are now displayed. I don't know what fixed it.
Comment 2 Andrei Nistor 2010-12-01 18:03:46 UTC
I've encountered this with kmail 1 sometimes and it would get fixed by itself minutes later. Wich is weird, because it didn't use akonadi afaik
Comment 3 Anne-Marie Mahfouf 2010-12-02 12:58:40 UTC
Reproduced, see screenshot
Comment 4 Anne-Marie Mahfouf 2010-12-02 13:01:46 UTC
Created attachment 53974 [details]
I clicked on a mail and no preview was displayed, it stays like this...
Comment 5 Anne-Marie Mahfouf 2010-12-02 13:23:41 UTC
I can't point on when it happens and why. But it happened again. As KMail2 is very slow displaying mails, aggregating them or whatever I suppose it's a cause. It appears be doing something else and not managing displaying the content.
Comment 6 Alexander Potashev 2011-04-07 16:34:44 UTC
Try to click on another e-mail, and then back on the e-mail you clicked before.
Comment 7 Volker Krause 2011-04-10 11:12:24 UTC
Git commit f91829a5fc7975232a392c192056ec8ff0404ddd by Volker Krause.
Committed on 10/04/2011 at 11:17.
Pushed by vkrause into branch 'master'.

Fix possible race between item loading and the busy splash timer.

In the rare but theoretically possible scenario that the splash timer
fired between item receiving and item fetch job end, it would result in
the busy splash shown instead of the message.

CCBUG: 257970

M  +2    -0    kmail/kmmainwidget.cpp     

http://commits.kde.org/kdepim/f91829a5fc7975232a392c192056ec8ff0404ddd
Comment 8 Stephen Kelly 2011-04-22 13:02:15 UTC
Please retest this. It will likely be re-classified as not as release blocker if no one re-confirms it.
Comment 9 Alexander Potashev 2011-04-23 18:32:24 UTC
*** Bug 271014 has been marked as a duplicate of this bug. ***
Comment 10 Ivan D Vasin 2011-06-17 17:22:34 UTC
this happens to me every time, on every message, when kmail is still loading folders on startup.

steps to reproduce:
1. launch kmail.
2. wait for a folder to appear in one of the folder lists.
3. click on a folder.
4. wait for a message to appear in the message list.
5. click on the message.
6. wait.

actual result:
the message preview pane shows "Retrieving folder contents" indefinitely.

expected results:
1. the message preview pane shows "Retrieving message" until the message is retrieved, regardless of whether the rest of the folder contents are retrieved.
2. after the message is retrieved, the message preview pane displays the message.

workaround:
1. after all folders are loaded (not just the one that contains the message), select a different message.
2. select the original message.

this is with KMail 2.1.0, Kontact 4.6.0, Akonadi 1.5.3, KDE 4.6.4.
Comment 11 Ivan D Vasin 2011-06-21 18:55:38 UTC
this is resolved on my system.

over the weekend, i reinstalled Kubuntu on this machine.  i purposely didn't retain my KMail or Akonadi data, since i wanted a blank slate.  after installing KDE 4.6.4 (from ppa:kubuntu-ppa) and Kontact Suite 4.6.0 (from ppa:kubuntu-ppa/experimental), i logged out of X and did ``rm -rf ~/.config ~/.local ~/.kde`` before logging back in.

after that, i no longer see this issue.  even better, this resolved several other issues:
  * all folders and messages seem to load *much* faster.
  * i no longer need to wait for a folder to load entirely before listing its messages.
  * i no longer need to wait for all folders to load before previewing any messages.

this is especially peculiar since all of the relevant software versions are the same.  the major differences are:

  * the old setup started as Kubuntu 10.10 with KDE 4.5 and Kontact Suite 4.4, which was later upgraded to Kubuntu 11.04 with KDE 4.6 and Kontact Suite 4.6.  the new setup is a fresh installation of the latter versions.

  * the old setup had fresh settings for KDE 4.6, but its Kontact Suite settings were migrated from 4.4 to 4.6.  the new setup has fresh settings for everything.

i suspect that the latter point is what made the difference.  if you're seeing any of these issues, try wiping out ~/.config, ~/.local, and ~/.kde.  of course, back those up first if you value your current settings and data--simply renaming them should do the trick.  the real culprit might be one or more specific subdirectories of those directories, but this shotgun approach should be useful at least to determine whether that's the case.
Comment 12 Ivan D Vasin 2011-07-01 16:00:40 UTC
the issue returns for me if i enable "interval mail checking" or "check mail on startup".  these features are confusing to me; even if i disable them, KMail still receives new messages at regular intervals and on startup.  what is the purpose of these features?  are they broken or useless?

regardless, disabling them seems to have no negative impact, and it seems to make this issue mostly go away.  i say "mostly" because it still sometimes happens on startup, but not as dramatically as before and not every time.
Comment 13 Johannes Zellner 2011-07-19 07:45:03 UTC
I recently updated to Kmail 2 and hit the same issue.
It only happens with my imap bridge for an MS exchange.
Other two disconnected Imap accounts work just fine.
To reproduce, I can just delete a single message from this account and it get stuck with:

"
Retrieving Folder Contents

Please wait . . .
 "

Only solution for me is now to close kmail and then resatart akonadi service and start kmail again....this works not always :-(
Comment 14 Alvise 2011-08-14 16:47:06 UTC
Still there with kmail2 4.7.0

If I launch kmail from the command menu, I get the following message when kmail
becomes stuck retrieving folder contents:
kmail2(8586) MessageViewer::ContactPhotoMemento::slotSearchJobFinished: Unable
to fetch photo for contact: "Item query returned empty result set"
Comment 15 San 2011-10-17 10:37:54 UTC
same issue here after upgrading to kubuntu 11.10 (ships with kmail 4.7.2)

sometimes the email finally appears after a while, but not always.
When I have the "please wait" infernal splash screen, it stays put for all my sub folders.
Comment 16 Silver Salonen 2012-03-06 11:03:22 UTC
I can almost always re-create the problem when I quit KMail - the Akonadi IMAP-processes remain running which actually also keep kmail process alive. When I kill KMail and re-launch it, the new kmail seems not to be able to communicate with Akonadi anymore.

When I kill kmail and the imap-processes, re-launch KMail, it starts working again.
Comment 17 tony den haan 2012-03-16 14:41:01 UTC
i've been having this problem with imap for years already. strace shows little more than:

read(7, 0x251c604, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN}, {fd=8, events=POLLIN}, {fd=7, events=POLLIN}, {fd=9, events=POLLIN}, {fd=10, events=POLLIN}, {fd=5, events=POLLIN}, {fd=13, events=POLLIN}, {fd=16, events=POLLIN}], 8, 0) = 0 (Timeout)
Comment 18 Andreas Cord-Landwehr 2012-03-16 14:51:30 UTC
Make sure that you are running packages from KDE SC 4.8.1 (kdepimlibs, kdepim-runtime, kdepim) since with that release several causes for this problems were fixed (actually my problems are all gone after upgrade). If that does not solve the problem, also check if the imap resource is online (can be checked with akonadiconsole).
Comment 19 Silver Salonen 2012-03-16 14:52:32 UTC
I still have the problem quite often in 4.8.1, and both IMAP resources are online.
Comment 20 Mark Fraser 2012-04-29 08:29:57 UTC
I'm still seeing this with KDE 4.8.2 and only POP3 email.
Comment 21 Silver Salonen 2012-08-02 10:04:23 UTC
Still happens in 4.9.0.
Comment 22 Roman Zimmermann 2013-03-19 20:15:07 UTC
The bug status says "NEEDS INFO" - I don't see any request for more information. There seem to be at least some users who can reproduce this problem with the current version. So what information should we provide? How can we get this information?
Comment 23 Andrew Crouthamel 2018-09-24 02:07:52 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 24 Andrew Crouthamel 2018-10-27 02:54:59 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!