Bug 257959 - KGet does not build (bittorrent plugin fails)
Summary: KGet does not build (bittorrent plugin fails)
Status: RESOLVED FIXED
Alias: None
Product: kget
Classification: Applications
Component: torrent (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KGet authors
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-26 11:50 UTC by Andrea Scarpino
Modified: 2011-01-09 18:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrea Scarpino 2010-11-26 11:50:10 UTC
Version:           unspecified (using KDE 4.5.80) 
OS:                Linux

Hi, kdenetwork-kget build fails with:

Linking CXX shared module ../../../lib/kget_metalinkfactory.so
[ 44%] Building CXX object
kget/transfer-plugins/bittorrent/CMakeFiles/kget_bittorrentfactory.dir/bttransferhandler.o
In file included from
/build/src/kdenetwork-4.5.80/kget/transfer-plugins/bittorrent/bttransferhandler.cpp:16:0:
/build/src/kdenetwork-4.5.80/kget/transfer-plugins/bittorrent/scandlg.h:27:45:
fatal error: datachecker/datacheckerlistener.h: No such file or
directory
compilation terminated.
make[2]: *** [kget/transfer-plugins/bittorrent/CMakeFiles/kget_bittorrentfactory.dir/bttransferhandler.o]
Error 1
make[1]: *** [kget/transfer-plugins/bittorrent/CMakeFiles/kget_bittorrentfactory.dir/all]
Error 2
make[1]: *** Waiting for unfinished jobs....

I am using a recent snapshot of libktorrent from git.

Reproducible: Always


Actual Results:  
build fails


libktorrent-git 20101125
kde 4.5.80
Comment 1 Lukas Appelhans 2010-11-26 14:06:05 UTC
Yes it does only compile with stable libktorrent at the moment...

I will push a fix which let's it compile with both soon though :)

Lukas
Comment 2 Andrea Scarpino 2010-12-13 11:39:41 UTC
fixed with http://websvn.kde.org/?view=revision&revision=1205226
Comment 3 Christoph Feck 2011-01-08 17:25:08 UTC
I know I should not compile kget trunk against libktorrent master, but there are incompatible changes in libktorrent again.

The code needs to be adapted at some point, otherwise the user has to keep two versions of libktorrent installed, which defeats the primary motivation for splitting ktorrent. Reopening.
Comment 4 Lukas Appelhans 2011-01-08 21:20:44 UTC
Hey!

I didn't notice the newly introduced compile error yet, thanks for pointing me...

there are ifdefs now to support different versions since a few weeks already...

Lukas
Comment 5 Lukas Appelhans 2011-01-09 18:34:29 UTC
SVN commit 1213219 by lappelhans:

Remove the jobtracker again and go for the new direct method introduced recently in libktorrent
BUG:257959


 M  +0 -1      CMakeLists.txt  
 D             btjobtracker.cpp  
 D             btjobtracker.h  
 M  +0 -3      bttransferfactory.cpp  
 M  +2 -1      bttransferhandler.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1213219