Bug 257666 - icon size in pager tooltip should follow small icons settings
Summary: icon size in pager tooltip should follow small icons settings
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-pager (show other bugs)
Version: unspecified
Platform: Debian unstable Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-23 05:47 UTC by Janet
Modified: 2012-03-30 21:13 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janet 2010-11-23 05:47:35 UTC
Version:           unspecified (using KDE 4.5.3) 
OS:                Linux

The icons for the applications per desktop in the tooltip of the pager widget are shown in very tiny 16x16 size. I propose they should follow the size of the small icons according to systemsettings. Usually the reason to set a bigger small icons' size is bad eyes.

Reproducible: Always
Comment 1 Shaun Reich 2011-12-29 17:52:39 UTC
Git commit f95e3bad93b0a3efe5c6d2f0dd92cacb22f0ca31 by Shaun Reich.
Committed on 29/12/2011 at 06:33.
Pushed by sreich into branch 'master'.

Prefer KIconLoader::Small icon sizes for window thumbnails when possible

This makes the pager actually abide by the system settings designated
Small icon size. So increasing it to e.g. 42x42 would make the window
icons in the pager use that size.

It's set to use the width/height (whichever is smallest), and the
KIconLoader::Small. Whichever value is smaller.

Was previously hardcoded to 16x16. Should be a safe change, going to
backport.

M  +11   -6    plasma/desktop/applets/pager/pager.cpp

http://commits.kde.org/kde-workspace/f95e3bad93b0a3efe5c6d2f0dd92cacb22f0ca31
Comment 2 Shaun Reich 2011-12-29 17:53:07 UTC
Git commit f9db201ebb1b52c71fad13c6497302617e54b015 by Shaun Reich.
Committed on 29/12/2011 at 06:33.
Pushed by sreich into branch 'KDE/4.8'.

Prefer KIconLoader::Small icon sizes for window thumbnails when possible

This makes the pager actually abide by the system settings designated
Small icon size. So increasing it to e.g. 42x42 would make the window
icons in the pager use that size.

It's set to use the width/height (whichever is smallest), and the
KIconLoader::Small. Whichever value is smaller.

Was previously hardcoded to 16x16. Should be a safe change, going to
backport.
(cherry picked from commit 30366dfdcb6e649aca7edcf8fb9ea1b4a8fa3aa7)

M  +11   -6    plasma/desktop/applets/pager/pager.cpp

http://commits.kde.org/kde-workspace/f9db201ebb1b52c71fad13c6497302617e54b015
Comment 3 Shaun Reich 2011-12-29 18:12:50 UTC
By the way, let me know if this change is optimal or if you need some further tweaking of it...
Comment 4 Shaun Reich 2011-12-29 19:24:31 UTC
Git commit 1f5bf6e3fb8646fa3b768d88ebb2c5e8178b517e by Shaun Reich.
Committed on 29/12/2011 at 20:14.
Pushed by sreich into branch 'KDE/4.8'.

Use KIconLoader::Small for tooltip thumbnails as well.

It's possible ::Small should not be used for the tooltips of the pager,
perhaps ::Panel or ::Toolbar, etc. etc.?

This should present no change to anyone, since the defaults for ::Small
is 16x16 anyways.
FIXED-IN: 4.8
(cherry picked from commit e4736084dd391d3acd48e1bd64adbd5760eca68c)

M  +4    -2    plasma/desktop/applets/pager/pager.cpp

http://commits.kde.org/kde-workspace/1f5bf6e3fb8646fa3b768d88ebb2c5e8178b517e
Comment 5 Shaun Reich 2011-12-29 19:25:02 UTC
Git commit e4736084dd391d3acd48e1bd64adbd5760eca68c by Shaun Reich.
Committed on 29/12/2011 at 20:14.
Pushed by sreich into branch 'master'.

Use KIconLoader::Small for tooltip thumbnails as well.

It's possible ::Small should not be used for the tooltips of the pager,
perhaps ::Panel or ::Toolbar, etc. etc.?

This should present no change to anyone, since the defaults for ::Small
is 16x16 anyways.
FIXED-IN: 4.8

M  +4    -2    plasma/desktop/applets/pager/pager.cpp

http://commits.kde.org/kde-workspace/e4736084dd391d3acd48e1bd64adbd5760eca68c
Comment 6 Janet 2012-03-30 21:13:22 UTC
Thanks :)