Bug 25755 - kmail external editor behaviour
Summary: kmail external editor behaviour
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Unclassified
Component: composer (show other bugs)
Version: 4.9 pre
Platform: openSUSE RPMs Linux
: NOR normal with 104 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 24865 (view as bug list)
Depends on:
Blocks:
 
Reported: 2001-05-15 12:33 UTC by colm
Modified: 2014-11-16 09:06 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mepk 2001-05-15 12:20:55 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           kmail
Version:           KDE 2.1.1 
Severity:          wishlist
Installed from:    SuSE RPMs
Compiler:          Not Specified
OS:                Linux
OS/Compiler notes: Not Specified

Whenever I want use the external editor in kmail (emacs %f) the composer starts and I have to click inside the text area _and_ _then_ type 1 character first before kmail finally starts the external editor.

Sorry but THIS SUCKS!

Look at the knode newsreader they implemented this feature very well:
The composer _and_ the external editor start at the same time. After that you can type using your favourite editor. Then you simply close your editor and the composer gets all the text which you can still edit afterwards inside the composer.

Please change the odd kmail behaviour thanks in advance!

Christian Janoff.
mepk@c64.org


(Submitted via bugs.kde.org)
Comment 1 Ingo Klöcker 2003-06-10 15:52:04 UTC
*** Bug 24865 has been marked as a duplicate of this bug. ***
Comment 2 Anthony Parent 2003-08-04 17:42:24 UTC
I would like to add my 2 cents worth here. I setup kmail to use the external editor, and 
tryed to send a new message. To me it appeared that the external editor function 
didn't work. I wasn't until I found this bug that I realized I had to type in the composer 
window to get my exteral editor to come up. This is VERY wierd behavior and should 
be fixed. 
Comment 3 Stephan Kulow 2004-05-18 17:31:59 UTC
Replaced mepk@c64.org with colm@tuatha.org due to bounces by reporter
Comment 4 Gilles Schintgen 2004-07-25 01:12:35 UTC
Comment #2 is absolutely right. I thought it was broken until I looked it up in the documentation. Really weird behaviour.
Comment 5 Tassilo Horn 2006-05-22 13:31:54 UTC
You're all right, the current behavior is weird. For me the most bugging thing is that the external editor is _always_ launched, even if you don't need it.

So I propose a solution in Bug/Wish #127817. Feel free to vote.
Comment 6 Tassilo Horn 2006-05-22 13:34:42 UTC
Argh, solution is in Bug #127817. (The "/Wish" prevented bugzilla from automatically creating the link.)
Comment 7 Anthony Parent 2006-05-23 02:59:52 UTC
First, make it configureable, "Always use external editor" or "Use external editor only when told" or something like that

Secondly, make sure that there is a hot key or short-cut key for starting the external editor. (Make that configurable as well.) That way if someone is in "Only when told" mode and they are editing a message they thought would be quick, and later decide to use the external editor, they just hit a hot key and the editor starts up. (With the already edited message.) Don't force the use of a menu. (Although that should be there as well.)

That's my vote.
Comment 8 Björn Ruberg 2009-12-13 00:56:54 UTC
I consider having to click in the composer window a bug. A bug that is still valid.
Comment 9 Martin Koller 2012-07-05 20:45:46 UTC
Report still valid in kmail2, KDE 4.9RC1
Comment 10 Laurent Montel 2013-04-17 07:11:20 UTC
Git commit c4ffca8a53bade9ada0652c48978c5b295411112 by Montel Laurent.
Committed on 17/04/2013 at 09:10.
Pushed by mlaurent into branch 'KDE/4.10'.

Fix Bug 25755 - kmail external editor behaviour

FIXED-IN: 4.10.3
(waou bug reported in 2001...)

M  +1    -2    kmail/kmcomposewin.cpp
M  +7    -0    messagecomposer/kmeditor.cpp
M  +2    -0    messagecomposer/kmeditor.h

http://commits.kde.org/kdepim/c4ffca8a53bade9ada0652c48978c5b295411112
Comment 11 Garry Williams 2014-11-16 03:51:03 UTC
(In reply to mepk from comment #0)
> Whenever I want use the external editor in kmail (emacs %f) the
> composer starts and I have to click inside the text area _and_
> _then_ type 1 character first before kmail finally starts the
> external editor.
>
> Sorry but THIS SUCKS!

Well, the behavior was fine for me for years.

My work flow is now broken (http://xkcd.com/1172/).

Open a new message window (ctrl-N); type in recipient(s); tab to
subject and type in subject; tab to message area and tab.  Now focus
is in the editor.  Edit message.

The behavior you requested and got is fine for replying to a message
since you want to start editing the reply immediately.  But it's wrong
to immediately open the editor and have it steal focus when starting a
new message.

I wish this "fix" never happened.
Comment 12 RJVB 2014-11-16 09:06:25 UTC
I think Anthony described how to make the "fix" complete and probably acceptable for everyone: https://bugs.kde.org/show_bug.cgi?id=25755#c7 ...