Bug 257438 - Crash when selecting files
Summary: Crash when selecting files
Status: RESOLVED FIXED
Alias: None
Product: nepomuk
Classification: Unclassified
Component: libnepomukcore (show other bugs)
Version: 4.4
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
: 294302 294446 294886 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-20 20:22 UTC by montgomerie
Modified: 2012-12-30 19:02 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description montgomerie 2010-11-20 20:22:49 UTC
Application: dolphin (1.4)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 2"
Qt Version: 4.6.3
Operating System: Linux 2.6.34-12-default x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
I was drag-selecting files in Dolphin when it froze and crashed

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#5  0x00007f5357ca936c in QMutex::lock (this=0x9cd148) at thread/qmutex.cpp:150
#6  0x00007f5354dc757f in Soprano::Client::ClientConnection::~ClientConnection (this=0x9cb510, __in_chrg=<value optimized out>) at /usr/src/debug/soprano-2.4.2/client/clientconnection.cpp:73
#7  0x00007f5354dc3b83 in ~LocalSocketClientConnection (this=0x9cb510, __in_chrg=<value optimized out>) at /usr/src/debug/soprano-2.4.2/client/localsocketclient.cpp:56
#8  Soprano::Client::LocalSocketClientConnection::~LocalSocketClientConnection (this=0x9cb510, __in_chrg=<value optimized out>) at /usr/src/debug/soprano-2.4.2/client/localsocketclient.cpp:58
#9  0x00007f5354dc4546 in Soprano::Client::LocalSocketClient::disconnect (this=0x9caa58) at /usr/src/debug/soprano-2.4.2/client/localsocketclient.cpp:164
#10 0x00007f5354dc45af in Soprano::Client::LocalSocketClient::connect (this=0x9caa58, name=...) at /usr/src/debug/soprano-2.4.2/client/localsocketclient.cpp:145
#11 0x00007f53599e1e53 in init (this=0x9ca8a0) at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/nepomukmainmodel.cpp:102
#12 Nepomuk::MainModel::init (this=0x9ca8a0) at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/nepomukmainmodel.cpp:189
#13 0x00007f53599e2ac1 in Nepomuk::ResourceManager::init (this=0x9b1910) at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/resourcemanager.cpp:320
#14 0x00007f53599e4203 in Nepomuk::ResourceManager::ResourceManager (this=0x9b1910) at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/resourcemanager.cpp:278
#15 0x00007f53599eda09 in ResourceManagerHelper () at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/resourcemanager.cpp:298
#16 operator-> () at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/resourcemanager.cpp:302
#17 Nepomuk::ResourceManager::instance () at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/resourcemanager.cpp:306
#18 0x000000000043aa3f in _start ()

Reported using DrKonqi
Comment 1 Sebastian Trueg 2011-01-05 17:55:36 UTC
Can you reproduce this with Soprano 2.5.3?
Comment 2 Christophe Giboudeaux 2012-02-23 13:46:55 UTC
*** Bug 294446 has been marked as a duplicate of this bug. ***
Comment 3 Christophe Giboudeaux 2012-02-29 10:12:39 UTC
*** Bug 294886 has been marked as a duplicate of this bug. ***
Comment 4 Christophe Giboudeaux 2012-02-29 10:12:56 UTC
*** Bug 294302 has been marked as a duplicate of this bug. ***
Comment 5 Vishesh Handa 2012-12-30 19:02:44 UTC
Marking as FIXED.

The relevant code has changed considerably and this crash can no longer occur, specially with the latest Soprano.