Bug 257397 - BlueDevil cannot receive files from phone to PC
Summary: BlueDevil cannot receive files from phone to PC
Status: RESOLVED FIXED
Alias: None
Product: solid
Classification: Unclassified
Component: bluetooth (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Alex Fiestas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-20 10:18 UTC by linuxboy
Modified: 2010-12-31 17:33 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
dbus-monitor log of the interrupted transfer session (14.92 KB, text/plain)
2010-11-20 10:18 UTC, linuxboy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description linuxboy 2010-11-20 10:18:33 UTC
Created attachment 53572 [details]
dbus-monitor log of the interrupted transfer session

Version:           unspecified (using KDE 4.5.1) 
OS:                Linux

Bluedevil send file TO phone but cannot receive file FROM phone.

I use kubuntu 10.10, this is the packages.

bluedevil_1.0~rc4-0ubuntu2.1_i386.deb
libbluedevil1_1.8-0ubuntu1_i386.deb

I've tried to remove packets from canonical and I've tried to compile myself last version of bluedevil and libbluedevil (from gitorius). Nothing change, files from phone cannot be transferred to PC.

I've tried with others phones or bluetooth pc devices, and happens the same thing.

If I try to browse the phone, 






Reproducible: Always

Steps to Reproduce:
get a phone, send a file from phone to pc.

Actual Results:  
connection was interrupted by pc and file isn't transferred from phone to pc.

Expected Results:  
file is transferred from phone to pc

In attachment you can find dbus-monitor log.
Comment 1 linuxboy 2010-11-20 10:24:34 UTC
sorry for missing word at the end of my post. I complete the post now.

If I try to browse the phone from PC, all works good, but if I try to get a file from phone, transfer hangs and only a part of file was transfered. If I try to put a file on phone, all works perfectly.
Comment 2 Pino Toscano 2010-11-20 10:53:02 UTC
> last version of bluedevil and libbluedevil (from gitorius).

libbluedevil & bluedevil are on git.kde.org now.
Comment 3 linuxboy 2010-11-20 16:51:09 UTC
thank you, Pino. I've removed the ubuntu package of bluedevil and libbluedevil and then I've downloaded the last git version of bluedevil and libbluedevil from git.kde.org . Then, I've compiled and installed them. But the problem isn't solved. I cannot send files from phone to PC.
Comment 4 info 2010-11-21 12:37:10 UTC
i have similar problems with:

bluedevil-1.0-1mdv2010.1
libbluedevil1-1.8.1-0.0mdv2010.1

with xperia x1 and nokia 9500 i am not able to send/receive file.
i can browse the nokia device and transfer file.

Luca.
Comment 5 Alex Fiestas 2010-11-21 20:23:06 UTC
Fixed in master (1.1) and stable (1.0.1), will be released asap.

Thanks!
Comment 6 linuxboy 2010-11-21 23:54:09 UTC
(In reply to comment #5)
> Fixed in master (1.1) and stable (1.0.1), will be released asap.
> 
> Thanks!

Yes, it works perfectly now. I've downloaded, compiled and installed the current git-version of libbbluedevil and bluedevil and the bug is fixed.

Thank you.
Comment 7 info 2010-11-22 15:15:27 UTC

I've downloaded, compiled and installed the
current git-version of libbbluedevil and bluedevil
Something better, but with Sony Xperia X1 i still have problems.
Sending file to the pc the icon change and say connected, but the transfer hangs.
Sending file to the phone randomly works.
Pc to pc it works.
Thanks anyway for your work, Luca.
Comment 8 Lamarque V. Souza 2010-12-31 17:33:52 UTC
I think this problem is not solved. I am not able to receive files from two phones: Samsung i8910 and Sony w800i. I am able to use w800i as input device (as a mouse) but not receive files from it. I can send files and browse the phones.