Bug 257113 - Crash during deletion of wired connection
Summary: Crash during deletion of wired connection
Status: RESOLVED DUPLICATE of bug 240285
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-17 02:36 UTC by J. Don Book
Modified: 2010-11-17 13:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description J. Don Book 2010-11-17 02:36:36 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

Deleting wired connection from inside the connection manager.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7700720 (LWP 27438))]

Thread 4 (Thread 0xae21ab70 (LWP 27441)):
#0  0x00d49e36 in clock_gettime (clock_id=13950964, tp=0xae219f80) at ../sysdeps/unix/clock_gettime.c:100
#1  0x08a5550b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x08b2c6e5 in QTimerInfoList::updateCurrentTime (this=0xa6687ac) at kernel/qeventdispatcher_unix.cpp:339
#4  0x08b2c72a in QTimerInfoList::timerWait (this=0xa6687ac, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x08b2a7a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xae21a0ac) at kernel/qeventdispatcher_glib.cpp:136
#6  0x08b2a83d in timerSourcePrepare (source=0x0, timeout=0xd4dff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0756ee6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x0756f279 in ?? () from /lib/libglib-2.0.so.0
#9  0x0756f848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x08b2a59f in QEventDispatcherGlib::processEvents (this=0xa630400, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x08afa609 in QEventLoop::processEvents (this=0xae21a280, flags=) at kernel/qeventloop.cpp:149
#12 0x08afaa8a in QEventLoop::exec (this=0xae21a280, flags=...) at kernel/qeventloop.cpp:201
#13 0x089f6b7e in QThread::exec (this=0x9f7a7d0) at thread/qthread.cpp:490
#14 0x08ad935b in QInotifyFileSystemWatcherEngine::run (this=0x9f7a7d0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x089f9df9 in QThreadPrivate::start (arg=0x9f7a7d0) at thread/qthread_unix.cpp:266
#16 0x0014dcc9 in start_thread (arg=0xae21ab70) at pthread_create.c:304
#17 0x0026a6ae in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 3 (Thread 0xad218b70 (LWP 27447)):
#0  0x001503eb in __pthread_mutex_lock (mutex=0xa9f8ddc) at pthread_mutex_lock.c:61
#1  0x00277f76 in pthread_mutex_lock (mutex=0xa9f8ddc) at forward.c:182
#2  0x0756eea3 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#3  0x0756f279 in ?? () from /lib/libglib-2.0.so.0
#4  0x0756f848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x08b2a59f in QEventDispatcherGlib::processEvents (this=0xa9fb6d0, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x08afa609 in QEventLoop::processEvents (this=0xad218280, flags=) at kernel/qeventloop.cpp:149
#7  0x08afaa8a in QEventLoop::exec (this=0xad218280, flags=...) at kernel/qeventloop.cpp:201
#8  0x089f6b7e in QThread::exec (this=0xa623858) at thread/qthread.cpp:490
#9  0x08ad935b in QInotifyFileSystemWatcherEngine::run (this=0xa623858) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x089f9df9 in QThreadPrivate::start (arg=0xa623858) at thread/qthread_unix.cpp:266
#11 0x0014dcc9 in start_thread (arg=0xad218b70) at pthread_create.c:304
#12 0x0026a6ae in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xac602b70 (LWP 31351)):
#0  0x0756a067 in g_main_context_query () from /lib/libglib-2.0.so.0
#1  0x0756f2c4 in ?? () from /lib/libglib-2.0.so.0
#2  0x0756fba7 in g_main_loop_run () from /lib/libglib-2.0.so.0
#3  0x0305b6b4 in ?? () from /usr/lib/libgio-2.0.so.0
#4  0x0759648f in ?? () from /lib/libglib-2.0.so.0
#5  0x0014dcc9 in start_thread (arg=0xac602b70) at pthread_create.c:304
#6  0x0026a6ae in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb7700720 (LWP 27438)):
[KCrash Handler]
#7  0x00000000 in ?? ()
#8  0x08b140e4 in QObject::disconnect (sender=0xa606a48, signal=0x0, receiver=0xa311608, method=0x92ae732 "2hasDefaultRouteChanged(bool)") at kernel/qobject.cpp:2749
#9  0x0929e09d in disconnect (this=0xa606a48) at /usr/include/qt4/QtCore/qobject.h:229
#10 InterfaceItem::currentConnectionChanged (this=0xa606a48) at ../../applet/interfaceitem.cpp:311
#11 0x0929ea6b in InterfaceItem::connectionStateChanged (this=0xa606a48, state=Solid::Control::NetworkInterface::Disconnected) at ../../applet/interfaceitem.cpp:426
#12 0x0929d72b in InterfaceItem::handleConnectionStateChange (this=0xa606a48, new_state=3, old_state=8, reason=38) at ../../applet/interfaceitem.cpp:358
#13 0x09292339 in InterfaceItem::qt_metacall (this=0xa606a48, _c=QMetaObject::InvokeMetaMethod, _id=48, _a=0xbf9ee210) at moc_interfaceitem.cpp:120
#14 0x09292c6a in WirelessInterfaceItem::qt_metacall (this=0xa606a48, _c=QMetaObject::InvokeMetaMethod, _id=48, _a=0xbf9ee210) at moc_wirelessinterfaceitem.cpp:69
#15 0x08b018ca in QMetaObject::metacall (object=0xa606a48, cl=153821172, idx=48, argv=0xbf9ee210) at kernel/qmetaobject.cpp:237
#16 0x08b146ad in QMetaObject::activate (sender=0xa360230, m=0x3b6562c, local_signal_index=3, argv=0xb3ee298) at kernel/qobject.cpp:3280
#17 0x03b48b7f in Solid::Control::NetworkInterface::connectionStateChanged (this=0xa360230, _t1=3, _t2=8, _t3=38) at ./networkinterface.moc:157
#18 0x03b48cfb in Solid::Control::NetworkInterface::qt_metacall (this=0xa360230, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbf9ee380) at ./networkinterface.moc:125
#19 0x03b4e01a in Solid::Control::WirelessNetworkInterface::qt_metacall (this=0xa360230, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbf9ee380) at ./wirelessnetworkinterface.moc:105
#20 0x08b018ca in QMetaObject::metacall (object=0xa360230, cl=153821172, idx=7, argv=0xbf9ee380) at kernel/qmetaobject.cpp:237
#21 0x08b146ad in QMetaObject::activate (sender=0xa4819b8, m=0x5dccaf4, local_signal_index=2, argv=0xb3ee298) at kernel/qobject.cpp:3280
#22 0x05db9c7f in NMNetworkInterface::connectionStateChanged (this=0xa4819b8, _t1=3, _t2=8, _t3=38) at ./networkinterface.moc:183
#23 0x05db9be1 in NMNetworkInterface::stateChanged (this=0xa4819b8, new_state=3, old_state=8, reason=38) at ../../../solid/networkmanager-0.7/networkinterface.cpp:247
#24 0x05dbad80 in NMNetworkInterface::qt_metacall (this=0xa4819b8, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0xbf9ee590) at ./networkinterface.moc:120
#25 0x05db041a in NMWirelessNetworkInterface::qt_metacall (this=0xa4819b8, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbf9ee590) at moc_wirelessnetworkinterface.cpp:88
#26 0x08b018ca in QMetaObject::metacall (object=0xa4819b8, cl=153821172, idx=7, argv=0xbf9ee590) at kernel/qmetaobject.cpp:237
#27 0x08b146ad in QMetaObject::activate (sender=0xa2db0e0, m=0x5dcdae4, local_signal_index=0, argv=0xb3ee298) at kernel/qobject.cpp:3280
#28 0x05dc472f in OrgFreedesktopNetworkManagerDeviceInterface::StateChanged (this=0xa2db0e0, _t1=3, _t2=8, _t3=38) at ./nm-deviceinterface.moc:134
#29 0x05dc47b4 in OrgFreedesktopNetworkManagerDeviceInterface::qt_metacall (this=0xa2db0e0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf9ee79c) at ./nm-deviceinterface.moc:90
#30 0x0075d9dc in QDBusConnectionPrivate::deliverCall (this=0x9d1e0a0, object=0xa2db0e0, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:919
#31 0x007691f7 in QDBusCallDeliveryEvent::placeMetaCall (this=0xaca7300, object=0xa2db0e0) at qdbusintegrator_p.h:103
#32 0x08b0e6a2 in QObject::event (this=0xa2db0e0, e=0xa311608) at kernel/qobject.cpp:1219
#33 0x06188fdc in QApplicationPrivate::notify_helper (this=0x9bee588, receiver=0xa2db0e0, e=0xaca7300) at kernel/qapplication.cpp:4396
#34 0x0618f04e in QApplication::notify (this=0x9bdda78, receiver=0xa2db0e0, e=0xaca7300) at kernel/qapplication.cpp:3798
#35 0x010d568a in KApplication::notify (this=0x9bdda78, receiver=0xa2db0e0, event=0xaca7300) at ../../kdeui/kernel/kapplication.cpp:310
#36 0x08afbb3b in QCoreApplication::notifyInternal (this=0x9bdda78, receiver=0xa2db0e0, event=0xaca7300) at kernel/qcoreapplication.cpp:732
#37 0x08afed8b in sendEvent (receiver=0x0, event_type=0, data=0x9bc7028) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#38 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9bc7028) at kernel/qcoreapplication.cpp:1373
#39 0x08afef4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#40 0x08b2aa74 in sendPostedEvents (s=0x9bf0910) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#41 postEventSourceDispatch (s=0x9bf0910) at kernel/qeventdispatcher_glib.cpp:277
#42 0x0756b855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#43 0x0756f668 in ?? () from /lib/libglib-2.0.so.0
#44 0x0756f848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#45 0x08b2a565 in QEventDispatcherGlib::processEvents (this=0x9bc6ce8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#46 0x0624abe5 in QGuiEventDispatcherGlib::processEvents (this=0x9bc6ce8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#47 0x08afa609 in QEventLoop::processEvents (this=0xbf9eefc4, flags=) at kernel/qeventloop.cpp:149
#48 0x08afaa8a in QEventLoop::exec (this=0xbf9eefc4, flags=...) at kernel/qeventloop.cpp:201
#49 0x08aff00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#50 0x06187e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#51 0x0089086e in kdemain (argc=1, argv=0xbf9ef1d4) at ../../../../plasma/desktop/shell/main.cpp:118
#52 0x080485bb in main (argc=1, argv=0xbf9ef1d4) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 255468, bug 255354, bug 240285.

Reported using DrKonqi
Comment 1 Dario Andres 2010-11-17 13:17:19 UTC
[Comment from a bug triager]
This issue is being tracked at bug 240285. Merging. Thanks

*** This bug has been marked as a duplicate of bug 240285 ***