Bug 256975 - Margin settings are ignored unless Printer Properties dialog is opened first
Summary: Margin settings are ignored unless Printer Properties dialog is opened first
Status: RESOLVED UPSTREAM
Alias: None
Product: kdelibs
Classification: Unclassified
Component: print-dialog (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: KDEPrint Devel Mailinglist
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-15 13:33 UTC by Tristan Miller
Modified: 2012-11-23 07:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tristan Miller 2010-11-15 13:33:57 UTC
Version:           unspecified (using KDE 4.5.3) 
OS:                Linux

When printing (to PDF or PostScript; I haven't tested this with an actual printer as I don't have one), the margin settings are ignored, and KDE uses ridiculously small margins.  However, if, before printing, you click on the "Properties" button next to the selected printer, a dialog will pop up allowing you to adjust the margins.  Just click on "OK" or "Cancel" (there's no need to actually change any settings); then when you print the margin settings will be used.

Reproducible: Always

Steps to Reproduce:
1. File->Print
2. Printer->Name->Print to File (PDF) or Printer->Name->Print to File (Postscript)
3. Print

Actual Results:  
4. The output file has very narrow margins, regardless of what the actual margin settings were.

Expected Results:  
4. The output file should have had the same margins specified in the Printer's Properties dialog.

To work around, insert the following steps:

2a. Properties
2b. Cancel
Comment 1 John Layt 2010-11-15 13:56:06 UTC
This is a problem in Qt, can you please report upstream at http://bugreports.qt.nokia.com/secure/Dashboard.jspa.  Thanks!
Comment 2 Tristan Miller 2010-11-15 15:31:50 UTC
As requested, I reported this on the Qt bug tracker: http://bugreports.qt.nokia.com/browse/QTBUG-15351
Comment 3 Tristan Miller 2011-03-17 10:46:30 UTC
This seems to be a duplicate of Bug 198172.
Comment 4 Tristan Miller 2012-11-23 07:34:30 UTC
The upstream bug has been marked as resolved in Qt 5.0.
Comment 5 Tristan Miller 2012-11-23 07:37:52 UTC
Oh, and the URL for the upstream bug report has changed: https://bugreports.qt-project.org/browse/QTBUG-15351