Bug 25690 - kdesu confused by extra output after successful authentication
Summary: kdesu confused by extra output after successful authentication
Status: RESOLVED FIXED
Alias: None
Product: kdesu
Classification: Unclassified
Component: general (show other bugs)
Version: 1.0
Platform: Mandrake RPMs Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kdesu bugs tracker
URL:
Keywords:
: 183671 (view as bug list)
Depends on:
Blocks:
 
Reported: 2001-05-14 03:48 UTC by rayner
Modified: 2010-11-06 17:19 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.5.4


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rayner 2001-05-14 03:40:34 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           kdesu
Version:           1.0 (using KDE 2.1.1 )
Severity:          wishlist
Installed from:    Mandrake RPMs
Compiler:          Not Specified
OS:                Linux
OS/Compiler notes: Not Specified

If you run a script in profile or bashrc such as:
/usr/games/fortune
kdesu will not function but says incorrect password.
The fortune program sends text to the console that kdesu
must be processing as the password rather then what you
type in.

(Submitted via bugs.kde.org)
Comment 1 Oswald Buddenhagen 2010-11-06 14:45:57 UTC
*** Bug 183671 has been marked as a duplicate of this bug. ***
Comment 2 James Richard Tyrer 2010-11-06 15:57:29 UTC
This is a KDE-2 bug from 2001.  Since it is like 9 years old, it should probably be closed.
Comment 3 Oswald Buddenhagen 2010-11-06 17:19:44 UTC
SVN commit 1193637 by ossi:

don't let extra output confuse us

we already assume that getting EOF instead of a stub signature is an
authentication failure. actively rejecting all extra output on top of
that does in fact break things if PAM or some login script prints
something before the stub is executed.

BUG: 25690
FIXED-IN: 4.5.4

 M  +0 -7      su.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1193637