Bug 256077 - Rekonq crashed when after closing the program.
Summary: Rekonq crashed when after closing the program.
Status: RESOLVED UPSTREAM
Alias: None
Product: Phonon
Classification: Frameworks and Libraries
Component: Xine backend (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Harald Sitter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-04 21:13 UTC by stevlowe9
Modified: 2010-12-17 10:22 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stevlowe9 2010-11-04 21:13:13 UTC
Application: rekonq (0.6.1)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
I had just closed out rekonq after reviewing a web page and then I received the error that the program had crashed.

-- Backtrace:
Application: rekonq (rekonq), signal: Aborted
[Current thread is 1 (Thread 0x7f022b621760 (LWP 7757))]

Thread 7 (Thread 0x7f02166c6710 (LWP 7758)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f022a13520e in ?? () from /usr/lib/libQtWebKit.so.4
#2  0x00007f022a135329 in ?? () from /usr/lib/libQtWebKit.so.4
#3  0x00007f0225bb7971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#4  0x00007f022ae9b91d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f02144e6710 (LWP 7759)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f0226148e3b in wait (this=<value optimized out>, mutex=0x2379eb0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x2379eb0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f022815f524 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2379c20, th=0x278de20) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f022816272b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2379f10, th=0x278de20) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f0228160c9f in ThreadWeaver::ThreadRunHelper::run (this=0x7f02144e5e00, parent=0x2379c20, th=0x278de20) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f02281611f8 in ThreadWeaver::Thread::run (this=0x278de20) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f022614827e in QThreadPrivate::start (arg=0x278de20) at thread/qthread_unix.cpp:266
#8  0x00007f0225bb7971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#9  0x00007f022ae9b91d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f021103b710 (LWP 7761)):
#0  0x00007f022ae8f1d3 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f02217b7009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f02217b745c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f02262681e6 in QEventDispatcherGlib::processEvents (this=0x2543820, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007f022623aa02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f022623adec in QEventLoop::exec (this=0x7f021103adb0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f02261452fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f022621a5f8 in QInotifyFileSystemWatcherEngine::run (this=0x251a100) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f022614827e in QThreadPrivate::start (arg=0x251a100) at thread/qthread_unix.cpp:266
#9  0x00007f0225bb7971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007f022ae9b91d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f020b99d710 (LWP 7807)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:212
#1  0x00007f02078910d1 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f0225bb7971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#3  0x00007f022ae9b91d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f01f854f710 (LWP 7858)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f022aa9b334 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f022ada6160) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f022aa9b369 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f022adb4234) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f0225bb7971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#4  0x00007f022ae9b91d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f01f7604710 (LWP 7863)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f0226148e3b in wait (this=<value optimized out>, mutex=0x2379eb0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x2379eb0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f022815f524 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2379c20, th=0x32e6fa0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f022816272b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2379f10, th=0x32e6fa0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f0228160c9f in ThreadWeaver::ThreadRunHelper::run (this=0x7f01f7603e00, parent=0x2379c20, th=0x32e6fa0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f02281611f8 in ThreadWeaver::Thread::run (this=0x32e6fa0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f022614827e in QThreadPrivate::start (arg=0x32e6fa0) at thread/qthread_unix.cpp:266
#8  0x00007f0225bb7971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#9  0x00007f022ae9b91d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f022b621760 (LWP 7757)):
[KCrash Handler]
#6  0x00007f022ade8ba5 in raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007f022adec6b0 in abort () at abort.c:92
#8  0x00007f022ae2243b in __libc_message (do_abort=<value optimized out>, fmt=<value optimized out>) at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
#9  0x00007f022ae2c4b6 in malloc_printerr (action=3, str=0x7f022aefcca2 "corrupted double-linked list", ptr=<value optimized out>) at malloc.c:6283
#10 0x00007f022ae2c961 in malloc_consolidate (av=<value optimized out>) at malloc.c:5169
#11 0x00007f022ae2f350 in _int_free (av=0x7f020c000020, p=0x7f020c975d70) at malloc.c:5034
#12 0x00007f022ae32c83 in __libc_free (mem=<value optimized out>) at malloc.c:3738
#13 0x00007f02078918d9 in ?? () from /usr/lib/libxine.so.1
#14 0x00007f0207891d75 in ?? () from /usr/lib/libxine.so.1
#15 0x00007f020788cf0f in xine_exit () from /usr/lib/libxine.so.1
#16 0x00007f0207b1a408 in QList<Phonon::Xine::XineEngine>::free(QListData::Data*) () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#17 0x00007f0207b14c79 in Phonon::Xine::Backend::~Backend (this=0x2ad0cc0, __in_chrg=<value optimized out>) at ../../xine/backend.cpp:123
#18 0x00007f0225045927 in Phonon::FactoryPrivate::~FactoryPrivate (this=0x29ec490, __in_chrg=<value optimized out>) at ../../phonon/factory.cpp:218
#19 0x00007f022623c18c in qt_call_post_routines () at kernel/qcoreapplication.cpp:203
#20 0x00007f0226732288 in QApplication::~QApplication (this=0x7fff56fb58e0, __in_chrg=<value optimized out>) at kernel/qapplication.cpp:1044
#21 0x00007f022b18d7e3 in Application::~Application (this=0x7fff56fb58e0, __in_chrg=<value optimized out>) at /build/buildd/rekonq-0.6.1/src/application.cpp:102
#22 0x00007f022b214663 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /build/buildd/rekonq-0.6.1/src/main.cpp:198
#23 0x00007f022add3d8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff56fb6138) at libc-start.c:226
#24 0x0000000000400659 in _start ()

Possible duplicates by query: bug 208881.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2010-12-17 10:22:23 UTC
The problem is in libxine, not much we can do about this, sorry. Please report this upstream at the xine-project