Bug 256031 - kcmshell crashes when adding mobile broadband connection
Summary: kcmshell crashes when adding mobile broadband connection
Status: RESOLVED FIXED
Alias: None
Product: Network Management
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lamarque V. Souza
URL:
Keywords:
: 265372 268914 269647 279362 284784 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-04 11:16 UTC by Tamás Németh
Modified: 2011-10-23 14:18 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
crash information (7.58 KB, application/octet-stream)
2010-11-04 11:16 UTC, Tamás Németh
Details
Latest crash information (7.62 KB, text/plain)
2011-02-21 12:42 UTC, Tamás Németh
Details
New crashlog after updating (7.62 KB, text/plain)
2011-02-21 17:08 UTC, Tamás Németh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Németh 2010-11-04 11:16:13 UTC
Created attachment 53121 [details]
crash information

Version:           unspecified (using Devel) 
OS:                Linux

When I try to add my _SECOND_ mobile broadband connection, the dialog windows crashes, and I won't be able to add the connection.

Adding the first connection will succeed (when called from knetworkmanager it uses the old method where I have to set Number, APN, PIN, etc. and it works fine), however, if I already have a connection, then adding the second one won't succeed. When I start adding the second connection, KDE gives me a new, different dialog where I have to set my country, ISP, etc. However, when selecting any country KDE gives me NO ISP names, as it were missing some ISP database. I tried to manually create my ISP, but when I click on Next, the dialog crashes.

Reproducible: Always

Steps to Reproduce:
Add a mobile broadband connection and then try to add a second one.

Actual Results:  
kcmshell crashes.

Expected Results:  
I should be able to add the new 3G connection.

Crash info attached.
Comment 1 Christoph Feck 2010-11-04 13:28:11 UTC
Backtrace from attachment:

Application: KDE beállítómodul (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0x00007fe54220bc78 in MobileConnectionWizard::initializePage (this=0x9dd870, id=<value optimized out>) at /usr/src/debug/networkmanagement/settings/config/mobileconnectionwizard.cpp:103
#7  0x00007fe555e4d13c in QWizardPrivate::switchToPage (this=0x9df730, newId=<value optimized out>, direction=<value optimized out>) at dialogs/qwizard.cpp:849
#8  0x00007fe555e4d928 in QWizard::qt_metacall (this=0x9dd870, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0x7fffd99044b0) at .moc/release-shared/moc_qwizard.cpp:170
#9  0x00007fe542204200 in MobileConnectionWizard::qt_metacall (this=0x9dd870, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd99044b0)
    at /usr/src/debug/networkmanagement/build/settings/config/moc_mobileconnectionwizard.cpp:78
#10 0x00007fe5567c2b5f in QMetaObject::activate (sender=0x84efd0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffd99044b0) at kernel/qobject.cpp:3272
#11 0x00007fe555fc60c2 in QAbstractButton::clicked (this=<value optimized out>, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:206
#12 0x00007fe555d0a84b in QAbstractButtonPrivate::emitClicked (this=<value optimized out>) at widgets/qabstractbutton.cpp:546
#13 0x00007fe555d0be1b in QAbstractButtonPrivate::click (this=0x9e3760) at widgets/qabstractbutton.cpp:539
#14 0x00007fe555d0c08c in QAbstractButton::mouseReleaseEvent (this=0x84efd0, e=0x7fffd9904e30) at widgets/qabstractbutton.cpp:1121
#15 0x00007fe5559a5678 in QWidget::event (this=0x84efd0, event=0x7fffd9904e30) at kernel/qwidget.cpp:8187
#16 0x00007fe555953f34 in QApplicationPrivate::notify_helper (this=0x669cb0, receiver=0x84efd0, e=0x7fffd9904e30) at kernel/qapplication.cpp:4396
#17 0x00007fe55595cbda in QApplication::notify (this=<value optimized out>, receiver=0x84efd0, e=0x7fffd9904e30) at kernel/qapplication.cpp:3959
#18 0x00007fe557439846 in KApplication::notify (this=0x7fffd99073a0, receiver=0x84efd0, event=0x7fffd9904e30) at /usr/src/debug/kdelibs-4.5.3/kdeui/kernel/kapplication.cpp:310
#19 0x00007fe5567ad9dc in QCoreApplication::notifyInternal (this=0x7fffd99073a0, receiver=0x84efd0, event=0x7fffd9904e30) at kernel/qcoreapplication.cpp:732
#20 0x00007fe555954f35 in sendEvent (receiver=0x84efd0, event=0x7fffd9904e30, alienWidget=0x84efd0, nativeWidget=0x9dd870, buttonDown=0x7fe556429ef8, lastMouseReceiver=..., spontaneous=true)
    at ../../src/corelib/kernel/qcoreapplication.h:215
#21 QApplicationPrivate::sendMouseEvent (receiver=0x84efd0, event=0x7fffd9904e30, alienWidget=0x84efd0, nativeWidget=0x9dd870, buttonDown=0x7fe556429ef8, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:3058
#22 0x00007fe5559d22e8 in QETWidget::translateMouseEvent (this=0x9dd870, event=<value optimized out>) at kernel/qapplication_x11.cpp:4403
#23 0x00007fe5559d0a19 in QApplication::x11ProcessEvent (this=0x7fffd99073a0, event=0x7fffd9905790) at kernel/qapplication_x11.cpp:3536
#24 0x00007fe5559f8252 in x11EventSourceDispatch (s=0x66da00, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#25 0x00007fe5522f7a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#26 0x00007fe5522f8270 in ?? () from /usr/lib64/libglib-2.0.so.0
#27 0x00007fe5522f8510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#28 0x00007fe5567d85ff in QEventDispatcherGlib::processEvents (this=0x616cf0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#29 0x00007fe5559f7eee in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#30 0x00007fe5567ace12 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#31 0x00007fe5567ad025 in QEventLoop::exec (this=0x7fffd9905ab0, flags=...) at kernel/qeventloop.cpp:201
#32 0x00007fe555e09d4e in QDialog::exec (this=0x9dd870) at dialogs/qdialog.cpp:552
#33 0x00007fe542205530 in ManageConnectionWidget::addClicked (this=0x8bb2e0) at /usr/src/debug/networkmanagement/settings/config/manageconnectionwidget.cpp:262
#34 0x00007fe5422040f4 in ManageConnectionWidget::qt_metacall (this=0x8bb2e0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd9905c80)
    at /usr/src/debug/networkmanagement/build/settings/config/moc_manageconnectionwidget.cpp:92
#35 0x00007fe5567c2b5f in QMetaObject::activate (sender=0x8a9a30, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffd9905c80) at kernel/qobject.cpp:3272
#36 0x00007fe555fc60c2 in QAbstractButton::clicked (this=<value optimized out>, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:206
#37 0x00007fe555d0a84b in QAbstractButtonPrivate::emitClicked (this=<value optimized out>) at widgets/qabstractbutton.cpp:546
#38 0x00007fe555d0be1b in QAbstractButtonPrivate::click (this=0x7f4d90) at widgets/qabstractbutton.cpp:539
#39 0x00007fe555d0c08c in QAbstractButton::mouseReleaseEvent (this=0x8a9a30, e=0x7fffd9906600) at widgets/qabstractbutton.cpp:1121
#40 0x00007fe5559a5678 in QWidget::event (this=0x8a9a30, event=0x7fffd9906600) at kernel/qwidget.cpp:8187
#41 0x00007fe555953f34 in QApplicationPrivate::notify_helper (this=0x669cb0, receiver=0x8a9a30, e=0x7fffd9906600) at kernel/qapplication.cpp:4396
#42 0x00007fe55595cbda in QApplication::notify (this=<value optimized out>, receiver=0x8a9a30, e=0x7fffd9906600) at kernel/qapplication.cpp:3959
#43 0x00007fe557439846 in KApplication::notify (this=0x7fffd99073a0, receiver=0x8a9a30, event=0x7fffd9906600) at /usr/src/debug/kdelibs-4.5.3/kdeui/kernel/kapplication.cpp:310
#44 0x00007fe5567ad9dc in QCoreApplication::notifyInternal (this=0x7fffd99073a0, receiver=0x8a9a30, event=0x7fffd9906600) at kernel/qcoreapplication.cpp:732
#45 0x00007fe555954f35 in sendEvent (receiver=0x8a9a30, event=0x7fffd9906600, alienWidget=0x8a9a30, nativeWidget=0x7a7ef0, buttonDown=0x7fe556429ef8, lastMouseReceiver=..., spontaneous=true)
    at ../../src/corelib/kernel/qcoreapplication.h:215
#46 QApplicationPrivate::sendMouseEvent (receiver=0x8a9a30, event=0x7fffd9906600, alienWidget=0x8a9a30, nativeWidget=0x7a7ef0, buttonDown=0x7fe556429ef8, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:3058
#47 0x00007fe5559d22e8 in QETWidget::translateMouseEvent (this=0x7a7ef0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4403
#48 0x00007fe5559d0a19 in QApplication::x11ProcessEvent (this=0x7fffd99073a0, event=0x7fffd9906f60) at kernel/qapplication_x11.cpp:3536
#49 0x00007fe5559f8252 in x11EventSourceDispatch (s=0x66da00, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#50 0x00007fe5522f7a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#51 0x00007fe5522f8270 in ?? () from /usr/lib64/libglib-2.0.so.0
#52 0x00007fe5522f8510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#53 0x00007fe5567d85ff in QEventDispatcherGlib::processEvents (this=0x616cf0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#54 0x00007fe5559f7eee in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#55 0x00007fe5567ace12 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#56 0x00007fe5567ad025 in QEventLoop::exec (this=0x7fffd9907280, flags=...) at kernel/qeventloop.cpp:201
#57 0x00007fe555e09d4e in QDialog::exec (this=0x7a7ef0) at dialogs/qdialog.cpp:552
#58 0x00007fe548870e3d in kdemain (_argc=6723408, _argv=0x7fffd9907590) at /usr/src/debug/kdebase-runtime-4.5.3/kcmshell/main.cpp:285
#59 0x0000000000407509 in _start ()
Comment 2 Lamarque V. Souza 2011-01-16 02:31:01 UTC
I have just commited some changes to fix this problem. Please "git pull" them and try again.
Comment 3 Lamarque V. Souza 2011-02-04 14:39:14 UTC
*** Bug 265372 has been marked as a duplicate of this bug. ***
Comment 4 Tamás Németh 2011-02-21 12:42:20 UTC
Created attachment 57415 [details]
Latest crash information

Finally I realized that not only the second connection is unable to be added, but even the first one if I use plasmoid network management instead of knetworkmanager. This is because knetworkmanager's own simplified connection dialog window works, whereas KDE's advanced connection wizard always crashes. Does the patch mentioned in https://bugs.kde.org/show_bug.cgi?id=256031#c2 really solve the problem? This symptom still persists in openSUSE 11.4 RC1 and http://download.opensuse.org/repositories/KDE:/Release:/46/openSUSE_11.3.
Comment 5 Tamás Németh 2011-02-21 13:32:45 UTC
(In reply to comment #2)
> I have just commited some changes to fix this problem. Please "git pull" them
> and try again.

Can you point out the patches solving this problem please? OpenSUSE 11.4 will
be shipped with KDE 4.6.0 but openSUSE developers are willing to incorporate
important patches: https://bugzilla.novell.com/show_bug.cgi?id=673755#c4
Comment 6 Lamarque V. Souza 2011-02-21 15:58:40 UTC
Have you really tried the lastest Plasma NM snapshot? The last crashlog you sent is exactly the same as the first one, which is not possible because in the latest snapshot I did several modifications that changed the line where the crash used to happen in the first crashlog.

Plasma NM is in constant modification, it is better use the latest snapshot than try to patch a single problem. Several important problems have been solved in the last months. Problems not only related to the connection wizard but connections problems, compilation problems and other crash problems.

Plasma NM is in KDE Extragear exactly because us developers need more freedom to do changes without a rigid schedule. It is not a good idea for OpenSuse to use a rigid schedule for Plasma NM as it seems the cause in the novell's bug entry you mentioned. Important changes and fixes are being added to Plasma NM all the time and that is going to continue for the time being. Plasma NM does not even have a release version because there is not any. There is only the snapshots.
Comment 7 Tamás Németh 2011-02-21 17:08:52 UTC
Created attachment 57419 [details]
New crashlog after updating

(In reply to comment #6)
> Have you really tried the lastest Plasma NM snapshot?

I still used the old version, indeed. However, now I upgraded to 0.9.1git20110127 but it still crashes at the same point.
Comment 8 Lamarque V. Souza 2011-03-19 21:30:16 UTC
*** Bug 268914 has been marked as a duplicate of this bug. ***
Comment 9 Roger Luedecke 2011-03-20 08:04:36 UTC
SO any idea on hiow to get my Mobile Broadband working again?

On Sat, Mar 19, 2011 at 1:30 PM, Lamarque V. Souza <lamarque@gmail.com>wrote:

> https://bugs.kde.org/show_bug.cgi?id=256031
>
>
> Lamarque V. Souza <lamarque@gmail.com> changed:
>
>           What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>                 CC|                            |roger.luedecke@gmail.com
>
>
>
>
> --- Comment #8 from Lamarque V. Souza <lamarque gmail com>  2011-03-19
> 21:30:16 ---
> *** Bug 268914 has been marked as a duplicate of this bug. ***
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
>
Comment 10 Lamarque V. Souza 2011-03-20 08:15:26 UTC
Upgrade to a newer version, you both are using a outdated version.
Comment 11 Roger Luedecke 2011-03-20 20:32:36 UTC
I updated broadband providers, what else do I need to update?

On Sun, Mar 20, 2011 at 12:15 AM, Lamarque V. Souza <lamarque@gmail.com>wrote:

> https://bugs.kde.org/show_bug.cgi?id=256031
>
>
>
>
>
> --- Comment #10 from Lamarque V. Souza <lamarque gmail com>  2011-03-20
> 08:15:26 ---
> Upgrade to a newer version, you both are using a outdated version.
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
>
Comment 12 Lamarque V. Souza 2011-03-20 20:51:22 UTC
You should upgrade Plasma NM (git://anongit.kde.org/networkmanagement), not broadband providers.

Some distributions call the Plasma NM package knetworkmanager, others networkmanager-kde. Plasma NM is in constant developement, unfortunately most distributions still keep releasing old Plasma NM packages with old bugs that have already been fixed in newer versions.
Comment 13 Lamarque V. Souza 2011-03-29 03:38:47 UTC
*** Bug 269647 has been marked as a duplicate of this bug. ***
Comment 14 Christoph Feck 2011-08-04 11:31:36 UTC
*** Bug 279362 has been marked as a duplicate of this bug. ***
Comment 15 Christoph Feck 2011-10-23 14:18:56 UTC
*** Bug 284784 has been marked as a duplicate of this bug. ***