Bug 256026 - networkmanagement (plasmoid) makes kded4 crash when resuming from suspend to disk
Summary: networkmanagement (plasmoid) makes kded4 crash when resuming from suspend to ...
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: KDED Module (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-04 10:16 UTC by S. Burmeister
Modified: 2010-11-08 23:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S. Burmeister 2010-11-04 10:16:59 UTC
Application: kded4 ($Id: kded.cpp 1156841 2010-07-29 19:59:05Z zander $)
KDE Platform Version: 4.5.3 (KDE 4.5.3) "release 8"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.5-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I was resuming from a suspend to disk when kded4 crashed because of networkmanagement. I am using the networkmanagement plasmoid.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KDE-Dienst (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0x00000000140c3058 in ?? ()
#7  0x00007f541a6ee7a9 in QMetaObject::cast (this=0x7f540039b940, obj=0x8daca0) at kernel/qmetaobject.cpp:266
#8  0x00007f540060b25a in qobject_cast<Knm::InterfaceConnection const*> (first=0x8daca0, second=0x6bf380) at /usr/include/QtCore/qobject.h:468
#9  activatableLessThan (first=0x8daca0, second=0x6bf380) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:184
#10 0x00007f540060bd53 in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., t=
    @0x75ba88, lessThan=0x7f540060b1f0 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:358
#11 0x00007f540060bba8 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:187
#12 SortedActivatableList::handleUpdate (this=<value optimized out>) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:105
#13 0x00007f54005fc5c3 in ActivatableList::activatableChanged (this=<value optimized out>) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:144
#14 0x00007f54005f8248 in ActivatableList::qt_metacall (this=0x7d8f20, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffdf020e50)
    at /usr/src/debug/networkmanagement/build/libs/service/moc_activatablelist.cpp:74
#15 0x00007f541a6fca1f in QMetaObject::activate (sender=0x817aa0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3295
#16 0x00007f540018ac31 in Knm::InterfaceConnection::setActivationState (this=0x817aa0, state=<value optimized out>) at /usr/src/debug/networkmanagement/libs/internals/interfaceconnection.cpp:82
#17 0x00007f54003d386d in NMDBusActiveConnectionProxy::~NMDBusActiveConnectionProxy (this=0x817960, __in_chrg=<value optimized out>)
    at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:58
#18 0x00007f54003d3899 in NMDBusActiveConnectionProxy::~NMDBusActiveConnectionProxy (this=0x817960, __in_chrg=<value optimized out>)
    at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:60
#19 0x00007f54003d5a97 in qDeleteAll<QHash<QString, NMDBusActiveConnectionProxy*>::const_iterator> (begin=<value optimized out>, end=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:322
#20 0x00007f54003d48a6 in qDeleteAll<QHash<QString, NMDBusActiveConnectionProxy*> > (this=<value optimized out>, status=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:330
#21 NMDBusActiveConnectionMonitor::networkingStatusChanged (this=<value optimized out>, status=<value optimized out>)
    at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:246
#22 0x00007f54003abd80 in NMDBusActiveConnectionMonitor::qt_metacall (this=0x8ae810, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffdf021020)
    at /usr/src/debug/networkmanagement/build/backends/NetworkManager/moc_nmdbusactiveconnectionmonitor.cpp:78
#23 0x00007f541a6fca1f in QMetaObject::activate (sender=0x88ce30, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffdf021020) at kernel/qobject.cpp:3295
#24 0x00007f54041824ce in Solid::Control::NetworkManager::Notifier::statusChanged (this=<value optimized out>, _t1=Solid::Networking::Unknown)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/libs/solid/control/networkmanager.moc:100
#25 0x00007f54041826e3 in Solid::Control::NetworkManager::Notifier::qt_metacall (this=0x88ce30, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffdf021180)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/libs/solid/control/networkmanager.moc:83
#26 0x00007f5404182ab0 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x88ce30, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffdf021180)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/libs/solid/control/networkmanager_p.moc:76
#27 0x00007f541a6fca1f in QMetaObject::activate (sender=0x896100, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffdf021180) at kernel/qobject.cpp:3295
#28 0x00007f5403d5eb4e in Solid::Control::Ifaces::NetworkManager::statusChanged (this=<value optimized out>, _t1=Solid::Networking::Unknown)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/libs/solid/control/ifaces/networkmanager.moc:108
#29 0x00007f53fb765dab in NMNetworkManager::qt_metacall (this=0x896100, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffdf0212e0)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/solid/networkmanager-0.7/manager.moc:97
#30 0x00007f541a6fca1f in QMetaObject::activate (sender=0x88d910, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffdf0212e0) at kernel/qobject.cpp:3295
#31 0x00007f53fb758b41 in OrgFreedesktopNetworkManagerInterface::StateChanged (this=<value optimized out>, _t1=1)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:176
#32 0x00007f53fb760fce in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x88d910, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x7fffdf021720)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:105
#33 0x00007f5417b2d188 in QDBusConnectionPrivate::deliverCall (this=0x87e430, object=0x88d910, msg=..., metaTypes=..., slotIdx=8) at qdbusintegrator.cpp:904
#34 0x00007f5417b39ecf in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:101
#35 0x00007f541a6fa509 in QObject::event (this=0x88d910, e=0x943210) at kernel/qobject.cpp:1248
#36 0x00007f54198bd4d4 in QApplicationPrivate::notify_helper (this=0x6c59b0, receiver=0x88d910, e=0x943210) at kernel/qapplication.cpp:4302
#37 0x00007f54198c5aca in QApplication::notify (this=<value optimized out>, receiver=0x88d910, e=0x943210) at kernel/qapplication.cpp:4185
#38 0x00007f541b34e7b6 in KApplication::notify (this=0x7fffdf022200, receiver=0x88d910, event=0x943210) at /usr/src/debug/kdelibs-4.5.3/kdeui/kernel/kapplication.cpp:310
#39 0x00007f541a6e8e4c in QCoreApplication::notifyInternal (this=0x7fffdf022200, receiver=0x88d910, event=0x943210) at kernel/qcoreapplication.cpp:726
#40 0x00007f541a6ec5ba in sendEvent (receiver=0x0, event_type=0, data=0x60f500) at kernel/qcoreapplication.h:215
#41 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60f500) at kernel/qcoreapplication.cpp:1367
#42 0x00007f541a711173 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#43 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#44 0x00007f5416272a93 in g_main_dispatch (context=0x6c7a30) at gmain.c:1960
#45 IA__g_main_context_dispatch (context=0x6c7a30) at gmain.c:2513
#46 0x00007f5416273270 in g_main_context_iterate (context=0x6c7a30, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2591
#47 0x00007f5416273510 in IA__g_main_context_iteration (context=0x6c7a30, may_block=1) at gmain.c:2654
#48 0x00007f541a71167f in QEventDispatcherGlib::processEvents (this=0x616ba0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#49 0x00007f541995e14e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#50 0x00007f541a6e8292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#51 0x00007f541a6e8495 in QEventLoop::exec (this=0x7fffdf022150, flags=...) at kernel/qeventloop.cpp:201
#52 0x00007f541a6ec88b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#53 0x00007f540a9e44a7 in kdemain (argc=1, argv=0x6a8880) at /usr/src/debug/kdelibs-4.5.3/kded/kded.cpp:894
#54 0x00000000004074a9 in launch (argc=1, _name=0x40b267 "kded4", args=<value optimized out>, cwd=0x0, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=
    false, startup_id_str=0x40b0f7 "0") at /usr/src/debug/kdelibs-4.5.3/kinit/kinit.cpp:723
#55 0x0000000000409cba in main (argc=4, argv=0x7fffdf0231f8, envp=0x7fffdf023220) at /usr/src/debug/kdelibs-4.5.3/kinit/kinit.cpp:1835

Reported using DrKonqi
Comment 1 Christoph Feck 2010-11-08 23:06:24 UTC

*** This bug has been marked as a duplicate of bug 210878 ***